1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

game stutters when limiting fps with rivatuner but not with inspector?

Discussion in 'Videocards - NVIDIA GeForce' started by alexander1986, Apr 26, 2018.

  1. alexander1986

    alexander1986 Active Member

    Messages:
    67
    Likes Received:
    1
    GPU:
    GTX 1060 6gb
    hey, messing around with a game and when I limit the fps to 120 in this game with nvidia inspector and framelimiter off ingame, its no stutter whatsoever but I can feel a input delay, compared to limiting to 120 fps with rivatuner SS and ingame limiter off,

    problem is with rivatuner the picture stutters, it comes and goes in waves basically, but the FPS counter stays the same, its weird and would like to fix the stutters because input-delay wise it feels a lot better this way, between the stuttering that is :D which kills it, tried also limiting with riva to my exact refresh rate, stuttering did not disappear,

    any tips? should I try some different prerender frame values or anything? thanks !
     
  2. -Tj-

    -Tj- Ancient Guru

    Messages:
    15,168
    Likes Received:
    648
    GPU:
    Zotac GTX980Ti OC
    More importantly, which game?
     
    alexander1986 likes this.
  3. alexander1986

    alexander1986 Active Member

    Messages:
    67
    Likes Received:
    1
    GPU:
    GTX 1060 6gb

    Fifa 18, if it matters I can select dx12 or dx11, and my exact refresh rate is 120.004 hz :D but I guess without vsync its not important ?


    also, downloaded latest nvidia inspector, and tested ingame frame limiter off + inspector frame limit 120 fps (Limiter V2 - Force Off [Enables Limiter V1 (Less Input Lag)] it seems to be called) + max prerender frames 1 in inspector + directx 12 feels pretty good, (directx11 stutters with this combination for example)

    but would still like to run rivatuner without stuttering !
     
    -Tj- likes this.
  4. alexander1986

    alexander1986 Active Member

    Messages:
    67
    Likes Received:
    1
    GPU:
    GTX 1060 6gb
    its frostbite engine btw in fifa 18, if anyone else has any tips also would be greatly appreciated! the input feeling is soo good with rtss but need to figure out how to remove the stuttering, preferrably without enabling vsync :p
     

  5. -Tj-

    -Tj- Ancient Guru

    Messages:
    15,168
    Likes Received:
    648
    GPU:
    Zotac GTX980Ti OC
    Ah ok, yeah I've read about these stutter issues in Fifa games, all the way back to Fifa16?

    I see few users reporting it time to time. Guess it comes and goes with certain gpu drivers.


    Try rtss 120fps + auto frames to render + fastsync, disable anything ingame.

    Maybe disable ingame AF and force in game profile + AF filter optimization (nvinspctor) enabled, texture quality - quality mode, threaded opt. - on.

    Ps if its frostbyte, does it have user.cfg file too like by BF3, BF4?

    RenderDevice.ForceRenderAheadLimit 1

    or disable any fps limiter and use build-in?
    GameTime.MaxVariableFps 120
     
    alexander1986 likes this.
  6. alexander1986

    alexander1986 Active Member

    Messages:
    67
    Likes Received:
    1
    GPU:
    GTX 1060 6gb

    will try these ones :p btw my true refreshrate is 120.004 hz exactly (lightboost) does this matter in this case?


    it does have cfg file and command line option from launcher but very limited options there, they are like 3-4 options from the launcher and language select basically, almost positive you cant
    use those commands you mentioned, not sure tho,


    but I will try your combinations and see if I can get stutter-free RTSS 120 fps without vsync, that is my goal :D


    Interestingly, I got very good results now with dx12 + pre render frames 1 + inspector 120 fps Limiter V2 - Force Off [Enables Limiter V1 (Less Input Lag)] (its an option in latest inspector version I think)

    It stutters just a little bit at start of a game then more or less disappears completely after that, but RTSS still feels like lowest input lag, just gotta find way to remove stutter :D


    tweaking continues....
     
  7. -Tj-

    -Tj- Ancient Guru

    Messages:
    15,168
    Likes Received:
    648
    GPU:
    Zotac GTX980Ti OC
    I have 144HZ monitor and some games read is as 143.981HZ and 144fps limit works just fine.


    Maybe its some sort game engine and rtss issue in dx12? You use the latest MSI AB? Or maybe try stealth mode, or custom 3d or both, and hide OSD or try different OSD mode, raster 3d instead of vector 3d.
     
    alexander1986 likes this.
  8. alexander1986

    alexander1986 Active Member

    Messages:
    67
    Likes Received:
    1
    GPU:
    GTX 1060 6gb

    after some more tweaking and looking at this picture also:


    [​IMG]


    I turned off lightboost and went back to 144hz, vsync on, 143.000 fps limit RTSS (my monitor gives exactly 144.000 hz in refreshtest) and it feels very good+ zero stutter, veeery slight motion blur at super fast movement because no more lightboost, but worth it because of no stutter :D will probably give up on RTSS 120 fps no vsync for now :/


    but looking at above picture, would you recommend 143.000 fps rtss / 144 hz + vsync on and max prerender 1 (this feels best out of everything i've tested so far) or 143.993 / 143.990 fps limit in rtss? what is best/lowest input lag in theory? is there really any big difference between say 143.993 and 143.000 ?
     
  9. -Tj-

    -Tj- Ancient Guru

    Messages:
    15,168
    Likes Received:
    648
    GPU:
    Zotac GTX980Ti OC
    I have Samsung C24FG73 native 144HZ, + extra Samsung's own lightboost if I want, its not bound to 120HZ, but I don't use it much, it makes backlight strobe flicker, not visible but could get irritating by desktop mode.

    Went form 60 to 144HZ recently and its like night and day.. Couldn't believe there is no vsync stutter if it dropps bellow 144Hz unlike by 60 down into 50-55fps.. But when fps dropped to similar 55fps it looked the same as on 60HZ jitter/stutter


    That said, you can try 141fps limit + vsync, 1frame
     

Share This Page