G73JH Video card failing to Accept driver BSOD

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by passwerdz, Apr 10, 2013.

  1. passwerdz

    passwerdz New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    ATI (Radeon) HD 5870
    Total Memory Size 8GB
    Memory Type DDR3
    Memory Slots (Total) 2
    Memory Slots (Available) None
    Maximum Memory Supported 8GB
    Memory Configuration 4GB + 4GB

    Processor Brand Intel
    Processor Class Core i7
    Processor Type Quad-Core
    Processor Speed 1.6GHz
    Processor Number i7-720QM

    Operating System Windows 7 Ultimate


    Graphics Description Dedicated Graphics
    GPU/VPU ATI Mobility Radeon HD 5870
    Video Memory 1GB GDDR5 discrete graphics memory


    Whats up all I was wondering if I could get a bit of assistance with the installation of my drivers. Yesterday I was playing Bioshock?, Well through the beginning of the game I was doing fine all of a sudden I saw a BSOD I thought nothing of it since all it did in the begging was reboot itself, once the laptop rebooted for some reason my ATI drivers wasn't functioning looks like I was in safe mode, like it has got corrupted somehow. Well I went ahead and updated my BIOS from 211 to 213. I also downloaded chastity's VBIOS od2.rom I followed all the directions to a ''T'' when trying to flash I had received a error ATIFLASH -P O -F Fix_od2.rom adapter not found Error 0FL01 press 1 to continue? Can someone please explain to me what in the world is going on?
     
    Last edited: Apr 10, 2013
  2. TheOriginalTO

    TheOriginalTO Master Guru

    Messages:
    287
    Likes Received:
    0
    GPU:
    ATI 5870m
  3. passwerdz

    passwerdz New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    ATI (Radeon) HD 5870
    Yes I tried registering to that site but for some reason it doesn't allow me to register?
     
  4. hulawafu77

    hulawafu77 Member Guru

    Messages:
    191
    Likes Received:
    0
    GPU:
    7970M
    The vBIOS for that AMD will be broken forever since Asus are the ballsack derps when it comes to performance laptops. Just learn from this lesson, don't buy Asus in the future. Since G73JH, they have not been up to par with their competition and price in the same category, it's pathetic. Actually for that matter, just avoid AMD for mobile, AMD doesn't give a crap.

    Usually when someone says AMD driver support blows, guess you can find plenty of reasons why Nvidia is just as bad. For mobile, not really, AMD really is inferior for driver support. Really really sucks. I mean really really really suck. REALLY REALLY REALLY sucks. I had the G73JH and the 5870M was a nightmare. I thought maybe that was a fluke, nope, 7970M has been a real pain since day 1. And no signs of changing, it's terrible.
     
    Last edited: Apr 10, 2013

  5. TheOriginalTO

    TheOriginalTO Master Guru

    Messages:
    287
    Likes Received:
    0
    GPU:
    ATI 5870m
    Well, I've never seen of his error before. I have the G73JH and all of my stuff is up to date with no problems. This laptop is a real power machine. Did you have drivers installed at the time when you were trying to flash the Vbios? Install the 8.68 version that is stock on the laptop and then try to flash it.
     
  6. hulawafu77

    hulawafu77 Member Guru

    Messages:
    191
    Likes Received:
    0
    GPU:
    7970M
    Yes... I was the second person on NBR to have the notebook and the first to do a guide on how to unlock OverDrive for the G73JH. I was well versed with the notebook.

    The G73JH 5870M was broken from the start and broken still today. The voltage settings are at the hardware level. Believe that was the culprit for why the memory settings on that were broken. The official BIOS from Asus, even after the GSOD supposed fixes (lots of users continued to have them), the memory clock speeds were always fixed at 1100... So it may change from 850 down to 300 or whatever the core speeds were, this was because EVERYTIME the memory downclocked or back to normal, your screen would flicker. If you did have it dynamic, then if you ran a program like Steam, OMG, it's a real mess, will flicker back and forth, back and forth. The only solution was to assign hotkeys and force it into high performance and then force it into low power modes.

    G73JH 5870M sucked balls, in comparison to what Clevo, Alienware and MSI had. It's was a POS trash.
     
  7. TheOriginalTO

    TheOriginalTO Master Guru

    Messages:
    287
    Likes Received:
    0
    GPU:
    ATI 5870m
    Well, I'm sorry to hear that your experience was not great with it, but mine is just smooth and beautiful. All games run like butter and given that the machine is dated technology wise, I'm cool with that.
     
  8. volkov956

    volkov956 Ancient Guru

    Messages:
    6,095
    Likes Received:
    0
    GPU:
    GTX 1080 TI
    use the unofficial bios fix is what I have done for asus 5870m models
     
  9. passwerdz

    passwerdz New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    ATI (Radeon) HD 5870
    Thank you for the response. I have a day off work today, I basically stood up all night trying to figure this out. I still haven't a clue on what is going on. Like I stated I was playing Bioshock for maybe 20 min my computer just shut down with BSOD I didn't even have a chance to write down or take a picture of the screen laptop just rebooted on it's own. I figured the reason why I got BSOD is because my BIOS and VBIOS needs to be updated to play the game so that is what exactly I tried to do I had success updating my BIOS, But not the VBIOS. tried different methods of searching for the card using all the commands possible I still got a no adapter found. Yes I typed everything in correctly that was a typo I apologize. Here is a screenshot of gpu-z. I am running drivers from Microsoft I tried overriding the driver I get a message stating ''Windows found driver software for your device but encountered an error while attempting to install it''

    I never had a problem with my Asus up until now, I believe it was human error not the fault of the PC. can I manipulate the Error.. no, I wouldn't know where to start I am using the pc right now so I'm not sure if I am bricked or what is going on? I know that windows is not reading the card correctly. I am using a standard VGA driver to support the Video card as of right now so it does turn on and function i have video and all except the driver for the card. Here is a screenshot in gpu-z

    [​IMG] This is what I get from GPU-Z
     
  10. hulawafu77

    hulawafu77 Member Guru

    Messages:
    191
    Likes Received:
    0
    GPU:
    7970M
    ROFL, there is no unofficial BIOS fix. It's the official BIOS with the overdrive unlocked that I had wrote a tut for before with a slightly different clock speeds. But it still has the same issues as the original BIOS.

    What makes it hilarious is that Asus knew the 5870M sucked. They never bothered to finish fixing the vBIOS issues, cause that would have meant they would have to do a recall of all the G73JH. And since the G73JH, Asus has not had an AMD GPU. ROFL, they released two Nvidia flavors of the G73 in quick succession and ignore the JH issues. Some JH owners were lucky enough to be able to return and get G73JW/SW replacements.

    I also think it's hilarious that some of you are happy your 5870M doesn't function as it's supposed to like it does with Alienware, MSI and Clevo. But great, happy you are able to use your broken 5870M on games but not enjoy all the other features that are expected in a notebook solution.
    - Oh that also means MSI, Alienware, Clevo HD5870M and HD5850M will outperform an Asus 5870M. Alienware M15X with HD5850M annihilate the broken Asus HD5870M, oh and runs cooler and whole lot more battery life. More of everything.

    This is also due to Asus being the cheapskates. They use cheap fabrication to make their boards, including the latest. Some are so stupid, that they integrated it onto the main board, ridiculous. Alienware, MSI and Clevo all use boards made by AMD/Nvidia with vBIOS that function properly, but not Asus, they are special. Also means even the latest generation of Asus machines underperform, don't have the features that are expected in notebooks, and not upgradable. Asus performance notebook solutions suck hard.

    Sorry if the impression for others reading, but Asus performance notebok solutions for AMD and Nvidia both suck equally, it's not just AMD. Whether it's red or green, it sucks compared to the competition.
     
    Last edited: Apr 11, 2013

  11. TheOriginalTO

    TheOriginalTO Master Guru

    Messages:
    287
    Likes Received:
    0
    GPU:
    ATI 5870m
    Dude, what is your problem with this video card?? I am getting 60+ fps in everything i play with full ultra graphics...
     
  12. volkov956

    volkov956 Ancient Guru

    Messages:
    6,095
    Likes Received:
    0
    GPU:
    GTX 1080 TI
    Last edited: Apr 11, 2013
  13. Espionage724

    Espionage724 Guest

    Probably just another case of improper-setup on the user's end and that user blaming something totally unrelated because that's all they know :cool:

    Na but I have no idea really (although I have seen the above plenty of times). If you two have the same graphics card, and if your experience is true... then drivers is the last thing I would assume to be the issue.
     
  14. magus

    magus New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Mobility Radeon 5870
    Well after reading this thread, I hope my 5870 works because I am waiting for a g73jh rbbx05 I bought off ebay. I hope it's not a pain to set up the graphics card and that it works well. We'll see.
     
  15. passwerdz

    passwerdz New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    ATI (Radeon) HD 5870
    I already tried updating the Vbios, I am getting adapter not found That is why I updated the Bios to 213 from 211, The Vbios is not finding The card.

    I am hoping I don't have to jump the Vbios chip from 3 to 8 that will suck or maybe having to flash a new vbios chip.
     
    Last edited: Apr 11, 2013

  16. hulawafu77

    hulawafu77 Member Guru

    Messages:
    191
    Likes Received:
    0
    GPU:
    7970M
    Mostly because you don't get 60 FPS on everything you play on full ultra graphcs, rofl. Simply not possible, even a desktop HD5770 overclocked to hell, which is what your 5870M is based on doesn't get 60 FPS on full ultra on everything. Even I don't, and my 7970M is quite literally twice the power of yours. But nice try at bragging.

    Yes go ahead, make assumptions. And not take into account that 3 years later, on NBR Asus forum, the most talked about issue is still the junk Asus 5870M. And that's not from me, I kissed that piece of garbage good bye. And said hello to this awesomeness, bought this junk before I realized how crap Enduro is.

    Without Enduro, it's not too shabby. Still not as good as a 680M, not even close. 680M still runs cooler, more power efficient, has less driver issues, doesn't have DX11 artifacts on AMD title games like 7970M does (the irony is not overlooked), and of course the frame latency issues. Overall better performance, and overclocks better than any mobile GPU I've read about so far, it's truly a monster. 7970M is a whimpering corgi that someone has been kicking it in the nuts.

    The best solution if you run into issues is force flash a Clevo vBIOS on it, but that means you won't have HDMI output. Either have that or have stable performance and 5870M performing as close to as it's supposed to.

    You also realize you bought the Best Buy version right? That one comes with less HDD space (not a big deal, can upgrade to an SSD and a second large storage HDD), and it comes with an inferior, lower res panel. If you want a nice panel, you want to look for a matte AUO that is compatibile with G73JH. AUO makes the best panel for G73JH, the LG one is second best if you can them find.

    I really hope you only paid $300 for that. Sager was selling the P150EM with a 680M for $1500 for months. Best deal I've ever seen for a mobile rig.
     
    Last edited: Apr 11, 2013
  17. passwerdz

    passwerdz New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    ATI (Radeon) HD 5870
    Hmm seems that the problem was corrected I took the laptop apart repasted the GPU and reseated the card took the battery off then downgraded my BIOS and upgraded again.

    [​IMG]
     
  18. Espionage724

    Espionage724 Guest

    Glad you appear to of fixed your issue :) Unrelated, but I'd recommend updating GPU-Z at some point, I think the latest version is like 0.7.9 or something :p
     
  19. passwerdz

    passwerdz New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    ATI (Radeon) HD 5870
    Took me 3 days I found the culprit to what was going on. basically a couple of inf files in system32 what belongs to a program called motion-joy, it allows you to connect your ps3 controller to your pc I deleted all the inf files associated to motion joy, and wha-la everything is back to normal.
     

Share This Page