1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

G-Sync.... need some insights

Discussion in 'Videocards - NVIDIA GeForce' started by robtorbay, Aug 21, 2018.

  1. robtorbay

    robtorbay Master Guru

    Messages:
    220
    Likes Received:
    6
    GPU:
    EVGA GTX 980ti SLI
    Hey all! Recently purchased a G-Sync screen and did some research to make sure I was using the feature correctly (and maybe I am not...). So I went into the Nvidia settings and enabled G-Sync and then in the game disabled VSYNC.

    For the most part I dont see any tearing but there tends to be some tearing now and then in games like wow.

    Is this normal or am I missing something? I just assumed this tech was suppose to be flawless from the reading that I have done. That said, other than saving a few MS on response time which I dont really care about I kinda wish I had to of saved the cash and just got a screen and enabled VSYNC because I dont really see much benefit from when I used a regular monitor and VSYNC.

    Video card setup is 980ti * 2 in SLI which is what I am assuming the issue is stemming from?

    Thanks in advanced!
     
  2. JaxMacFL

    JaxMacFL Ancient Guru

    Messages:
    1,535
    Likes Received:
    667
    GPU:
    Jedi Titan XP
    Turn on vsync in Nvidia control panel.
     
  3. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,302
    Likes Received:
    815
    GPU:
    1080Ti H20
    You have to enable Vsync in NVCPL to enable perfect synchronization of frames with the monitor.
    Also setup a FPS limit as gsync does not work at its max refresh rate.
     
    Last edited: Aug 22, 2018
  4. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    2,045
    Likes Received:
    1,006
    GPU:
    GTX 1080Ti
    What is your screens refresh rate? As others suggested turn on Vsync in your Global profile of Nvidia control panel. Via RivaTuner set global FPS cap to -3 fps from your screens Refresh rate.

    Example: if your screen is 144hz, set it to 141fps.

    Alternatively, you can use Nvidia Inspector for FPS limitation (but apparently it causes higher input lag).
     

  5. RealNC

    RealNC Ancient Guru

    Messages:
    2,498
    Likes Received:
    737
    GPU:
    EVGA GTX 980 Ti FTW
    As others pointed out, the "vsync" setting in the nvidia panel does something different when using g-sync. It enables frame time variance compensation. Whenever you change the g-sync setting, the vsync setting is automatically reset to "application preference". You need to go back and set it to "on".

    Also make sure to cap your FPS to -3FPS below your maximum refresh rate, in order to avoid g-sync starting to behave like vsync, as it does when FPS gets very near the maximum refresh rate.

    The latency difference is huge, not just "a few ms." It virtually matches vsync OFF latency. And you also gain FPS independence. Your FPS does not have to match your refresh rate anymore, or be an even fraction of it. You can play at any frame rate you want without getting judder.

    With that being said, you mentioned you play WoW, which AFAIK only supports windowed mode from now on, and g-sync still has some issues in windowed g-sync mode in Windows 10 1803, even with the latest hotfix.

    No experience here with SLI g-sync. Could be problematic, I don't know.

    More about configuration, frame capping, tests, etc, can be found in this 14-part article:

    https://www.blurbusters.com/gsync/gsync101-input-lag-tests-and-settings
     
  6. Dragam1337

    Dragam1337 Master Guru

    Messages:
    793
    Likes Received:
    299
    GPU:
    1080 Gaming X SLI
    Wow now only runs in windowed mode... meaning that you have to specifically choose g-sync for windowed mode, otherwise it won't work.

    It has nothing to do with the sli + gsync combo.
     
  7. Dragam1337

    Dragam1337 Master Guru

    Messages:
    793
    Likes Received:
    299
    GPU:
    1080 Gaming X SLI
    The only game that exhibits issues with sli + gsync is battlefront 2, haven't experienced issues with any other games.
     
  8. robtorbay

    robtorbay Master Guru

    Messages:
    220
    Likes Received:
    6
    GPU:
    EVGA GTX 980ti SLI
    Well these are some interesting feedback notes! Thanks mates! Seems to have resolved my issues!
     
    fluidz likes this.
  9. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    2,045
    Likes Received:
    1,006
    GPU:
    GTX 1080Ti
    It's not "seems", if you do everything correctly it Just Works!
     
  10. Dragam1337

    Dragam1337 Master Guru

    Messages:
    793
    Likes Received:
    299
    GPU:
    1080 Gaming X SLI
    With a few exceptions ;)
     

  11. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    2,045
    Likes Received:
    1,006
    GPU:
    GTX 1080Ti
    and those are?
     
  12. Netherwind

    Netherwind Ancient Guru

    Messages:
    5,865
    Likes Received:
    412
    GPU:
    MSI 1080Ti Gaming X
    How can I tell? I've played WoW at 94Hz (limit enabled) and 95Hz (limit disbled) and cannot feel the difference. I guess I must try again.
     
  13. Dragam1337

    Dragam1337 Master Guru

    Messages:
    793
    Likes Received:
    299
    GPU:
    1080 Gaming X SLI
    Battlefront 2 doesn't work very well sli + g-sync... performance is significantly better without it.

    Several games which only runs in windowed mode doesn't run very well with g-sync - wow among them.
     
  14. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    2,045
    Likes Received:
    1,006
    GPU:
    GTX 1080Ti
    That's an SLI issue, not the settings.

    That's why you enable Gsync for Windowed + Fullscreen mode. If you get lag, you simply alt-tab in and out of the game. It used to be all over the place back in the day, now it's much better but still sadly exists.

    But then again, it's not related to settings.
     
    fantaskarsef likes this.
  15. RealNC

    RealNC Ancient Guru

    Messages:
    2,498
    Likes Received:
    737
    GPU:
    EVGA GTX 980 Ti FTW
    A 95Hz monitor? Is that a thing?
     

  16. Dragam1337

    Dragam1337 Master Guru

    Messages:
    793
    Likes Received:
    299
    GPU:
    1080 Gaming X SLI
    No, the game works perfectly with just sli.

    You keep ranting about settings... who the fack mentioned settings? It has to do with g-sync and quirks / bugs related to it. G-sync in windowed mode is still far from optimal.
     
  17. adabiviak

    adabiviak Master Guru

    Messages:
    753
    Likes Received:
    14
    GPU:
    Gigabyte GTX 980Ti
    Interesting... I definitely noticed some hideous judder in 1803 (but it's smooth sailing in 1709 for me, which is why I went back).

    In 1803 or all? In 1709, it's fine in windowed mode.

    I don't, however, use a frame limiter... is the only option for this is a distinct piece of software (or is there a way in the nVidia driver/GeForce Experience to do it)? If it is extra software, what's recommended? nVidia Inspector?
     
  18. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    9,166
    Likes Received:
    1,411
    GPU:
    1080Ti @h2o
    There are options to limit FPS that way (driver, inspector), but afaik they're inferior to RTSS (which is installed along with Afterburner)
     
  19. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,302
    Likes Received:
    815
    GPU:
    1080Ti H20
    I assume you have a 100hz monitor because I've never seen a 95hz one.

    Anyways if it does exist, you are to close to the ceiling.

    Use FPS Limit set to -3 fps of the refresh rate to be safe.
     
  20. RealNC

    RealNC Ancient Guru

    Messages:
    2,498
    Likes Received:
    737
    GPU:
    EVGA GTX 980 Ti FTW
    It seems to be a 1803 issue from what I've seen. I'm on 1709 and have zero issues with windowed mode g-sync, and it's one of the reasons I'm not upgrading to 1803.

    The latest hotfix driver claimed to have fixed the issue, but from what I've seen, people report it still just doesn't work correctly.

    Another area g-sync can be glitchy in is multi-monitor support. If you've got more than one monitor, there's a good chance you'll get stutter, judder, and general frame pacing issues.

    So yeah, it's not perfect in some use cases. But if you're on Windows 10 1709, only have 1 monitor, and only have 1 GPU, then it really is excellent, and it's working in an invisible manner where it just makes things feel and look "as they should." You don't notice it's there, since VRR is a tech that removes defects, it doesn't add things for you to point at and notice. As soon as you disable it, you realize it's not a good experience to keep it disabled.
     
    Last edited: Aug 22, 2018

Share This Page