G-Sync + In-game V-Sync OR Control Panel V-sync?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by BlindBison, Oct 14, 2020.

  1. squalles

    squalles Master Guru

    Messages:
    852
    Likes Received:
    47
    GPU:
    Galax GTX 1080 EXOC
    i don´t know why but if i enable vsync even with same 3 fps cap below my refresh rate and gsync on, i´m have higher input lag, its easily perceptive on games like pes 2020 and cs, i´m always using latency mode on ultra too and its feels better to me
     
  2. janos666

    janos666 Maha Guru

    Messages:
    1,024
    Likes Received:
    168
    GPU:
    MSI RTX3080 10Gb
    I am not sure if G-Sync Compatible was ever validated for V-Sync + fps cap scenarios nearly as rigorously as module based G-Sync.
    I always see some tearing close to the bottom of the screen with V-Sync off. It virtually disappears at very low fps caps but I think it's still there for some degree (just not visible anymore to the naked eye). They say module based G-Sync is fine without V-Sync as low as -2 fps below the max refresh rate. Although most people probably doesn't test for tearing nearly as rigorously as I did.
    So Compatible displays might be loose with their timing and need V-Sync more often for small corrections. But removing that tear line from the bottom of the screen presumably needs VERY little sync delays (something like 1 ms or so, not a whole refresh rate cycle time, so you should be able to feel it, not even 1000 fps cameras will catch this easily because it's close to their sampling "noise floor").
     
    BlindBison likes this.
  3. jorj02

    jorj02 Member

    Messages:
    15
    Likes Received:
    2
    GPU:
    8 gb ram
    u can try little trick on gsync this one give me the most smooth gaming experience i ever had the problem frame rate limiter v3 not work for many games

    for ow is fine

    144hz do 138 fps 180hz do 171 fps 240hz do 234 fps


    [​IMG]
     
  4. aufkrawall2

    aufkrawall2 Master Guru

    Messages:
    783
    Likes Received:
    113
    GPU:
    6800 reference UV
    When you turn on vsync in many (any?) Vulkan application, it actually behaves like fifo_relaxed with Nvidia on Windows, i.e. there is tearing with frame times below refresh rate. When forcing via driver, it's regular fifo. A really weird mess.
     

  5. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,705
    Likes Received:
    1,563
    GPU:
    MSI 3080 Gaming X
    Wish there was a standard way for such things. I've read about tons of different variations but the one that does stand out more than others is G-Sync & V-sync ON in NVCPL. Also there is talk about frame cap at least 4 frames below refresh rate. Though then there's the discussion where you should enforce this limit? In MSI AB? NVCPL? In-game? The third option would be the worst since not all games have frame limiters.
     
  6. aufkrawall2

    aufkrawall2 Master Guru

    Messages:
    783
    Likes Received:
    113
    GPU:
    6800 reference UV
    Blurbusters pointed out the most important: Using vsync with VRR does not increase lag when you stay within VRR range, and that's what the fps limiters are for. Even limiting 1fps below maximum refresh rate can be enough to have decent latency, e.g. ULL ultra + Gsync does this in DX11 with 60Hz. That's basically it. With DX12/Vulkan in-game limiters can still give a substantially more direct result, as they can limit CPU prerender, whereas the driver can't.
     
    BlindBison likes this.
  7. janos666

    janos666 Maha Guru

    Messages:
    1,024
    Likes Received:
    168
    GPU:
    MSI RTX3080 10Gb
    IMO, V-Sync occasionally increases the latency by a tiny bit. That's how it removes that sporadically appearing tear line from the bottom of the screen. But we are talking about something like 1 ms or so, not nearly close to the avergae frame-time. It's probably not even consistently measurable by ~ 1000 Hz sampling rate sensors (like those 980 or something fps cameras in enthusiast sport equipments and some Samsung Note devices).

    On the other hand, most external limiters add measurable latency, something close to 1 frame (I guess it fluctuates between ~0 and ~1, depending on how things play out with all other factors at play in a complex system).
    But in-game limiters should not add any lag (however, I doubt anybody tested all games thoroughly).

    The important part is that V-Sync should be turned on for G-Sync and a limiter must be used for the optimal result (the theoretical perfect setup is a lagfree in-game limiter but an external is still better than nothing).
     
    BlindBison likes this.
  8. BlindBison

    BlindBison Master Guru

    Messages:
    663
    Likes Received:
    118
    GPU:
    RTX 2080 Super
    UPDATE: I've reproduced something very interesting in Metro Exodus Enhanced Edition (DX12 / Requires raytracing hardware to play the enhanced version, that one).

    I noticed with G-Sync the title was microstuttering quite a lot on my rig (3900X + 2080 S + 32 GB 2933 MHz RAM + NVMe SSD). I was using G-Sync ON + Control Panel V-Sync ON + FPS limit of 140 on my 144 Hz panel (though I never get close to reaching that as the game is quite heavy and I want that sweet raytraced quality). I'm basically maxing out the game, but using DLSS in Quality mode (1440p monitor resolution).

    Anyway, I'm at the part of the game where you get the crossbow and I noticed when I overlook a particular area of the game/the forest that the FPS tanks and the game microstutters hard. This does not happen if I use G-Sync ON + In-game V-Sync FULL with Control Panel V-Sync set to "Let the 3D app decice".

    So, I reproduced this using a quick save then swapped between the two modes. Now, interestingly the Full V-Sync mode in-game does appear to cap the game to 60 FPS I noticed, but for this section that's not relevant as framerates tanked down to the low 40s on this overlook with the control panel v-sync ON way. With the in-game V-Sync FULL way instead, my FPS were low 50s instead and the microstutter smoothed right out.

    I tested this back to back a couple times with the same result. Definitely not a result I expected to see, but this has kinda pushed me over the edge to maybe just trying the default control panel settings with V-Sync on in-game. Has anyone else seen this occur in other titles? Could it be DX12/Vulkan related? Thanks!
     
    Last edited: May 28, 2021
  9. AsiJu

    AsiJu Ancient Guru

    Messages:
    7,210
    Likes Received:
    2,169
    GPU:
    MSI 6800XT GamingX
    What happens if you have CPL Vsync On / ingame Off but use a lower framerate cap that you can consistently reach?

    Framerate limiter only helps with frame pacing if it's active and even frametimes help with Gsync as well, the more frametimes fluctuate the more display needs to do "adjusting".

    Anyway, I have had one case where ingame Vsync had to be enabled for Gsync to work at all, Surge 2 (Vulkan).
    So results can vary from game to game.

    Having said that Metro EEE doesn't have any perceivable microstutter for me, with or without fps cap, but I haven't played it extensively yet, just tried bits from beginning of various chapters to see how they run.
    I did start a new playthrough but I'm still in early Moscow level.

    EDIT: forgot to ask, do you have Low Latency Mode set to enabled or ultra? Try setting to Off if enabled or vice versa.
    The setting shouldn't have any effect on DX12/Vulkan but something to try.
    Pre-render queue depth and frame delivery timing is controlled by the games with low level APIs as far as I know.

    IIRC had set LLM to Ultra globally and didn't have to change the setting for Metro.
     
    Last edited: May 27, 2021
    BlindBison likes this.
  10. TAGTRAUM

    TAGTRAUM Member

    Messages:
    10
    Likes Received:
    4
    GPU:
    Aorus Xtrere 3080
    For my hardware (3080+11900K+980PRO+32GB Gear1 CL14+470.25 Driver) i must play with ULLM, Vsync NVCP or in-game and couple other settings, i haven't any guaranteed standardized options for any game. But in every game disabling ULLM is a must, also GPU scheduling and ReBar is off by default, with this options ON i have stutterfest no matter what settings i've done
     
    BlindBison likes this.

  11. BlindBison

    BlindBison Master Guru

    Messages:
    663
    Likes Received:
    118
    GPU:
    RTX 2080 Super
    Is it the GPU scheduling causing the stuttering for you or ReBar? Or both? My hardware doesn't support ReBar, but I could test Metro with GPU scheduling on vs off.
     
  12. BlindBison

    BlindBison Master Guru

    Messages:
    663
    Likes Received:
    118
    GPU:
    RTX 2080 Super
    I don't use the ULLM modes typically/i'm not using them in metro EE, but I could try disabling hardware accelerated GPU scheduling -- based on the tests I've seen it doesn't do much of anything at this time anyway.

    I tried an FPS cap with the control panel v-sync config, but not the in-game v-sync config. I'll test it some more after work. With the control panel v-sync config the game would run smoothly, but stutter very hard if it dipped even slightly beneath the cap. This does not occur if I'm reaching the "60" in engine limit which turns itself ON when v-sync FULL is active then it slightly dips below that. It's strange, but it has been my observation that certain games don't really like external FPS limiters for whatever reason. Still, I have not tried those external ones with the in-game v-sync option ON + g-sync ON + control panel v-sync set to "let 3d app decide" so i'll give it a go again.
     
  13. RealNC

    RealNC Ancient Guru

    Messages:
    3,363
    Likes Received:
    1,559
    GPU:
    EVGA GTX 980 Ti FTW
    There's always exceptions. This is a game that does something when in-game vsync is turned on that results in better performance. And there's games that run better with in-game vsync turned off (Fallout 4 is the prime example.)

    ¯\_(ツ)_/¯
     
    BlindBison and AsiJu like this.
  14. AsiJu

    AsiJu Ancient Guru

    Messages:
    7,210
    Likes Received:
    2,169
    GPU:
    MSI 6800XT GamingX
    Yeah turn off HAGS, chances are that's the culprit or part of the problem.

    Ofc you can also try vsync off both in nv cpl and ingame, Gsync on, cap to slightly below your VRR ceiling.

    Experiment.
     
    BlindBison likes this.
  15. TAGTRAUM

    TAGTRAUM Member

    Messages:
    10
    Likes Received:
    4
    GPU:
    Aorus Xtrere 3080
    I've turned off both, with rebar and supported game - AC Valhalla for example - i haven't seen any improvement, with added gpu scheduling ON - it become stutter all the way, so bigger "evil" i suppose is HAGS, but rebar even in full compatible system and latest hardware does nothing (also i'm playing on LG OLED 48CX in full HDMI 2.1), so even with overkill setup those options doesn't add anything, i have also Z390+9900KS+3080+32GB and on that system even with recently added rebar support, i have same stutterfest with options ON rather all the options OFF
     
    BlindBison likes this.

  16. BlindBison

    BlindBison Master Guru

    Messages:
    663
    Likes Received:
    118
    GPU:
    RTX 2080 Super
    It's really bizarre to me that Hardware Accelerated GPU scheduling would cause stuttering -- isn't is "supposed" to improve things? Why even have it otherwise? Or, is the issue that GPU scheduling screws with the way games pre-render on the CPU side? I don't really understand how it works to be frank.

    I turned the setting ON then OFF with reboots in between and didn't notice a discernible difference in my test area in Metro (for the other thing I was testing the difference was apparent though). I remember when the feature came out Gamer's Nexus did some tests for it and basically found almost no difference at all which made me wonder if it was some kind of "white list" thing where only certain titles which were approved had a change or some such, but I'm totally speculating.

    That was sometime back though so I've got no idea how much has changed since then. I'll need to test out the HAGS ON vs OFF in a couple CPU heavy titles I'd imagine. I mean, perhaps there was a difference that i'm just not capable of perceiving for my run, but I don't wanna get trick myself into placebo either haha.
     
  17. BlindBison

    BlindBison Master Guru

    Messages:
    663
    Likes Received:
    118
    GPU:
    RTX 2080 Super
    Thanks! That's really interesting for Fallout 4 -- iirc that game’s DX11.
     
    Last edited: May 28, 2021
  18. AsiJu

    AsiJu Ancient Guru

    Messages:
    7,210
    Likes Received:
    2,169
    GPU:
    MSI 6800XT GamingX
    It's an experimental feature atm and as such has issues.
    Besides afaik it may help in cpu limited scenarios and/or lower system latency but doubt it would be beneficial for frame pacing or against microstuttering in general.

    AMD drivers don't even support HAGS yet.
    What little I tried with NV gpu saw no benefit performance, frame pacing or latencywise whatsoever.
    Actually LatencyMon reported slightly higher latencies on average with HAGS enabled - which could be a bug or an error but in any case HAGS didn't reduce system latency, for me.

    YMMV but before HAGS is mature enough I'd say the first thing to turn off when facing issues.
     
    Last edited: May 28, 2021
    BlindBison likes this.
  19. BlindBison

    BlindBison Master Guru

    Messages:
    663
    Likes Received:
    118
    GPU:
    RTX 2080 Super
    Just a further update, I was reading over the Sekiro "FPS unlocker and more" mod: https://www.nexusmods.com/sekiro/mods/13

    And going off their instructions (and link to a BluBusters article/comment chain seems like, need to read further into that), it sounds like "Use 3D Application setting" for V-Sync in this game is also preferred to mitigate frametime stutter in conjunction with G-Sync:
    upload_2021-6-12_20-59-38.png
    I haven't finished downloading the game again yet, but I plan to test this out to see if it helps -- I recall running into a lot of issues with Sekiro like two years ago trying to get G-Sync to work so perhaps this'll help. For Dark Souls 3 the only way I could get G-Sync to work in fullscreen mode was to disable fullscreen optimizations on the .exe interestingly enough.
     
  20. SalamatiQus

    SalamatiQus Active Member

    Messages:
    80
    Likes Received:
    46
    GPU:
    RTX 3080 Vision OC
    I play Sekiro almost everyday with FPS unlocker. With GSync active the most important setting there is "Preferred refresh rate". If it is not set to "Highest available" then the game will output 60 fps even with unlocked framerate.
    Always played with VSync forced ON through global setting and now tried it with "Use the 3D application setting" and noticed no perceivable difference.
     
    BlindBison likes this.

Share This Page