G-Sync doesn't work with Dark Souls 3 -- Any idea why?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by BlindBison, Jul 17, 2020.

  1. BlindBison

    BlindBison Master Guru

    Messages:
    448
    Likes Received:
    73
    GPU:
    RTX 2080 Super
    Windows 10 and Nvidia Drivers are fully up to date -- inline with the Blur Buster's guide my typical approach is to enable V-Sync Globally in the Nvidia Control Panel (to enable the "frametime compensation" module or what not) then I disable V-Sync in-game. G-Sync is ON for both Windows and Fullscreen mode in the control panel settings. For most games, this is enough in conjunction with an FPS limit of ~3 beneath monitor refresh and G-Sync works just fine and dandy. Also, the Nvidia control panel default now globally is to force the highest refresh available so that's set too.

    However, this particular game (Dark Souls 3) misbehaves like I have just never seen -- I've tested this quite a bit today and what appears to be happening is that the game is forcing my monitor to behave as though it is a standard/traditional (non-G-Sync) 60 Hz monitor (it's a 144 Hz 1440p G-Sync panel). At first I though that maybe the game was just capping FPS internally to 60, but it ALSO is forcing the monitor to behave in this way and G-Sync simply is not working at all as far as I can tell. I get V-Sync level input delay and the same V-Sync hitching behavior that occurs when double buffer V-Sync dips beneath monitor refresh.

    Interestingly if I enable Ultra low latency mode for the Dark Souls 3 profile then it caps the game to 58 internally ("as though" G-Sync were enabled, but it's not) -- BUT, this comes with the same consistent hitching behavior like clockwork that capping 1-2 fps beneath refresh on a traditional V-Sync monitor would have with V-Sync ON.

    In Windowed mode, the game appears to be using the form of triple buffering that windows uses which is similar (the same to my knowledge basically) to fast sync -- the game microstutters periodically this way but input delay is noticeably reduced (since it's basically fast sync VS double buffer V-Sync if my understanding is correct). This is inspite of my nvidia drivers having the desktop refresh set to 144 hz and inspite of my control panel setting to use G-Sync when in windowed or fullscreen mode.

    I have simply never encountered this in a game before now -- Dark Souls Remastered for example appears to work totally fine in my tests -- that game you can set your monitor refresh in the options menu + disable in-game V-Sync where G-Sync works fine, it's just the game caps it's fps internally to 60. Dark Souls 3 on the other hand is just ... well, seemingly a garbage fire (tons of what I'm assuming is I/O stutter going in and out of areas on my 3900X / 2080S PC installed on an NVMe drive).

    But yeah, I tried googling round and couldn't really find much -- has anybody ever encountered this? Or, something like it with other games? I can force V-Sync OFF for the Dark Souls 3 profile but then the game tears constantly. Really bizarre.

    Anyway, thanks for your time, I appreciate it.
     
    Last edited: Jul 17, 2020
  2. AsiJu

    AsiJu Ancient Guru

    Messages:
    6,694
    Likes Received:
    1,758
    GPU:
    MSI RTX 2070 Armor
    Try enabling Vsync ingame as well. In some rare cases this might be needed for Gsync to work (example Surge 2).

    I have DS3 and can try it later.

    The game is capped to 60 fps so you can just as well run at a fixed refresh rate of 60 (Gsync off) with ULLM.

    Or set a fixed refresh and try using scanline sync, iirc scanline sync worked great with DS Remastered at least.
     
    BlindBison likes this.
  3. BlindBison

    BlindBison Master Guru

    Messages:
    448
    Likes Received:
    73
    GPU:
    RTX 2080 Super
    @AsiJu Thanks for your reply — for Dark Souls 3, it appears to force V-Sync ON internally — there is no in-game option to disable V-Sync (or enable it for that matter).

    So, the game is capped internally to 60 (just like Dark Souls Remastered), but the difference seems to be that the Remaster works totally fine with G-Sync while DS3 doesn’t at all in my tests. It’s not only capping the game to 60 FPS internally, it’s also forcing the monitor to behave as though it is a traditional non-G-Sync 60 hz panel too (which I’ve never seen before in another game).

    I could try the last thing you suggest — forcing V-Sync OFF in the control panel then using scan line sync — though, this might not work well since the RTSS cap might interfere somewhat with the internal cap which cannot be removed.
     
  4. AsiJu

    AsiJu Ancient Guru

    Messages:
    6,694
    Likes Received:
    1,758
    GPU:
    MSI RTX 2070 Armor
    Gsync works fine on my end:

    PART_1594970158618.jpeg

    game settings as are, nv cpl settings as are - Gsync On, Vsync On, Low Latency Off, Gsync enabled for fullscreen apps only.

    (But yeah indeed no toggle ingame for Vsync or refresh rate, both of which were present in DS Remastered I think)
    PS: it's funny how DS games get to your muscle memory;
    I haven't played DS3 in a year or two but first boss aced taking only a single hit - and even that was because I thought the boss was already dead - with a successful parry too.

    Anyway thanks for this topic as I've been meaning to replay DS3 for quite a while, thanks for giving me the "excuse" to reinstall it now :)

    EDIT: Gsync also works with ULLM and as far as I can tell there aren't stutters or hitches.
    In addition as I remember DS3 shouldn't really have i/o or streaming stutters etc., maybe something else is off here?
     
    Last edited: Jul 17, 2020
    BlindBison likes this.

  5. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,837
    Likes Received:
    236
    GPU:
    EVGA GTX 1080Ti SC
    Can you download Special4K and see whether you can force 1440p 165Hz in-game?
     
  6. Raptorta

    Raptorta Member

    Messages:
    22
    Likes Received:
    6
    GPU:
    Gigabyte GTX 970
    Hey! Had the exact same problem! Here is how I solved it on my end:
    I set scaling to GPU and enable override scaling then create a custom resolution of 2560x1439, set this resolution in DS3 and profit, you should now be at 144hz with working g-sync.
    If it still defaults to 60hz you should also disable full screen optimization for this game.

    ETA: The game does not misbehave that badly tho, the only thing that is happening is that it forces your monitor into 60hz mode, which in itselft sets your gsync range to 1-60. DS3 is a 60 fps game,so you hit the monitor's upper limit (at 60hz) which ALWAYS disengages G-sync (this is the reason you should cap it 3 frames below upper limit when using it in conjunction with V-sync.)
     
    Last edited: Jul 17, 2020
    BlindBison likes this.
  7. SalamatiQus

    SalamatiQus Member

    Messages:
    29
    Likes Received:
    14
    GPU:
    1080ti
    If you will do this, OP, do it offline or on alternate account through Family Sharing since it can possibly lead to online ban
     
    BlindBison and yasamoka like this.
  8. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,837
    Likes Received:
    236
    GPU:
    EVGA GTX 1080Ti SC
    Good call, yes.
     
  9. BlindBison

    BlindBison Master Guru

    Messages:
    448
    Likes Received:
    73
    GPU:
    RTX 2080 Super
    @AsiJu @Raptorta AsiJu, how were you able to get that "G-Sync ON" notification text in the top left of your screenshot there? I'm wondering if my monitor has something similar. Raptorta, as for your saying the game is G-Sync ON just with a range of 60 Hz, when I pan the camera in game when capping to a value under 60 (say, 58) I get recurring microstutter in the same way you get microstutter with traditional v-sync and capping under refresh -- so, at least on my rig it appears to be forcing the display to behave as though it's just a stock non-gsync display for some reason which is pretty weird.

    I'll try replicating those settings manually though and I'll try the custom resolution approach and see if it helps.Thanks!

    EDIT: It seems dell G-sync panels don't have an indicator option so RIP -- feelsbadman
     
    Last edited: Jul 17, 2020
  10. BlindBison

    BlindBison Master Guru

    Messages:
    448
    Likes Received:
    73
    GPU:
    RTX 2080 Super
    @yasamoka So, I tried the unsqueezed mod (special 4k iirc) and I got it to work for limiting framerate ingame to 30 or 48 in engine, but custom values above 60 didn't work and some features wouldn't seem to work correctly. So, I tried setting my screen refresh to 144 hz with v-sync off in the mod UI, but unfortunately this didn't seem to change anything. In the end, I uninstalled it for fear of a ban.
     
    yasamoka likes this.

  11. BlindBison

    BlindBison Master Guru

    Messages:
    448
    Likes Received:
    73
    GPU:
    RTX 2080 Super
    UPDATE: Alright so, it looks like disabling "Fullscreen Optimizations" for the DS3 exe and enabling GPU scaling under the control panel options resolved the problem for me -- which seems kinda weird -- I had heard previously that fullscreen optimization could cause problems in some games, but have never really experienced that until now. Anyway, thank you all for your help and time, I really appreciate it! (Other notable control panel settings -> G-Sync ON globally + Use Highest refresh forced for games globally + Control Panel V-Sync ON globally for the "frametime compensation" module or what not as described by blurbusters). Now the game appears to be capping itself internally to 60 fps, but with G-Sync ON now. Hurray! Thanks all

    Notably, if I set low latency mode to ULTRA with fullscreen optimizations enabled (default) then the game caps to 58 fps internally and I seem to get that weird v-sync stutter issue I described above. However, if I disable fullscreen optimizations then enable ULLM, the game caps at 60 internally and g-sync seems to function like I'd expect (so, I presume that the monitor is now correctly operating at its 144 hz range with just the in-game fps limiter capped to 60).
     
    Last edited: Jul 17, 2020
    AsiJu likes this.
  12. AsiJu

    AsiJu Ancient Guru

    Messages:
    6,694
    Likes Received:
    1,758
    GPU:
    MSI RTX 2070 Armor
    The G Sync indicator is a driver feature:

    in nv cpl when you are at the Gsync settings page, select Display from the top row menus and click G sync indicator or similar

    (Have Finnish language cpl so not sure what the exact English names are)
     
    Last edited: Jul 18, 2020
    BlindBison likes this.
  13. CrunchyBiscuit

    CrunchyBiscuit Master Guru

    Messages:
    273
    Likes Received:
    54
    GPU:
    AMD Radeon HD6950 2GB
    BlindBison likes this.
  14. CrunchyBiscuit

    CrunchyBiscuit Master Guru

    Messages:
    273
    Likes Received:
    54
    GPU:
    AMD Radeon HD6950 2GB
    Oh! I see AsiJu just beat me to it. Anyway, have fun!
     
    BlindBison and AsiJu like this.
  15. BlindBison

    BlindBison Master Guru

    Messages:
    448
    Likes Received:
    73
    GPU:
    RTX 2080 Super
    @CrunchyBiscuit Thanks! Yeah, I'd found that link on my own, but sadly it seems it's not an option of the Dell G-Sync panels :(
     

  16. BlindBison

    BlindBison Master Guru

    Messages:
    448
    Likes Received:
    73
    GPU:
    RTX 2080 Super
    As an aside, I have noticed this game stutters relatively frequently on my rig (3900X + 2080S stock clocks + 32 gb 3200 MHz RAM + installed on NVMe drive). I'm wondering if it has something to do with the GPU driver or, perhaps the game just wasn't optimized for Ryzen? That, or maybe I'll try disabling the new Windows setting "Hardware Accelerated GPU scheduling" which I've been using ON. At first I thought the stuttering was just I/O related (so, when you go into a new area for example), but I get stutters that happen just walking around Firelink Shrine (the home base in this game) so I really don't know. It is super annoying though (stuttering in games drives me nuts -- is way too common of an issue even with G-Sync in my experience, though some games like DOOM Eternal are smooth as butter which I greatly appreciate so obviously good ports out there too).
     
    Last edited: Jul 19, 2020
  17. SalamatiQus

    SalamatiQus Member

    Messages:
    29
    Likes Received:
    14
    GPU:
    1080ti
    I'm afraid what you are experiencing here is the game loading new area/assets. Unfortunately, DS3 does not do this seamlessly and small hiccup here and there is noticeable. If you happen to notice a small stutter, try walking back and forth some distance to see if it happens again.

    One of the early areas you can test this is at first bonfire of Farron keep (swamp). Just go from bonfire towards ladder almost up to a wall and back to bonfire. Game will load either previous forest area or next swamp area and stutter is usually noticeable.
     
    BlindBison likes this.
  18. AsiJu

    AsiJu Ancient Guru

    Messages:
    6,694
    Likes Received:
    1,758
    GPU:
    MSI RTX 2070 Armor
    You shouldn't have stutters like that, I have a Ryzen system too and no stutters.

    Try disabling HAGS, I have it off. Driver 451.67.

    FWIW I also have Windows' Variable Refresh Rate setting off.
     
  19. AsiJu

    AsiJu Ancient Guru

    Messages:
    6,694
    Likes Received:
    1,758
    GPU:
    MSI RTX 2070 Armor
    Those instructions aren't complete, you must be in the Set Up Gsync page for the Display top menu to appear.

    Works with all Gsync monitors as it's a driver option.
     
  20. BlindBison

    BlindBison Master Guru

    Messages:
    448
    Likes Received:
    73
    GPU:
    RTX 2080 Super

Share This Page