G-Sync at 120hz Causing Stuttering in some Games

Discussion in 'Videocards - NVIDIA GeForce' started by manic23, May 15, 2017.

  1. manic23

    manic23 Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    nVidia GTX 1080
    Can someone please help me out? I have a really annoying issue with my setup, I have an nVidia GTX 1080, 64GB ram, i7 6820HK with Widows 10 Creator's update installed. It is a high end gaming laptop (Asus G701VI). with a built in 120hz G-Sync monitor.

    On certain games like Forza Horizon 3 and Rise of the Tomb Raider having G-Sync enabled causes bad frame skipping/lag/stutter (not sure what to call it), but only when set to 120hz if I change to 60hz it's fine but obviously it runs at a lower frame rate then. Interestingly the FPS counter still reports a high frame rate (between 100 and 120) but that is not what I am experiencing on screen.

    If I turn G-Sync off and set the game to run at 120hz I get perfect performance, almost constant 120 FPS with no stutter, albeit with occasional frame drop as is it to expected. I am totally baffled by this. I am running the latest drivers (at the time of writing this v382.05). Can anyone offer any help?
     
    Last edited: May 15, 2017
  2. LocutusEstBorg

    LocutusEstBorg Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    nVidia
    Check if the games are actually running in Fullscreen Exclusive mode (you should not be able to see the Windows volume slider or notifications in-game), and make sure G-SYNC is set to fullscreen only in the NVIDIA Control Panel.
     
  3. manic23

    manic23 Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    nVidia GTX 1080
    Thanks but yes already thought og both those things, both are running full screen (not full windowed mode) and desktop v-sync is turned off.
     
  4. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,333
    Likes Received:
    2,655
    GPU:
    RX 5700 XT/GTX 1060
    Turn Gsync only for Fullscreen mode.
     

  5. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,363
    Likes Received:
    904
    GPU:
    1080Ti H20
    Disable display scaling in the NVCPL and also make sure to enable Vsync in control panel.
    Use FPS limiter to set to 118 via in-game(if no in-game, use RTSS)

    Gsync should be fullscreen only. Change Max Pre-rendered frames ahead to 1
     
  6. RavenMaster

    RavenMaster Maha Guru

    Messages:
    1,196
    Likes Received:
    138
    GPU:
    1x RTX 3080 FE
    Windows 10 Creators update turns on Game Mode and Game DVR by default. That will most likely be chopping your frame rates in half and overworking the GPU. Go into settings and turn off game mode and make sure game DVR is switched off. Then go into the Xbox app and make sure Game DVR is turned off there too.
     
  7. manic23

    manic23 Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    nVidia GTX 1080
    Thanks for your suggestions RavenMaster I tried everything you suggested but I still have the same issue.
     
  8. CK the Greek

    CK the Greek Maha Guru

    Messages:
    1,278
    Likes Received:
    11
    GPU:
    GB 2060S,Gsync,3DV2
    Clean re-install, test it.

    I would use DDU if I was having such an issue.
     
  9. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    Use nVidia Inspector to limit fps to 118 fps for those games which are stuttering at 120hz.

    With GSync you don't want to hit your fps to hit refresh rate as it introduces a little input lag.

    Also make sure Fast Sync is off
     
  10. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,363
    Likes Received:
    904
    GPU:
    1080Ti H20
    Don't use nv inspector. Unstable framerate + much higher input lag.

    Use either in-game or RTSS.
     

  11. Loophole35

    Loophole35 Ancient Guru

    Messages:
    9,764
    Likes Received:
    1,121
    GPU:
    EVGA 1080ti SC
    Not sure on RotTR but I know for a fact FH3 does not have exclusive full screen.
     
  12. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    When you say "much higher"... I'm not sure it's that much... it doesn't feel much higher when I tested them.
    I did read the Blurbusters thread on it, tried RTSS as apparently it's better ( at the time didn't work with UWP games anyway) ,but actually I found inspector limiter feels better for me with GSync most of the time than RTSS - plus you don't need any third party stuff running and it's easier to setup.

    But RTSS is a good call also.

    Ingame is first place to do it though if you can, but sadly most games inc Forza 3 don't let you choose a specific frame cap such as 118 do they.
     
  13. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,363
    Likes Received:
    904
    GPU:
    1080Ti H20
    It's quite a bit higher.

    Almost the same as having Vsync on.

    https://www.youtube.com/watch?v=rs0PYCpBJjc

    RTSS is smoother.
     
  14. RealNC

    RealNC Ancient Guru

    Messages:
    3,150
    Likes Received:
    1,375
    GPU:
    EVGA GTX 980 Ti FTW
    Hm. Just a shot in the dark, but what happens if you make sure these settings are used:

    • In-game vsync is disabled.
    • NVidia panel vsync is enabled.
    • G-Sync is enabled.
    • "Preferred refresh rate" in NVidia panel is set to "Highest available."
     
  15. manic23

    manic23 Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    nVidia GTX 1080
    Thanks for all your help guys, nothing has worked for me yet with anything but it's no major biggie, I can live with 60fps still looks good at that frame rate and FH3 is a great game really enjoying it.
     

  16. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    Have you confirmed GSync is actually working in the game ?
    My monitor has a button you can press and shows you if GSync or ULMB mode is active.

    It could still be 2 things.

    1) there is a GSync mode (based on combinations of settings which I cant remember if top of my head but are on GeForce.com somewhere) in which GSync is disabled when fps>refresh rate.
    This could case stuttering.
    May be related to Fast Sync setting I can't remember.

    2) have you got a game profile in which you have disabled GSync for one specific game ? If so it can cause GSync to be disabled globally for some strange reason,
     
  17. manic23

    manic23 Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    nVidia GTX 1080
    Thanks slickric21 I will check that out later tonight when I am home, you are all very helpful thanks very much :)
     
  18. RealNC

    RealNC Ancient Guru

    Messages:
    3,150
    Likes Received:
    1,375
    GPU:
    EVGA GTX 980 Ti FTW
  19. Mda400

    Mda400 Master Guru

    Messages:
    848
    Likes Received:
    89
    GPU:
    1660 - 2130/10ghz
    RTSS hooks onto/polls an application. That already creates delay from the start.

    Nvidia Inspector uses the driver's limiter and doesn't rely on hooking for control.

    I found the reason that Nvidia Inspector produces more delay is because I use to override the Vsync setting of an application globally (to always force off) or for a specific profile. Since Fast Sync was introduced, the driver's frame limiter works with an extra buffer if Vsync is driver controlled. If Vsync was driver controlled and I set to 'Force Off' (and set Vsync off in application as well), there would be a static tearing line at the bottom of the screen which would never happen with double buffering. Only an additional buffer could do this.

    Vsync set to "Use 3D application setting" while using Inspector, puts Vsync/buffering control back to the application while still being able to benefit from the frame limit.
     
    Last edited: May 19, 2017
  20. RealNC

    RealNC Ancient Guru

    Messages:
    3,150
    Likes Received:
    1,375
    GPU:
    EVGA GTX 980 Ti FTW
    Nope. Just tested. Inspector still has one frame more lag even with "Use 3D application setting".

    If you want to test yourself, cap to 22FPS. The additional 45ms of lag compared to RTSS is trivially easy to detect. A game with software mouse cursor is the easiest test (Fallout 4's start screen, for example.) Set Inspector to 22FPS and RTSS to 0FPS (disabled cap.) Start the game, move the mouse. There's lag. Alt+tab to RTSS and set a cap of 21FPS (so it takes over.) Back to the game, move the mouse. No lag (or rather very little lag.)

    That is the best example of observing the high inpulag cost of NVidia's frame limiter. No matter what you do, NVidia's limiter will give you double the input lag of RTSS. This is a test anyone can do on their own. Nobody needs to take my word for it. Just try this yourself with Fallout 4, or any game that has a software-rendered mouse cursor (hardware mouse cursor bypasses any frame limiter, do don't use such games for testing.)

    The tearing behavior you observe near the bottom of the screen most probably means NVidia's limiter is forcing adaptive vsync.
     
    Last edited: May 19, 2017
    fluidz likes this.

Share This Page