full screen stuttering and windowed smooth gameplay

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by CoMa666, Sep 27, 2013.

  1. CoMa666

    CoMa666 Master Guru

    Messages:
    392
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    Hi to all mates, i start to say to you sorry for my bad english.

    After many readings and searching in forums i discovered the major culprit of the stuttering.
    There is a problem an huge problem with games in full screen, i dunno if it's for refresh rate or Vsync but the clearly thing is in windowed mode the stuttering became to 0.
    I have experienced this problem with Amd/nvidia cards and drivers, so it's not about red or green.
    Games that have this problem:

    Star Wars Old Republic (tested with gtx 580, 680)

    Dota 2 (tested with hd7970 and gtx 680 lightningh)

    League of legends (tested with HD7970 and gtx 680)

    Diablo 3 (tested with HD7970 and gtx 670 msi power edition)

    Starcraft 2 (tested with HD7970 and gtx 670 msi power edition)

    Path of exile (tested with Hd7970 dual-x oc only)

    Sleeping Dogs (tested with Hd7970 dual-x oc only)

    Shadow Warrior( tested with HD7970)

    Bioshock Infinite(tested both with amd and Nvidia)

    Tf2 (tested with all my cards!)

    Now little proof that what i'm saing it's true:

    http://www.tomshardware.co.uk/forum/386194-33-certain-games-stuttering-drop-fullscreen

    http://www.neogaf.com/forum/showthread.php?t=437030

    http://forums.guru3d.com/showthread.php?t=371550

    http://forums.steampowered.com/forums/showthread.php?t=2804932

    http://forums.sleepingdogs.net/viewtopic.php?f=5&t=1596

    http://www.youtube.com/watch?v=0JZJgEmKlU0

    http://www.bloodlinechampions.com/forum/viewtopic.php?f=116&t=14855

    http://www.overclock.net/t/1405669/gtx-770-screen-stuttering-issues

    Now the question is, WHY noone can fix this?
    It's clearly a bug with screen resolution and refresh rate, so guys what do you think ?
     
    Last edited: Sep 27, 2013
  2. Pill Monster

    Pill Monster Banned

    Messages:
    25,234
    Likes Received:
    0
    GPU:
    7950 Vapor-X 1100/1500
    Disable vsync and cap the frame rate at ur monitors refresh rate (or a multiple of it).

    Actually with that many games and video cards affected it's probably something else like a dodgy PSU.
     
    Last edited: Sep 27, 2013
  3. CoMa666

    CoMa666 Master Guru

    Messages:
    392
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    corsair AX750, man it's not psu battlefield 3 ultra runs ultra smooth
     
  4. Pill Monster

    Pill Monster Banned

    Messages:
    25,234
    Likes Received:
    0
    GPU:
    7950 Vapor-X 1100/1500
    I didn't say it was specifically the PSU, but it could be, BF3 is only 1 out of 9 games....

    Try capping fps first or disabling vsync with RP.
     
    Last edited: Sep 27, 2013

  5. NobleKing

    NobleKing Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    EVGA GTX 780 SC ACX
    I have all these exact same problems. However I have more problems with my GTX 780. Its not the PSU
     
  6. Pill Monster

    Pill Monster Banned

    Messages:
    25,234
    Likes Received:
    0
    GPU:
    7950 Vapor-X 1100/1500
    How would you know? Your problem happens with 1 card - the op has used 4 different cards in 9 games.
     
  7. NobleKing

    NobleKing Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    EVGA GTX 780 SC ACX
    If I run Devil May Cry 4 Benchmark here is the outcome

    Vsync & 60hz and 120hz
    1. Full Screen DX 10 Vsync Jittery
    2. Window Mode Dx10 Vsync Smooth
    3. Full Screen DX 9 Vsync Smoother some jitter
    4. Window Mode Dx9 Vsync Smooth

    Same thing with Witcher 2, and Tomb Raider I have to play in windows mode. I updated my motherboard and CPU to haswell same problem. I must have a faulty GTX 780.
     
  8. NobleKing

    NobleKing Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    EVGA GTX 780 SC ACX

    I have less problems with an AMD card. I bought an AMD 7950 than later returned it to test for these problems. And the AMD card did better. Also when I had the gtx 680 I didn't have any stutter like this.
     
    Last edited: Sep 27, 2013
  9. Pill Monster

    Pill Monster Banned

    Messages:
    25,234
    Likes Received:
    0
    GPU:
    7950 Vapor-X 1100/1500
    Have you guys disabled vsync? (through RP not CCC). Disable then cap fps.

    **Or Inspector lol
     
    Last edited: Sep 27, 2013
  10. CoMa666

    CoMa666 Master Guru

    Messages:
    392
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    man we will take tearing and frankly that is not a solution, i'm searching an answer from devs.
     
    Last edited: Sep 27, 2013

  11. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,335
    Likes Received:
    3
    GPU:
    EVGA GTX 1080Ti SC
    Try to cap FPS at your refresh rate when using VSync. It could solve VSync-induced stuttering issues.

    Out of these games, I've played (extensively) Sleeping Dogs and BF3 and can confirm they have 0 stutter with VSync fullscreen on a single 7970.
     
  12. Pill Monster

    Pill Monster Banned

    Messages:
    25,234
    Likes Received:
    0
    GPU:
    7950 Vapor-X 1100/1500
    Right, obviously the devs are at fault because every player suffers stuttering with all 9 games you listed....:3eyes:
     
  13. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,335
    Likes Received:
    3
    GPU:
    EVGA GTX 1080Ti SC
    Yeah man there's most probably a serious issue at your side if you're getting VSync stutter with all those games.

    But before I start assuming things, we need to know more. Did you test those games on a fresh Windows installation with, let's say, WHQL drivers (or drivers deemed stable)?
     
  14. CoMa666

    CoMa666 Master Guru

    Messages:
    392
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    Yes i tested with fresh Windows.

    Pill can be u are not able to notice micro-stutering, try that games in windowed and then tell me, i poste only few links about other people that have stuttering!

    It's not only 9 games it's the first that come to my mind.

    guild wars2 is fine
    Bf3 fine
    BO2 fine
    Batman Arkham city fine
    and many Others, i will ad title that stutters in the main post.
     
  15. CoMa666

    CoMa666 Master Guru

    Messages:
    392
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    Many people are not able to see the difference from micro stutter and not.
    I will link topic on nvidia forum too ina while.
     

  16. CoMa666

    CoMa666 Master Guru

    Messages:
    392
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
  17. NobleKing

    NobleKing Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    EVGA GTX 780 SC ACX
    Nvidia could temporarily fix this issue by including a windowed mode (no border) in their drivers. Then all my games would be smooth. I hate using glitchy 3rd party window borderless programs.
     
  18. CoMa666

    CoMa666 Master Guru

    Messages:
    392
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    what programs u use?

    Do you have Windows 7 ?
     
  19. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,335
    Likes Received:
    3
    GPU:
    EVGA GTX 1080Ti SC
    Well, Sleeping Dogs (what I've tried) for sure doesn't stutter. That I can assure you. That is, as long as it doesn't dip below 60FPS.

    So as long as this is stuttering for you, then let's start there, since this game is stutter-free for me. Tried using in-game VSync vs. RadeonPro / CCC VSync and capping FPS (in-game vs. RadeonPro)?
     
  20. CoMa666

    CoMa666 Master Guru

    Messages:
    392
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    I have Windows 8 pro, sleeping dog it's not installed right now, i try to figure if with Windows 7 disabling aero and disabling the Vsync of the OS the problem persist.
    That's must be a V-sync conflict, read this:

    http://forums.guru3d.com/showthread.php?t=377210
     

Share This Page