Frequent "jitter"/microstutter in lots of games with G-Sync/3900X/2080S @1440p

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by BlindBison, Oct 23, 2020.

  1. Akakiy

    Akakiy Member

    Messages:
    18
    Likes Received:
    10
    GPU:
    MSI RX 5700 MECH OC
    enkoo1 and BlindBison like this.
  2. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    @SpajdrEX Sure, i'll try it, though I'm doubtful it will resolve much. The reason I say that is because the Nvidia control panel limiter also had the same issues so I think some games just don't play nice with RTSS/external frame limiting and don't like having their draw calls blocked or some such.
     
  3. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    @Akakiy Wow, never knew this existed -- would that same drag and drop .dll method still work with the DRM-less EPIC store version of the game? If so, I may redownload it and test this fix. I did see Kaldein's mod (I think it was Kaldein's at least to my recollection) and gave that a shot at some point, but it didn't really fix anything for me unfortunately. Thanks!

    Yeah, sadly my suspicion is that for many PC releases they just don't get the particularly CPU and streaming optimization that they require -- so I bring up Outer Worlds in my OP for example since I tried that numerous times since launch and I literally cannot play the game at anything other than the 30 fps capped value without awful microstuttering on my rig. On the one hand I worry it's an issue with my own PC, but on the other hand it just sorta seems like PC gets garbo versions of games sometimes. I'm still salty about the Dark Souls 3 "random" stutter that happens periodically as that's one I've been able to determine is not only happening to me.

    My respect for DOOM Eternal grows by leaps and bounds everytime I play a garbage stuttering PC port lol. That game is a harmony of good optimization -- good for Id.
     
    Archvile82 likes this.
  4. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    Just a heads-up, I did notice what seems to be a G-Sync "Bug" when using the new-ish "Fullscreen Optimizations" feature (defaults to ON now with no way to disable it globally, only on a per .exe basis).

    I've seen this happen in two games now (Dark Souls III and Red Dead Redemption 2) where despite G-Sync being ON for both fullscreen and windowed mode + control panel V-Sync ON (as per the blur buster's guide) + in-game V-Sync OFF (you can't turn off in-game v-sync in DS3 though as there's no option to do so), G-Sync did not engage and instead the game used traditional double buffer V-Sync.

    For example in Red Dead 2 on my 144 Hz monitor the game was locking to 72 / 48 FPS (standard double buffer vsync behavior) and I had a whole other thread on the Dark Souls 3 issue sometime back.

    In these cases what resolved the problem was disabling fullscreen optimization on the .exe, then G-Sync appears to work correctly. Super annoying issue though, sorta makes me wonder if it's happened in other games too, but I'm not certain.
     
    fluidz likes this.

  5. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,801
    Likes Received:
    8,048
    GPU:
    GF RTX 2070 Super
    BlindBison likes this.
  6. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    Thanks, that's helpful
     
  7. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,590
    Likes Received:
    3,877
    GPU:
    GTX 1080ti
    you can still kill it in the registry.
     
    BlindBison and Kevin Mauro like this.
  8. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    @Astyanax Interesting, I wasn't aware of that -- thanks!
     
  9. Vleeswolf

    Vleeswolf New Member

    Messages:
    1
    Likes Received:
    1
    GPU:
    1080 Ti 11 GB
    My hypothesis would be that gsync is not actually engaging, if you have indeed ruled out any powersaving kicking in. Are you running those games in fullscreen mode or (borderless) windows? You can confirm display mode is properly set by using https://www.nvidia.com/nl-nl/geforce/technologies/frameview/ and turning on the Gsync indicator as well to be sure. You should see an I (capital i) for independent flip in Frameview's HUD. This is assuming you did not disable FSO. Some rare games that run windowed also have independent flip, in that case gsync should work even if you have disable Nvidia's fullscreen & windowed setting.
     
    BlindBison likes this.
  10. rab3072

    rab3072 Member Guru

    Messages:
    110
    Likes Received:
    4
    GPU:
    EVGA RTX 3080 ULTRA
    I was having almost game-breaking stutters playing Apex Legends last night with my 3080. Frame rate is fine, yet my game is freezing every few seconds. Gsync off.
     
    BlindBison likes this.

  11. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    @rab3072 What CPU do you have? RAM speed/timings? In Digital Foundry's 2080 Super review (they used an 8700K which is a pretty beefy CPU even now) at 1440p, they were still getting some CPU bound microstuttering for certain games -- they talked about this again in their 3900X review so that's my inital "guess", but it's just a guess since iirc microstutter can be caused by who knows what. But yeah, a 3080 at 1440p or lower would be more inclined to run into those CPU bound microstuttering cases that Digital Foundry talked about than even the 2080 Super I'd expect -- maybe try capping framerate to a constistently achievablue value? Or using Nvidia DSR in the control panel to render at a higher resolution to shift more load onto the GPU and naturally bring framerate down a bit? Just some ideas -- that's solved the issue or mitigated microstutter for me in some games.
     
  12. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    @Vleeswolf Thanks, yeah I'm actually starting to wonder about that myself -- that's sort of what I'm wondering about with that "Fullscreen optimizations" bug I encountered in Red Dead 2 and Dark Souls 3 so I may try that as an experiment in other games like Hunt Showdown.

    Notably, it did seem like just toggling the checkbox on the .exe maybe doesn't work anymore for some games as in Hunt with fullscreen optimziations disabled I was still able to pull up the windows game bar same as usual (where in other games once you disable the fullscreen optimizations it takes you to desktop if you try to pull up the game bar) and I saw some threads online where they were claiming you couldn't disable it/that the checkbox doesn't work anymore in some cases: https://www.reddit.com/r/pcgaming/comments/ck13z9/psa_windows_10_1903_will_now_ignore_the_disable/

    Due to that, I'm gonna look into @Astyanax suggestion for the registry editor to see what happens if I test those games where the checkbox no longer seems to work -- maybe it is an issue with G-Sync like in Red Dead 2/Dark Souls 3, who knows?

    As for G-Sync setup/power plan I'm on Ryzen Balanced Power Plan (default) with Windows 10 default power settings (balanced) as I read for gaming those will at least generally work fine and I also updated my Ryzen 3900X chipset drivers for the X570.

    G-Sync settings are ON for both Fullscreen and windowed mode in nvidia control panel + V-sync on in nvidia control panel + v-sync OFF in-game + in-game set to fullscreen.

    EDIT: interestingly it seems I'm not the only one to encounter issues with "fullscreen optimizations" and G-Sync: https://www.nvidia.com/en-us/geforc...cards/5/272667/gsync-problem-with-fullscreen/
     
    Last edited: Nov 4, 2020
  13. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    @Astyanax for the registry way/disabling fullscreen optimizations globally to try to force it in .exes where the checkbox no longer worked (tested with gamebar), I did this: https://www.minitool.com/news/disable-fullscreen-optimizations.html

    So, adding that "GameDVR_FSEBehavior" field then setting it to "2". However, this did not appear to work at all unfortunately and I verified this by opening Overwatch after adding it to the registry then rebooting. Overwatch is one of the game's that does work correctly with disable fullscreen optimziations checkbox so with only registry part, gamebar still opens ingame/still using FSO. With checkbox the gamebar opens on desktop.

    Am I doing something wrong then? Perhaps it's now another one of the fields there in the latest build of Win10? You used to be able to disable windows defender via registry as well, but I noticed my old solution for that no longer works either :( upload_2020-11-3_21-24-7.png

    I also tried changing the GameDVR_FSEBehaviorMode to 2 since that was a variable that sounded similar and was already there + reboot and that didn't work either. Still experimenting since I found another thread where they go a bit more indepth. Confirmed this doesn't work anymore either: https://www.reddit.com/r/pcgaming/comments/ck13z9/psa_windows_10_1903_will_now_ignore_the_disable/ Ran the .reg file and still didn't disable FSO globally, but checkbox still worked for Overwatch for example.
     
    Last edited: Nov 4, 2020
  14. rab3072

    rab3072 Member Guru

    Messages:
    110
    Likes Received:
    4
    GPU:
    EVGA RTX 3080 ULTRA
    I still run the ASUS-Prime x470-pro MOBO and 2700x CPU (I know it will be a bottleneck, I'm hoping to grab a Zen3 at launch with a x570 MOBO). Also 32gb of RAM 3200 running on DOCP.
    My suspicion is the CPU is struggling, however, it never struggled previously with a 1070ti. My theory was that at 1080p - the graphics card would just easily produce the frames without breaking a sweat, then could tinker once I have the new CPU. What I didn't expect was to have worse performance with a 3080 paired with that CPU... It is driving me nuts as I might not even manage to get a Zen3 if they sell out and do an NVIDIA...
     
  15. Martigen

    Martigen Master Guru

    Messages:
    463
    Likes Received:
    211
    GPU:
    GTX 1080Ti SLI
    Been a while since I looked at this (I used to disable FSE for SLI) but set them as follows -- note there are 7 here and you have 6, so will need to add one as well:
    Code:
    [HKEY_CURRENT_USER\System\GameConfigStore]
    "GameDVR_Enabled"=dword:00000000
    "GameDVR_FSEBehaviorMode"=dword:00000002
    "GameDVR_FSEBehavior"=dword:00000002
    "GameDVR_HonorUserFSEBehaviorMode"=dword:00000001
    "GameDVR_DXGIHonorFSEWindowsCompatible"=dword:00000001
    "GameDVR_EFSEFeatureFlags"=dword:00000000
    "GameDVR_DSEBehavior"=dword:00000002
    
    Also make sure the GameBar is properly disabled:
    Code:
    [HKEY_CURRENT_USER\Software\Microsoft\GameBar]
    "ShowStartupPanel"=dword:00000000
    "GamePanelStartupTipIndex"=dword:00000003
    "AllowAutoGameMode"=dword:00000000
    "AutoGameModeEnabled"=dword:00000000
    "UseNexusForGameBarEnabled"=dword:00000000
    
     
    SpajdrEX, BlindBison and JonasBeckman like this.

  16. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    @Martigen Thanks, I'll give that a shot after work today. EDIT: my gamebar section looks like this so its missing many of those fields (latest version of win10, fully up to date): upload_2020-11-4_12-48-8.png
    I noticed in your block for the gamebar you have settings for "GameMode" -- I had thought that we wanted GameMode enabled/to work, no? Would that be something separate from the GameBar? Thanks,
     
  17. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    Eh, even running both of those blocks (gamebar / disable fso globally) didn't work for me :( Hunt/OW still launch with them enabled where the checkbox works to disable them in OW, but not in Hunt/MCCCollection. Perhaps they changed it in one of the updates.
     
  18. Blanky

    Blanky Member

    Messages:
    24
    Likes Received:
    5
    GPU:
    RTX 2070 SUPERXTrio
    In some games for Gsync to work properly with the exclusive full screen I solve it by creating an executable shortcut by adding this command " -window-mode exclusive" (be careful to add the space before the "-") , it's the only way I have to make it work, if the game is from Steam I add it to the launch parameters. (excuse my bad English, it's interesting to read and learn from you)
     
    fluidz and BlindBison like this.
  19. suty455

    suty455 Master Guru

    Messages:
    460
    Likes Received:
    178
    GPU:
    Nvidia 3090
    Am curious why are you leaving v synch active when using gsync unless I have misunderstood it v synch will try to make framerates stick to the resolution of the monitor whilst gsynch will actively change the resolution to match the frame rate your card is capable of, so in effect you have 2 systems working to opposite ends, I always disable vsync and never have any stutters in any game I also ensure its disabled in both the game and the Nvidia control panel
     
  20. BlindBison

    BlindBison Master Guru

    Messages:
    665
    Likes Received:
    120
    GPU:
    RTX 2080 Super
    @suty455 It's part of the blurbuster's g-sync guide -- essentially V-Sync does something different when G-Sync is enabled (turns on the frametime compensation feature) and without it you'll still get some tearing. Blurbuster's recommends using control panel v-sync to ensure it's working correctly, but with g-sync the optimal setup is G-Sync ON + control panel V-Sync ON + fps cap ~3 beneath monitor refresh to avoid hitting the G-Sync ceiling and incurring v-sync level input lag. If you google the blurbuster's g-sync guide they explain in more depth why how this works.
     

Share This Page