Freesync is BROKEN

Discussion in 'Videocards - AMD Radeon' started by Synoxia, Jan 11, 2019.

  1. RealNC

    RealNC Ancient Guru

    Messages:
    3,114
    Likes Received:
    1,341
    GPU:
    EVGA GTX 980 Ti FTW
    "At least" ;-)
     
  2. Synoxia

    Synoxia Member Guru

    Messages:
    146
    Likes Received:
    13
    GPU:
    Rog Vega 64
    FRTC in early stage was breaking freesync. I tested this using 18.2.2 drivers... FRTC is much better now and it's the only way for me to achieve correct frame to refreshrate.
    RTSS > FRTC for input lag, FRTC > RTSS for hz. I usually combine both but without expensive equipment i can't really test if FRTC delivers correct frametimes. RTSS alone for sure introduces stutter at low framerates.
     
  3. Kamil950

    Kamil950 Member

    Messages:
    15
    Likes Received:
    1
    GPU:
    Radeon HD 7850 1GB
    - Do you have stutter with both options - RTSS+FreeSync with disabled V-Sync and RTSS+FreeSync+V-Sync enabled in-game (because V-Sync enabled in AMD Radeon Control Panel works maybe only with OpenGL, not DirectX and Vulkan)?

    - Use exclusive full-screen, maybe.


    - Disable F.lux program, EVGA Precision program if you use these.

    https://www.reddit.com/r/buildapc/comments/5pz9hp/for_those_experiencing_heavy_stutters_on_freesync/


    - You can also try to disable some overlays (Xbox Windows 10 Game Bar, Uplay, Origin, Steam) maybe.


    - Disable Power Monitoring in MSI Afterburner (it can cause stutter) if you use this.

    https://www.reddit.com/r/nvidia/comments/9f1iu7/psa_micro_stuttering_a_lot_turn_off_power/


    - Try poweroff and poweron your monitor while your pc is running. If it will not works - toggle your input selector on the OSD to HDMI1 and back (or any other source for that matter).

    https://forums.guru3d.com/threads/weird-stutter-when-enabling-g-sync-compatible.424912/


    - Maybe reduce refresh rate from 144 to 120Hz.
    Uninstall drivers with DDU program and install new drivers (I'm not sure if you did it or not).

    https://forums.blurbusters.com/viewtopic.php?f=5&t=4978#p41940
     
  4. Synoxia

    Synoxia Member Guru

    Messages:
    146
    Likes Received:
    13
    GPU:
    Rog Vega 64
    None of these work unfortunately.
     

  5. Kamil950

    Kamil950 Member

    Messages:
    15
    Likes Received:
    1
    GPU:
    Radeon HD 7850 1GB
    Did you disable Radeon Overlay (it is enabled by default maybe)?

    'Can you disable Radeon™ Overlay?

    Yes, in you can disable it from within Radeon Overlay using the Settings button in the top right and selecting “Disable Radeon™ Overlay” or using the Radeon™ Settings control panel, under Preferences, and unchecking “Show Overlay”.'

    https://www.amd.com/en/technologies/radeon-software-overlay

    https://www.reddit.com/r/radeon/comments/a66fnt/radeon_overlay_causing_large_stutters_ingame/ - about stutter with Radeon Overlay

    You can also try close 'amdow.exe' process.

    ***

    Did you disable in-game OSD in RivaTuner and close MSI Afterburner program?

    ***

    Maybe you can try also to disable Windows 10 Full-screen Optimizations (right click on game's icon -> Properties...).

    ***

    Do you have only one screen connected to your PC and only 1 device (PC) connected to your screen?

    ***

    Do you have stutter only below FreeSync range (in LFC range) or also in FreeSync range?
     
    Last edited: Jul 14, 2019
  6. Kamil950

    Kamil950 Member

    Messages:
    15
    Likes Received:
    1
    GPU:
    Radeon HD 7850 1GB
  7. Synoxia

    Synoxia Member Guru

    Messages:
    146
    Likes Received:
    13
    GPU:
    Rog Vega 64
    Sorry if i am necroing this but just wanted to let you know that the only way to fix this behaviour is to use RTSS + FRTC togheter. RTSS for smooth frametimes and FRTC for perfect 1:1 fps:Hz.
     
  8. Kamil950

    Kamil950 Member

    Messages:
    15
    Likes Received:
    1
    GPU:
    Radeon HD 7850 1GB
    Thanks for your answer.

    Should RTSS and FRTC be set at the same FPS limit number?

    Are RTSS+FRTC working together cause more input lag than only RTSS?
     
  9. Undying

    Undying Ancient Guru

    Messages:
    12,049
    Likes Received:
    1,638
    GPU:
    Aorus RX580 XTR 8GB
    Yes frtc adds some input lag so use just rtss as a limiter with a freesync.
     
  10. metagamer

    metagamer Maha Guru

    Messages:
    1,196
    Likes Received:
    455
    GPU:
    Palit GameRock 2080
    lol, if you actually knew anything about monitors, you would understand his argument. You clearly don't.
     
    Last edited: Sep 27, 2019

  11. Astyanax

    Astyanax Ancient Guru

    Messages:
    3,961
    Likes Received:
    1,117
    GPU:
    GTX 1080ti
    he doesn't have one, and neither do you.
     
  12. Synoxia

    Synoxia Member Guru

    Messages:
    146
    Likes Received:
    13
    GPU:
    Rog Vega 64
    To me it seems like the input lag is the same as RTSS, FRTC just serves the purpose of syncinc the HZ. but undying's answer is correct one. Just use RTSS if you do not experience this broken behaviour.
    Im curious if MaCk0y still has the same behaviour with the new gpu.
     
  13. Synoxia

    Synoxia Member Guru

    Messages:
    146
    Likes Received:
    13
    GPU:
    Rog Vega 64
    I have an update, check this apparently this user experience the same behaviour with RTSS. The problem is that i experience this with in-game framecap too...
     

Share This Page