1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Freesync and DX11/12?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Danny_G13, May 18, 2019.

  1. Danny_G13

    Danny_G13 Master Guru

    Messages:
    359
    Likes Received:
    7
    GPU:
    MSI 1080Ti FE @ 2GHz
    Ok, wasn't quite sure where to put this but having noticed stuttering in freesync in Anthem, then in Wildlands, I couldn't quite figure out why those two games didn't seem to properly work with Freesync on.

    Pretty much everything else does - then I found the common denominator:

    Does Freesync on Geforce have a problem with DX11?

    Every other AAA game I play works just fine with freesync, but these two stand out as not - and they're both DX11 games. They work sporadically some of the time, but not all - and it's random.

    Is this a known issue or has yours truly just casually stumbled upon it?

    And how would I fix it to work properly? If there's a way?
     
  2. bernek

    bernek Maha Guru

    Messages:
    1,454
    Likes Received:
    28
    GPU:
    VEGA64 / 8GB
    I've got same problem in Anthem well enabling vsync sometimes help and also alt+tab from game to desktop and back to it for me it fixed it. Since I gave up on my RX580 in favor of 1070GTX I forgot about Freesync I have it on but never looked for tearing. The sad part is that Freesync on nvidia at least for me has a performance downgrade. It somehow tries to smooth frames out also and I lose maybe 10-15% in raw fps but overall games are smoother so I stopped benchmarking and testing.
     
  3. spajdrik

    spajdrik Ancient Guru

    Messages:
    1,750
    Likes Received:
    204
    GPU:
    Sapphire RX580 8GB
  4. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,398
    Likes Received:
    281
    GPU:
    R9 290 Crossfire
    Freesync worked fine on Anthem until a recent patch of game or newest Nvidia driver,I do not know exactly which one it is but Anthem does stutter now for me also.
    I have not tried Wildlands in months and only played with G-Sync and not Freesync in that game.

    DX12 does not run good on Nvidia drivers causing stutter in almost every DX12 game I own.I only use DX12 on Nvidia now if it has RTX/DLSS in game, DX11 runs better in just about every game on Nvidia. Just my experience.

    I suggest if your looking at Freesync as the problem.Try to play with Freesync off and use fast sync for high refresh rate monitor and see how it works.
     

  5. Danny_G13

    Danny_G13 Master Guru

    Messages:
    359
    Likes Received:
    7
    GPU:
    MSI 1080Ti FE @ 2GHz
    I have a few of these but haven't tried any in recent months. I'll give Andromeda (essentially the predecessor to Anthem) a go and report back. Good shout.
     
  6. Danny_G13

    Danny_G13 Master Guru

    Messages:
    359
    Likes Received:
    7
    GPU:
    MSI 1080Ti FE @ 2GHz
    Might try that - but I did fiddle about with fullscreen modes too as a fix and noticed it only fixed it for a set period of time (like 30 seconds) until it broke again.

    Correct - you do lose a few frames technically but visual fluidity is about 90% guaranteed - it's an excellent bypass to needing a 2080Ti - a cheat way of getting the performance visually that you want (I'm 1080Ti). And agreed too - since freesync became Nvidia available I haven't run pretty much any benchmarks. They don't matter now.
     
  7. Danny_G13

    Danny_G13 Master Guru

    Messages:
    359
    Likes Received:
    7
    GPU:
    MSI 1080Ti FE @ 2GHz
  8. artina90

    artina90 Active Member

    Messages:
    60
    Likes Received:
    10
    GPU:
    GTX 970 Windforce 1.55Ghz
    I had no issues with freesync on Windows 1809, both DX 11 and 12 worked properly.
    After upgrading to 1903 sometimes the games lock themselves at 30 fps even if there is performance to spare.
    Alt-tabbing fixes it immediately but sometimes it happens again after a while, alt-tabbing again fixes it.
    This is a baseless speculation but it's almost as if the games switched from being the foreground app to a background app.
    This happens with borderless and full screen optimizations active, disabling fullscreen optimizations prevents it.
    Sadly there are some games with wonky HDR implementations (Monster Hunter World, FFXV) that implement HDR by running the game in borderless mode, enabling fullscreen exclusive switches HDR off.

    Monster Hunter World is the biggest offender of the "fps lock.
    In HDR mode it locks at 30 fps every time I start the game with 40% GPU utilization, then I alt tab and the game goes back to 60 fps with freesync working just fine in between 35-60 which is my supported range.
    After completing a couple of hunts it locks itself again with low GPU usage and I have to alt-tab again.
     
  9. Danny_G13

    Danny_G13 Master Guru

    Messages:
    359
    Likes Received:
    7
    GPU:
    MSI 1080Ti FE @ 2GHz
    You might be absolutely bang on. I'll have a look at this. The symptoms you're describing mirror mine exactly. I'll report back how this goes. Cheers.
     
  10. Danny_G13

    Danny_G13 Master Guru

    Messages:
    359
    Likes Received:
    7
    GPU:
    MSI 1080Ti FE @ 2GHz
    Hm, couldn't get it to actually switch - the music remained on in the background indicating it was till a 'foreground' task so that had no effect, and I tried to change the process priority but was locked out of it.

    Definitely think you might be onto something though.
     

  11. Danny_G13

    Danny_G13 Master Guru

    Messages:
    359
    Likes Received:
    7
    GPU:
    MSI 1080Ti FE @ 2GHz
    It's definitely a usage issue - for some reason GPU usage drops in some games, and sometimes fiddling around with video settings fixes it, but it doesn't sustain it.

    This is a clear Windows bug, and I'd love to know the actual fix because I can't play Wildlands or Anthem until this is resolved.
     
  12. d0X

    d0X Member Guru

    Messages:
    177
    Likes Received:
    7
    GPU:
    MSI GTX1070 GamingX
    I sometimes have the same problem in WoW, but alt-tabbing fixes it immediately. I have it set at 30 fps when in background so it is really obvious when it loses the foreground priority.
     
  13. Danny_G13

    Danny_G13 Master Guru

    Messages:
    359
    Likes Received:
    7
    GPU:
    MSI 1080Ti FE @ 2GHz
    alt-tab isn't working in wildlands at all. Doesn't seem to go background to switch back to foreground. But I have found that turning vsync and gsync off sees 100% GPU consistently. It's definitely a freesync and vsync issue - similar to triple buffering - when the fps dips to a certain level, instead of like in every other game where it stays there, Wildlands and Anthem just go straight to half of the refresh rate. But not with vsync/freesync off. Annoying as hell.
     
  14. Danny_G13

    Danny_G13 Master Guru

    Messages:
    359
    Likes Received:
    7
    GPU:
    MSI 1080Ti FE @ 2GHz
    I give up. I've tried everything. This is evidently a windows bug I can't negotiate any way around. I'll just have to miss out on Anthem and Wildlands. And potentially Break Point if it uses Wildlands' engine.
     
  15. d0X

    d0X Member Guru

    Messages:
    177
    Likes Received:
    7
    GPU:
    MSI GTX1070 GamingX
    You probably really tried everything, but I'll throw a few more suggestions for you just in case:

    1) maybe forcing high performance graphics mode: https://www.ghacks.net/2018/11/30/assign-graphics-performance-preferences-windows-10-programs/

    2)try enabling Freesync with all other vsyncs and triple-buffering disabled (Nvidia CP and in-game) and using a frame limiter (in-game or RTSS) with 2-3 fps less than your refresh rate

    3)Freesync + Nvidia CP vsync + frame limiter

    Can't think of anything else, sorry. Maybe it really is just a bug to be fixed in Windows or those particular games.
     

  16. Danny_G13

    Danny_G13 Master Guru

    Messages:
    359
    Likes Received:
    7
    GPU:
    MSI 1080Ti FE @ 2GHz
    The high performance thing seemed to make sense, but made no difference. There has to be some way of truly forcing full power on GPU because that seems to be the issue.
     

Share This Page