1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fortnite stuttering - fixed

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by knivestv, May 10, 2018.

  1. knivestv

    knivestv Master Guru

    Messages:
    222
    Likes Received:
    2
    GPU:
    EVGA 1080Ti SC
    I noticed while running on a fresh install of Windows 10 1803 and just the game / drivers, it starts hitching after about 30 minutes of play. Friends reported the same thing, so I spent last weekend testing some bits and I found the problem.

    Drivers from 387.92+ cause the graphics card to have clear and consistent frame drops after the game has been running longer than about 30 minutes. If you look at your GPU on task manager while on the mission select / map screen, you can see the hitching every few seconds.

    [​IMG]

    My framerate drops from 144 with gSync down to 20 at these moments, resulting in hitching / stuttering. It does this in game too, but more randomly than the mission select screen.

    I have tried: 387.92, 388.13, 388.43, 388.71, 390.65, 390.77 and 397.31. And a fresh build of windows twice. It seems that drivers from 387.xx upwards contribute to this strange issue where the game gradually degrades in performance the longer you play.

    To fix it, I have to use 385.69. Using that driver with the current build of Fortnite doesn't produce stuttering. My framerate stays at 144 on the mission select screen, and it varies up and down smoothly while playing the game. I played 5 hours straight last Sunday, no problems.

    I also tested this theory on my Alienware laptop (build 1709 ) to rule out my desktop hardware being the cause, and I get identical results. 385.69 is the newest (older) driver I can use that doesn't cause constant stuttering / hitching.
    I didn't bother testing any drivers older than 385.69, because I would like to have the most up-to-date driver possible... Unfortunately this is it!

    I forgot to save the GPU screenshots in between Windows reloads on my desktop.. the shot above is from my laptop to show the constant frequency of hitching, and here it is fixed with 385.69 on desktop.

    [​IMG]

    The hitching "V" on the task manager was a lot deeper on the 1080Ti, dropping to around 60% I think because the framerate was much higher than the laptop (144 vs about 75). Both drop to around 20 when this hitching starts to happen.

    Hardware:
    Desktop i7 5820K, GeForce 1080Ti, 16GB RAM
    Alienware i7 4710MQ, Geforce 860M SLi, 8GB RAM
     
    Last edited: May 11, 2018
    TheDeeGee likes this.
  2. gabsvm

    gabsvm Member

    Messages:
    36
    Likes Received:
    4
    GPU:
    GTX 650 MSI OC
    Only happening on the newest windows build or you try another version already? I was thinking about it too, after some times the games seems to sttuter without a reason just like that, but im in Windows 8.1 with a GTX 650.
     
  3. knivestv

    knivestv Master Guru

    Messages:
    222
    Likes Received:
    2
    GPU:
    EVGA 1080Ti SC
    The version on my Alienware is 1709, I haven't pressed the button to upgrade it yet. Should have mentioned it o_O I'll edit to acknowledge that. :oops:
     
  4. gabsvm

    gabsvm Member

    Messages:
    36
    Likes Received:
    4
    GPU:
    GTX 650 MSI OC
    I already downloaded 385.69, gonna do some tests today and come back here to post my results, im currently in 388.84.
     
    iDelta likes this.

  5. gabsvm

    gabsvm Member

    Messages:
    36
    Likes Received:
    4
    GPU:
    GTX 650 MSI OC
    Im testing at this moment, seems ok with The Evil Within 2 (the king of optimization xD), playing WoW right now, all seems very smooth, gonna test others games in a while.
     
    spajdrik likes this.
  6. knivestv

    knivestv Master Guru

    Messages:
    222
    Likes Received:
    2
    GPU:
    EVGA 1080Ti SC
    Nice :cool: I'm mostly playing coop games at the moment - Dying Light runs perfect, Killing Floor 2 as well. I need to reinstall the rest of my steam library at some point, however I'm mostly playing Fortnite (save the world) so I'm in no rush to do this right now.

    I don't remember seeing any problems in other games with latest drivers, but since 90% of my game time is Fortnite this stuttering really started to bug me! I thought it must be the game engine or my O/S or something, because the Nvidia drivers 390.65 specifically said "provides the optimal gaming experience for Fortnite". I have to wonder what optimal experience they refer to, since this bug pre-dates that driver, and continues to the latest one...?

    Anyway, my coop buddies on team Nvidia have made this change and reported that all is well. The one person who uses Ryzen and a Vega64 said there was zero stuttering for him, and that's what got me thinking.. maybe it's not the game or Windows, it must be something else.

    Windows 10 has a habit of updating Nvidia drivers if you use older ones, maybe Windows 8.1 does too? I use a WSUS box on an old server, so I can prevent this easily but if you have problems with automatic updates undoing all your work this will solve it https://www.howtogeek.com/263851/ho...from-automatically-updating-specific-drivers/
     
    Last edited: May 11, 2018
  7. adabiviak

    adabiviak Master Guru

    Messages:
    753
    Likes Received:
    14
    GPU:
    Gigabyte GTX 980Ti
    Interesting... I'll give this a spin when time permits, thanks!
     
  8. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,256
    Likes Received:
    780
    GPU:
    1080Ti H20
    What's most annoying is the fact that pre 4.0 patch there was zero blurry textures; now it looks like they reduced MIPs so we get more pop-in and lower LOD

    VRAM usage is <3GB on a 11GB card.
     
  9. gabsvm

    gabsvm Member

    Messages:
    36
    Likes Received:
    4
    GPU:
    GTX 650 MSI OC
    I tested last night the new ones and got more sttuters and TDR's randomly. Reverted back to 385.69 and all games runs better, even FFXV Benchmark runs flawless compared to previous drivers, 390 drivers are not so good in my case at least xD i always deactivate Windows Update, only using it to manually update Windows or something else so i dont get any surprise xD
     
  10. knivestv

    knivestv Master Guru

    Messages:
    222
    Likes Received:
    2
    GPU:
    EVGA 1080Ti SC
    lol snap! :cool: I had a go of the new drivers this morning and found the same thing as you, more stuttering / hitching. I'll stick with 385.69 and get some Fortnite in this weekend. Friends should be online any minute now, time to get a cold beer! Enjoy the weekend *runs to fridge*
     

  11. Astyanax

    Astyanax Master Guru

    Messages:
    324
    Likes Received:
    72
    GPU:
    GTX 1080ti
  12. CaptaPraelium

    CaptaPraelium Member Guru

    Messages:
    152
    Likes Received:
    29
    GPU:
    1070
    Title says fixed but all I see is a workaround by downgrading drivers. Am I missing something?

    This looks a lot like the stuttering bugs many have been reporting in recent drivers (although it's hard to say without frametime graphs and without comparing the performance with power monitoring disabled). I've been discussing it in the new driver threads and nvidia are aware of it, have replicated it and are working on it (although there's no mention of it in the driver notes)
     
  13. kieron fleming

    kieron fleming New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    gtx 1080ti
    to make the game look a lot sharper I disable in game aa looks like crap and use NVidia control panel aa not the fxaa option though you still have jaggies but a lot more tolerable than blurro vision.
     
  14. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,256
    Likes Received:
    780
    GPU:
    1080Ti H20
    I'm not referring to post processing.

    I mean low LOD popin, where textures in building look like crap when you zoom in on them with a sniper or sometimes even when you're walking up to them.

    LOD on xbone X is better likely due to allocating more resources to VRAM.

    No option on PC, you only see mid 2GB usage
     
  15. X7007

    X7007 Maha Guru

    Messages:
    1,387
    Likes Received:
    6
    GPU:
    Inno3D 1080GTX
    What about other games then ? there are stuttering there also ? does this driver fix the issue ?
     

  16. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    5,539
    Likes Received:
    171
    GPU:
    MSI GTX 1070
    Thanks, i'll give this a try!
     
    Last edited: Jun 24, 2018
  17. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    5,539
    Likes Received:
    171
    GPU:
    MSI GTX 1070
    Can confirm that going to this older driver works.

    Can also confirm that it's not a Driver issue, as this issue started during Fortnite Patch 4.0/4.1 and i used a newer driver than 385.69 before that.

    They changed something around Patch 4.0/4.1 that caused this to happen.
     
    Last edited: Jun 24, 2018
  18. endbase

    endbase Master Guru

    Messages:
    576
    Likes Received:
    21
    GPU:
    MSI GTX 1070 Gaming
    On the latest patch with latest driver no problems with fortnite :)
     
  19. Stormyandcold

    Stormyandcold Ancient Guru

    Messages:
    5,098
    Likes Received:
    88
    GPU:
    MSI GTX1070 GamingX
    My GTX680m 4GB laptop was crashing within a few minutes of getting in-game in Fortnite.

    I finally found the solution to fix this problem on a Ruclip video.

    Craig Lister found his fix to be to run Fortnite without running the Epic Launcher at all. Instead, close Epic Launcher (or don't run it at all) and run the Fortnite Launcher instead found here; C:\EpicGames\Fortnite\FortniteGames\Binaries\Win64\FortniteLauncher

    Now my laptop can play Fortnite without crashing.
     
  20. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    5,539
    Likes Received:
    171
    GPU:
    MSI GTX 1070
    You sure you have the game open for 2 hours or more, because only then you will start to notice the hiccups, and they get worse the longer the game is running.
     

Share This Page