Forceware drivers, black levels broken

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by tolkaNo, Mar 8, 2011.

  1. tolkaNo

    tolkaNo New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    8800gt
    Hey

    I just reformatted and installed latest forceware (266.58) and found out that the black levels in videos are gaids

    I never had this problem before the format, i don't know what version forcewares i was using, something pretty old that worked though

    For whatever reason it seems to output blacks fine on my tv (samsung 42" plasma)

    Some pics i took to show what i mean

    http://i407.photobucket.com/albums/pp157/tolkaNo/SDC10558.jpg
    http://i407.photobucket.com/albums/pp157/tolkaNo/SDC10554.jpg

    Note that blacks show up as grey

    I think its probably something to do with dynamic range (0-255) that kinda thing, ive screwed around with lots of settings but it doesn't change anything though

    When i had the oldass forcewares installed, i had everything set at default and everything was perfect without touching anything

    So yeah i dunno. Any ideas?
     
  2. Cyberdyne

    Cyberdyne Ancient Guru

    Messages:
    3,582
    Likes Received:
    303
    GPU:
    2080 Ti FTW3 Ultra
    If you use HDMI (lol) try switching from RGB color mode to Ycbcr in the NVCP.
     
    Last edited: Mar 28, 2011
  3. nyhunter

    nyhunter New Member

    Messages:
    6
    Likes Received:
    0
    Is that only for videos or all Black level output on TV ? I had poor blacks then i went to nvidia control panel - change resolution - create a custom resolution with 1920x1080 progressive 60hz 32 bit and my blacks were fixed.
     
  4. Redemption80

    Redemption80 Ancient Guru

    Messages:
    18,495
    Likes Received:
    266
    GPU:
    GALAX 970/ASUS 970
    Yeah, as per above lowering Dynamic Range or changing Digital Colour Format to ycbcr444.

    Would ideally go with the changing digital colour format, as all video's SD or HD are 16-235, lowering the dynamic range to 0-255 will cause you to have crushed blacks and overblown whites.
     

  5. kado

    kado Member

    Messages:
    27
    Likes Received:
    4
    GPU:
    GTX1070 G1 8GB
    YCbCr444 setting in control panel is broken in 26x.xx drivers, I tried 270.32 and it's still the same, rgb or green image. The latest working drivers are 259.32. Hope they fix this issue.
     
  6. nick0323

    nick0323 Maha Guru

    Messages:
    1,010
    Likes Received:
    61
    GPU:
    Asus DUAL RTX2060S
    And there I am wondering why the colours on my IIyama LED look crap.

    And there I am wondering why the hell Asus have just released 259.44WHQL dated 23/03/2011 - because Asus acknowledge that any 260.xx driver breaks everything and ruins user experience.

    I'm dropping back from 266.58 which doesn't even allow me to run two monitors. Yawn!
     
  7. GhostXL

    GhostXL Ancient Guru

    Messages:
    6,084
    Likes Received:
    54
    GPU:
    Merc 319 6800 XT
    YCbCr444 works just fine here in the 26x.xx's, actually it's worked in all of them for me. It makes a huge difference on my LCD with black levels, and colors are much more rich.
     
  8. cricket bones

    cricket bones Master Guru

    Messages:
    823
    Likes Received:
    215
    GPU:
    EVGA RTX 3080 FTW
    Works for me, too. HDMI.
     
  9. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    6,954
    Likes Received:
    960
    GPU:
    GTX1080Ti
    Yep working here on the 267.85 driver... For those of you getting the pink screen after setting to the YCbCr444, toggling the 'content type reported to the display' and hitting apply will fix that.
     
  10. Xtreme512

    Xtreme512 Master Guru

    Messages:
    753
    Likes Received:
    26
    GPU:
    RTX 3070 Ti
    hey Im using 2333T with my GTX 460. in 267.59 I dont see any YCbCr444 color settings under my NVCP even though I use HDMI to DVI cable. How can i change it ? would it make any diffrences ?
     

  11. kado

    kado Member

    Messages:
    27
    Likes Received:
    4
    GPU:
    GTX1070 G1 8GB
    After some serious testing and several driver instalations (with fresh install or with driver sweeper) I got the folowing results:
    YCbCr works after a fresh install, you can change from RGB to YCbCr but if you change "monitor content type (or whatever it is because mine is in portuguese)" to something else then automatic then no more ever again ycbcr, only get rgb or green image. The same happens if I put RGB back and try YCbCr again. I even tried on my netbook that has a ION gpu with HDMI output (Asus 1201N) with the same results. 259.32 has no issues whatsoever.
    So as long as I don't change that setting ever again everything is fine!:)
    Thanks for the tips and help.
    [​IMG]

    I also tried a different HDMI cable, connections in both DVI ports on the gpu and in all 4 HDMI ports on the tv. Also tried with two different DVI to HDMI converters, one from ATI and other from NVIDIA.
     
  12. Cyberdyne

    Cyberdyne Ancient Guru

    Messages:
    3,582
    Likes Received:
    303
    GPU:
    2080 Ti FTW3 Ultra
    If you don't see anything wrong I would not worry about it. I should think that so long as the port used on the GPU is DVI you would not see or have to worry about the problem, could be wrong though, I only have DVI.
     
  13. Xtreme512

    Xtreme512 Master Guru

    Messages:
    753
    Likes Received:
    26
    GPU:
    RTX 3070 Ti
    ok thanks... my black and white levels are correct though.:)
     
  14. Mufflore

    Mufflore Ancient Guru

    Messages:
    13,562
    Likes Received:
    1,850
    GPU:
    Aorus 3090 Xtreme
    Most video actually looks better for it though!
    I always run 0-255, contrast is turned up on my TV to prevent darks looking too dark.
    Its worth noting I use a plasma TV capable of 110% NTSC, this might be preventing overblown whites, I dont see any.

    Running on my LCD (Dell 22"), I dont get the option to change the dynamic range.
    It appears when switched to the TV.
    It may only apply to displays that use extended gamut.


    This option doesnt appear on my monitor, only my TV.
     
    Last edited: Mar 30, 2011
  15. Redemption80

    Redemption80 Ancient Guru

    Messages:
    18,495
    Likes Received:
    266
    GPU:
    GALAX 970/ASUS 970
    Better is subjective though.

    More than likely the video player, or video decoder is compensating for it as no amount of contrast could sort black crush unless you just prefer it this way.

    I run mine at 0-255 too, but i have the player/codec set to sort it, and i have perfect blacks and great whites, but also every shade of grey inbetween.
     

  16. Mufflore

    Mufflore Ancient Guru

    Messages:
    13,562
    Likes Received:
    1,850
    GPU:
    Aorus 3090 Xtreme
    MPC-HC + ffdshow
    It looks great.
     

Share This Page