Forceware 270.51

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by dudikaz, Mar 30, 2011.

  1. JohnDoeGamer

    JohnDoeGamer Member

    Messages:
    13
    Likes Received:
    1
    GPU:
    EVGA 1080ti Gaming
    I think I am having this problem with this driver.

    Although it seems like a much fast driver over the 266.66 for my EVGA GTX560Ti card, it auto minimizes 3d games to the task bar (this beta driver does). I am overclocking my card and have had it using EVGA precision stable at 950/2150 but now it seems as though it wants to crash games at that level.

    I dunno. I want to like the speed of this driver but its maybe making my OC unstable.
     
  2. BossJ

    BossJ Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    2x470GTX OC / 8800gtx
    Ahhh I thought it was MSI Afterburner, and I was installing and reinstalling this driver / old versions of afterburner... This driver is crashing most my games with my USED to be stable OC's on my cards. Temps and everything are really low, but all of the 270 drivers, have been doing this to my cards.
     
  3. fellix

    fellix Member Guru

    Messages:
    198
    Likes Received:
    37
    GPU:
    KFA² GTX 1080 Ti
    All the 270 release drivers had that strange effect on my setup, where a previously stable overclock would give me some minor glitches, and even occasionally a frozen system under load. I mean, a non-demanding 3D application like Google Earth would display some strange texture artifacts and even crashed the system once, while gaming in L4D2 with tons of AA and AO enabled would run for hours. I even could spot some artifacts (a greenish spot popping from time to time) in a video playback.
     
  4. Mufflore

    Mufflore Ancient Guru

    Messages:
    13,040
    Likes Received:
    1,462
    GPU:
    Aorus 3090 Xtreme
    If you get higher fps, it stands to reason that more work is being done.
    More work = higher temps.
    If you are already on the limit of your overclock, this can tip you over the edge.
    You may have to reduce the overclock a tad or increase the voltage slightly, whatever works for you.
    If it nets you better performance...
     

  5. BetA

    BetA Ancient Guru

    Messages:
    4,373
    Likes Received:
    310
    GPU:
    G1-GTX980@1400Mhz
    just to give my 5 cent´s..

    using them now since 3 days or so and i have to say, they are stable and fast..no problems, even resizing works and image quality is normal, not as good as quadros but also good..

    Dragon age 2 runs good now without errors with dx11 and all settings to highest..
    Crysis 2 runs great, shift 2 also..i didnt found a game where i have encountered problems so far..and i have around 60 games installed..from Fear combat to the newest Crysis 2..

    Frames went up a lil in some games, some its the same...nothing special..

    gretez Beta
     
  6. Memorian

    Memorian Ancient Guru

    Messages:
    3,187
    Likes Received:
    281
    GPU:
    RTX 3080 Ti
    Lol no problems here.
     
  7. sykozis

    sykozis Ancient Guru

    Messages:
    21,991
    Likes Received:
    1,178
    GPU:
    MSI RX5700
    AB2.0 now shows GPU usage in excess of 1 billion %..... It actually made me laugh when I saw it.
     
  8. macdaddy

    macdaddy Ancient Guru

    Messages:
    2,400
    Likes Received:
    4
    GPU:
    TITAN X
    DA2 is great in DX11 all maxed out with this set.
     
  9. JohnDoeGamer

    JohnDoeGamer Member

    Messages:
    13
    Likes Received:
    1
    GPU:
    EVGA 1080ti Gaming
    Do you overclock at all or do you have a card that is factory overclocked? Just wondering if that is what is causing our issues.
     
  10. Saabjock

    Saabjock Master Guru

    Messages:
    359
    Likes Received:
    70
    GPU:
    PNY GTX1070XLR8
    Mine does... Great driver in everything I've run so far. About 15% better framerates and more importantly....super smooth.
     

  11. Baldassano

    Baldassano Member Guru

    Messages:
    172
    Likes Received:
    7
    GPU:
    2x MSI 1080ti SHWK
    Welloverall i have seen things running nicely with these, but i am still haveing nothing but issues with NBA2k11.. Getting 40-50FPS with everything on max, and the game is stuttering and jumpy.. the game has lost alot of the fluidity of the previous (267) driver i was on...

    It just doesnt make any sense.. MLB2k11 runs at 150fps, all maxed out.. isnt it the same engine? I tried movnig things around in the SLI profile butnothing has helped.. It sucks cause its the one game i was playing most of all..

    Very dissapointing, gonna have to wait for next release, cause i dont want to lose the improvements in everything else.
     
  12. VenoMaizeR

    VenoMaizeR Member Guru

    Messages:
    123
    Likes Received:
    0
    GPU:
    Asus Strix RX480OC 8gb
    Dunno why but the Quadro´s are working better then this versions on my 470. Cant find a single one of the oficials that works better (smooth without gliches).
     
  13. wrathloki

    wrathloki Ancient Guru

    Messages:
    1,569
    Likes Received:
    68
    GPU:
    EVGA FTW3 3070 ti
    I'm getting severe screen tearing in Civ V since I updated to this driver, even with vsync on or off in game or forced through the control panel. I did as clean an install as possible with these drivers so all I can think is it must be the drivers.
     
  14. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    They haven't caused me any problems, I have noticed some slight blurring though...
     
  15. holtehero

    holtehero New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    Zotac GTX580
    Worked fine in Crysis 2 and Bulletstorm, but wouldn't run World in Conflict at all, then found out that 270.32 also wouldn't run this (Game won't load at all)

    So have gone back to 267.91 as these seem to be most compatible
     

  16. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,056
    Likes Received:
    572
    GPU:
    EVGA GTX 1080 Ti SC2
    World in Conflict (with Soviet Assault expansion) is working fine for me with the 270.51 betas. The game is patched to the latest version.

    What error were you getting?
     
  17. holtehero

    holtehero New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    Zotac GTX580
    I'm using the complete edition an it just doesn't start at all, i get the first screen which shows latest news, but when i click start game it just shows the desktop.

    When i roll back to 267.91 or earlier then i have no problems and as soon as i click start game it shows the Ubisoft screen almost straight away.

    EDIT: I updated to patch 11 and for me it still doesn't work on any of the 270.xx branch, fine on 267 and earlier
     
    Last edited: Apr 4, 2011
  18. Jammed_Death

    Jammed_Death Active Member

    Messages:
    74
    Likes Received:
    0
    GPU:
    Gtx560 TI Hawk
    anyone knows why the nvidia cp says that i have the 260.99 installed even if i have the 270.51 installed?
     
  19. qqiiipp

    qqiiipp Member Guru

    Messages:
    140
    Likes Received:
    1
    GPU:
    ASUS Strix GTX 970
    You have to uninstall previous drivers before you install the latest. You can also use "Driver Sweeper"(handy little tool) after you do uninstall just to make sure everything is nice and clean(search the forum there is too many threads about it). You can also check the "Perform clean install" just before you press "install" button for the new drivers.
    It seams you skip one of the steps above or all of them. At the end there is always an army of trolls complaining about "5hity" drivers.
     
  20. Jammed_Death

    Jammed_Death Active Member

    Messages:
    74
    Likes Received:
    0
    GPU:
    Gtx560 TI Hawk
    i'm sure i did a "clean install" with the nvidia installer...
     

Share This Page