ForceWare 174.70 for XP/VISTA(32bit & 64bit)

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by gpxjohn, Mar 21, 2008.

  1. dren72

    dren72 Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    ATI 4870X2
    Works here. I just installed these and tried the newest WinDVD 9. Purevideo is definitely working here.
     
  2. F_L_C

    F_L_C Member Guru

    Messages:
    112
    Likes Received:
    0
    GPU:
    eVGA 7800GS
    There have been multiple posts throughout this thread saying this driver needs a modified INF to work w/ older cards. NOT TRUE. This is truly a unified driver and will be recognized for virtually every desktop/laptop GPU w/ no modification whatsoever.
     
  3. TheHunter

    TheHunter Banned

    Messages:
    13,405
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    lol:D,
    no cuz i took a survey - Help Us Make NVIDIA.com Better

    and told them here
     
  4. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,733
    Likes Received:
    708
    GPU:
    MSI 2070S X-Trio
    As tomorrow's Quad SLi day, so the Quad drivers for the GX2 will be released, and then be modded for other cards. :)
     

  5. jamiee

    jamiee Active Member

    Messages:
    77
    Likes Received:
    0
    GPU:
    EVGA GTX 680 Classified

    Didn't work for me using aBra's modified INF set using Vista 32bit.

    I first installed the driver then after a reboot, installed the PowerDVD 3730a update.
    PDVD still reports an incompatible video driver when I try to playback any HD discs.
     
  6. aBra

    aBra Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    ATI Radeon HD 4870
    I'm using my own inf and it's working here. :/
    Dunno what's causing that problem.
     
  7. jamiee

    jamiee Active Member

    Messages:
    77
    Likes Received:
    0
    GPU:
    EVGA GTX 680 Classified

    Maybe it only works with G92 and not G80 cores?
     
  8. Loster

    Loster Member Guru

    Messages:
    189
    Likes Received:
    14
    GPU:
    GTX 1080
    I have a g84 GPU and bluray/hdvdvd are working like a charm now.

    The best driver for my system so far.
     
  9. ViperXtreme

    ViperXtreme Ancient Guru

    Messages:
    3,124
    Likes Received:
    22
    GPU:
    GTX 1070 Super Jetstream
    any noticable difference between this and 174.16? (9600GT)
     
  10. jamiee

    jamiee Active Member

    Messages:
    77
    Likes Received:
    0
    GPU:
    EVGA GTX 680 Classified
    Ok I finally got things working!!

    Turns out that I needed to install the original download provided here (XFastest), this however creates a problem in that I can't access 1920x1080 res. and end up with a max of 1400x1050.
    But I just tried to create a custom resolution of 1080P and it worked!
    Even better -- PowerDVD Ultra now works too :banana:

    Not sure why I never thought of making a custom res before :bang:

    Live and learn.....
     

  11. Osuperman

    Osuperman Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    ATI 5850
    Rathbone, frytom, PaulvH, dren72, jamiee, aBra...

    Thanks for the replies! Good to know it's finally working properly. I think I'll try these drivers out... :D
     
  12. Rathbone

    Rathbone Active Member

    Messages:
    98
    Likes Received:
    0
    GPU:
    Asus Strix RTX2070
    I have just installed it again and I can confirm, it doesn't work on my HTPC.

    PowerDVD 7.3.3730a says incompatible driver, Showtime 4 has a very pixelated image und ArcSoft TMT only gives me a black screen with sound. This driver is still broken imho. Went back to 174.40 and all is good.

    WinDVD 9 works though.

    OS is Vista 32 SP1.
     
    Last edited: Mar 25, 2008
  13. blow

    blow Member

    Messages:
    38
    Likes Received:
    0
    This driver are better or worse than 174.31(best vista 64 driver i think)?
     
  14. FrenchKiss

    FrenchKiss Master Guru

    Messages:
    337
    Likes Received:
    2
    GPU:
    Gigabyte GTX970 G1 GAMING
    Some Crysis benchmarks (yeah again). I used the new HardwareOC Crysis Benchmark v1.1.1

    WinXP x32 SP3 3300, Crysis Retail 1.2.1, dx9 with very high tweaks (from all over the Internet + my personal modification, so you can't rly compare to ur system ^^)

    Resolution: 1920×1200 (HD WideScreen)

    Driver version: 6.14.0011.7470 (English)
    Result: Minimum= 21.76 FPS Average= 27.31 FPS Max= 38.92 FPS

    Driver version: 6.14.0011.7460 (English)
    Result: Minimum= 21.68 FPS Average= 27.28 FPS Max= 38.66 FPS

    Driver version: 6.14.0011.7453 (English)
    Result: Minimum= 21.80 FPS Average= 27.29 FPS Max= 38.87 FPS

    Driver version: 6.14.0011.7440 (English)
    Result: Minimum= 21.44 FPS Average= 27.25 FPS Max= 38.31 FPS

    Good IQ, and stable too. Keepers so far.
     
  15. MiracleMan

    MiracleMan Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    8800gt 512mb
    Last night I tested Need for speed prostreet with 174.70 drivers and AA are broken. Even at AA 8x I get aliased borders with white dots.
    Going back to 174.53
     

  16. scandalous

    scandalous Master Guru

    Messages:
    718
    Likes Received:
    4
    GPU:
    980TI Classified
    I have a problem with these drivers. Everything seems to run smooth and better in every game and i really believed they were keepers. But then I wanted to play bf2 and then when i start the game my computer crashes completely. I have to shut the computer down via the power button.

    The game crashes Immediately on start up, the screen flickers 2 times (this is just the screen going from 120hz to a lower hertz) and then when when the EA games icon is popping up it freezes.

    When I uninstall the drivers and install the 163.76 drivers or the 169.21 the game works but the 169.21 drivers are really crappy and the 163.76 are not as smooth as the 174.70.

    Does anyone have a solution to my problem with bf2?

    My specs.

    Nvidia xfx 8800gts 320mb
    intel e8200 2.66ghz
    4gb ddr2 800mhz
    power supply: 650w
    On xp x64
     
    Last edited: Mar 25, 2008
  17. frytom

    frytom Member

    Messages:
    41
    Likes Received:
    17
    GPU:
    MSI RTX 3090

    You need the correct inf file. Try the original modded version (the chinese one).
    The newer inf mods (made and provided here in this forum) mods break with the hdcp / nvidia purevideo driver.
     
  18. escalibur

    escalibur Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    GTX 980 Ti STRIX (soon)
    Does anyone know is there any way to make RivaTuner detect these 174.70 drivers in Vista x64?:3eyes:
     
  19. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,733
    Likes Received:
    708
    GPU:
    MSI 2070S X-Trio
    They've just updated their site, 174.53's now have Quad SLi support in their Vista sets, also XP sets dated for today as well now, though **** knows what they added into those to change the date. :D
     
  20. Rathbone

    Rathbone Active Member

    Messages:
    98
    Likes Received:
    0
    GPU:
    Asus Strix RTX2070
    Thanks, downloaded the Xfastest package and it worked. Do you know which part of the inf is responsible for video and HDCP settings?
     

Share This Page