Force maximum screen refresh rate to be 120

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by alb3530, Oct 27, 2020.

  1. alb3530

    alb3530 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Nvidia
    Brief description of the problem:
    When lauching game "The Crew 2" (and "The Crew" as well) in full screen mode, it switches refresh rate from 120 (desktop refresh rate) to 144 (max supported resolution).

    Detailed description:

    I'm using Windows 10, and current refresh rate is 120.
    My monitor supports 144, but 120 is the highest refresh rate possible for ULMB, which I use.

    The problem is when I open the game in full screen mode, it switches refresh rate from 120 to 144: in fact, it doesn't matter what refresh rate Windows is set to, the game will always force the monitor to be at its maximum refresh rate. This makes ULMB unable to work.

    Things I've tried (no success):

    -"Preferred refresh rate" option in NVIDIA Control Panel;
    -Editing game file "PCScalability.xml" (no apparent option to limit the refresh rate);


    Things I haven't tried:

    -SpecialK (game uses BattleEye);
    -Memory Editing (game uses BattleEye);
    -Disassemble/Reverse Engineering (game uses BattleEye);
    -Windows Registry editing (not tried yet)

    I thought about other possibilites, like making Windows thinks max refresh rate of the monitor is 120 (instead of 144), but before trying to do things like this, I'd like to know if there's something less evasive I can do to avoid switching refresh rate to 144. Maybe this can be done with Nvidia Profile Inspector, but if it's possible, I don't know how this can be done.

    If you know any other solutions (like registry editing)

    Thanks!
     
  2. Astyanax

    Astyanax Ancient Guru

    Messages:
    8,409
    Likes Received:
    2,810
    GPU:
    GTX 1080ti
    did you try going into the game settings and setting <Current resolution@120>
     
  3. JaylumX

    JaylumX Master Guru

    Messages:
    547
    Likes Received:
    14
    GPU:
    RTX 2070S
    Have you explored using CRU to edit the EDID and remove 144hz?
     
    Mda400, Cyberdyne and Cave Waverider like this.
  4. Caesar

    Caesar Maha Guru

    Messages:
    1,210
    Likes Received:
    460
    GPU:
    GTX 1070Ti Titanium
    Monitor Specs/Details?
     

  5. alb3530

    alb3530 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Nvidia
    The game doesn't have a refresh rate setting, but only a frame rate setting, with either 30 or 60 as options (I'm using 60)
    XML settings file also doesn't have any refresh rate setting.

    As an additional info, desktop resolution is 2560 x 1440, and game is set to that same resolution.

    ASUS ROG Swift PG279Q
    https://www.asus.com/us/ROG-Republic-Of-Gamers/ROG-SWIFT-PG279Q/



    No, but that was a good one!


    I had opened CRU before posting here, but it didn't show any resolutions in "Standard Resolutions", so I blindly closed the app.

    But it seems just what I'm looking for, thanks!

    It worked!

    In my case, there's no downside in doing this method (144hz becomes unavailable after doing this), as I'm using ULMB globally, so i don't need 144hz.


    This is what I did:

    -Opened CRU (admin required);
    -Did the following steps:

    upload_2020-10-28_20-48-32.png


    -In Device Manager, selected the GPU, and right clicked "Disable Device";

    -In Device Manager, selected the GPU, and right clicked "Enable Device";

    Note: I could use "restart64.exe" utility in CRU folder instead using Device Manager.
     

Share This Page