For those having black screens on windows boot...could you check something.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by mtrai, May 7, 2015.

  1. mtrai

    mtrai Maha Guru

    Messages:
    1,175
    Likes Received:
    369
    GPU:
    PowerColor RD Vega
    After reading literally hundreds of threads and trying every driver under the sun.

    I have the found the offending issue causing my r9 290x black screening on boot up. If I disable CCC I do not get black screens.

    If I reenable CCC it black screens on boot. I have tried tried drivers going back to 13 something. Some CCC work better but still black screen.

    Anyhow if your having this issue with your card try disabling CCC.
     
  2. maxstep

    maxstep Member Guru

    Messages:
    128
    Likes Received:
    0
    GPU:
    SLI 2x 980Ti AMP! Extreme
    That's a great advice! I frequently get black screens on one of my panels on a cold boot, although a reboot fixes it in 99% of the cases.
     
  3. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    just delay the start so the desktop boots up before CCC loads.
     
  4. mtrai

    mtrai Maha Guru

    Messages:
    1,175
    Likes Received:
    369
    GPU:
    PowerColor RD Vega
    What I am trying to figure out is if CCC starting up with windows is the true cause of the dreaded R9 series and similar cards black screen on boot up.
     

  5. toasty

    toasty Member Guru

    Messages:
    113
    Likes Received:
    8
    GPU:
    2080Ti Trio X
    My current card never blackscreened on boot except for if I saved an unstable mem OC in Afterburner, which set to apply on startup; would reproduce the black screen lock up guaranteed.
    It will black screen the same but under load if an unstable mem OC is applied during testing.

    I've had 290s that would black screen as soon as they get a whif of the driver (crash during usual display flicker portion of install.) These cards would also sometimes crash on boot when loading the driver and/or ccc and were not stable at idle unless running the memory underclocked, yet fully stable under load.
     
  6. mtrai

    mtrai Maha Guru

    Messages:
    1,175
    Likes Received:
    369
    GPU:
    PowerColor RD Vega
    I think I stumbed on a possble solution on the black screening / black screen lock up during boot up and driver install. Working with the people over at leshcat driver they mod for switchable graphic and mobile system even though I have a desktop

    So far 2 days without black screen, and multiple drivers installs with CCC correctly with no black screens/ black lock ups during installs.

    The thoughts at this time is a simple dword registry settings, but investigating further.
     
  7. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    This could be related to power state change of GPU (and voltages).

    Try to "force constant voltage" in Afterburner options, this prevent voltage drop at idle and black screens in your case.
     
  8. Demrock

    Demrock Member

    Messages:
    45
    Likes Received:
    0
    GPU:
    Sapphire Boost 7950x2
    On W10 build 10074 it always crashes...

    Tried the W10 automated drivers and the 15.4 drivers wich doesnt seem to help.

    Downloading 15.4.1 but i dont have much hope.
     
  9. mtrai

    mtrai Maha Guru

    Messages:
    1,175
    Likes Received:
    369
    GPU:
    PowerColor RD Vega
    Let me try to help...from what I have have found.

    Can you try this set of drivers: http://www.leshcatlabs.net/forums/viewtopic.php?f=6&t=859

    Make sure you use DDU to nuke all graphics drivers.

    Please report back...You will have to do a manual install due to the drivers are set up for switchable graphics. Just follow the instructions on the forums.
     
  10. Demrock

    Demrock Member

    Messages:
    45
    Likes Received:
    0
    GPU:
    Sapphire Boost 7950x2
    I downloaded the 15.4.1 drivers and it seems booting up windows 10 build 10074 seems to have fixed the crashes so far.

    Done about 15 reboots and no crashes \o/

    Thanks for the assistance sir :)
     

  11. mtrai

    mtrai Maha Guru

    Messages:
    1,175
    Likes Received:
    369
    GPU:
    PowerColor RD Vega

    Glad I could help. I was to the point of RMA'ing my new card due to this issue, but kept thinking it was not hardware but driver related during start up.

    I also tried the beta ones that were released yesterday and it seems to have fixed the boot up driver issue as well as leshcats did.

    Just remember if you are using win 10 when you up date and sometimes whenever it f'ing feels like will install the win 10 TP amd drivers and CCC which fails. I have had to use ddu to reinstall the working drivers.

    My thoughts on this is the card goes into a zero power state and something with the CCC during boot up hangs.

    Also if you do not need CCC, the drivers work perfect without it and that it what hangs and causes the black screen on boot up.
     
  12. Eoma

    Eoma Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    Palit GTX 1070 SJS
    Hey guys, i just moved from a dead Sapphire 7950 boost (vertical red lines, grey screen lockup) to a used Asus R9 290 DCUII OC (got it for ~$194). Still has warranty till Q1 2017, works great and fortunately no blank screen crashes during bootup or driver installs.
    BUT, it randomly loses the monitor signal, image blanks out and then displays again.
    There is no hang or crash during these blankouts/blackouts and seems to happen in both in 2D (surfing, general windows) as well as 3D loads (playing SoM now, awesome game by the way).
    I've tried increasing the 2D clocks (via Asus GPU Tweak) to 450/500 as suggested by some, but it still happens. Will take a look at the Windows power settings as well.
    PSU is a 1000 watt Corsair.
    Latest Omegas and 15.4 drivers show the same issue.
    Any idea ?
     

Share This Page