For Steam users trying to run SweetFX w/ Watch_Dogs

Discussion in 'Games, Gaming & Game-demos' started by jdwohlever, Jun 23, 2014.

  1. jdwohlever

    jdwohlever Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    NVIDIA Titan w/ 6GB RAM
    ATTENTION STEAM USERS:

    Here is what you HAVE to do to get it Sweet FX to work with Windows 8/8.1:
    THE FIRST TWO RULES ARE THE MOST IMPORTANT to make this work on Windows 8/8.1

    After doing everything else in RadeonPro to get Watch_Dogs set-up for SweetFX (found in other threads), there is another step you have to take,
    1) In RadeonPro, On the right hand side for the settings for watch_dogs settings, choose the LAUNCHER Tab and select STEAM

    2) Make sure that Steam nor Uplay does !!NOT!! start with Admin privileges. I tried for hours to get this to work, and it wasn't until I ran BOTH uplay and Steam WITHOUT Admin privileges that it would actually work.
    I know that sounds a55 backwards, but that is the way it is. NOTHING should be running with extra Admin settings. Not RadeonPro, not Steam and Not Uplay.

    Also, here are my other settings that maybe JUST as important:
    3) Make sure Uplay is NOT running before starting game.
    4) Make sure RadeonPro and Steam ARE running.
    5) Make sure Uplay does have Overlay ON.
    6) Not sure about Steam, but I have my Steam Overlay OFF and Uplay Overlay ON
    7) Start game from Steam

    8) Profit!*
     
  2. jdwohlever

    jdwohlever Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    NVIDIA Titan w/ 6GB RAM
    Wow, not one reply, this didn't help one single person?
     
  3. brunopita

    brunopita Banned

    Messages:
    611
    Likes Received:
    0
    GPU:
    MSI Gaming R9 270X 2GB
    I have both Steam and Uplay overlay turned off. Didn't try with different options.
     

Share This Page