for 6800gt/ultra users (only PCI-E)

Discussion in 'RivaTuner Advanced Discussion forum' started by legolasgleaf, Jun 2, 2006.

  1. legolasgleaf

    legolasgleaf Member Guru

    Messages:
    194
    Likes Received:
    0
    GPU:
    Quadro FX3500
    My card is a XFX 6800GT pci-e with softmod qfx4000

    I read in wikipedia that the fx4400 is a nv40 br02 (nv45), that is the same as 6800gt/ultra.

    I found in m*vktech the fx4400 bios:
    http://www.m*vktech.net/component/o...func,fileinfo/filecatid,1386/parent,category/

    (when you click, and the browser opens the url, delete the asterisk)

    I compare with my own backup and both have the same size (not with dell fx4000).

    And open with a hex editor I see:

    that my bios post show: nv45 p211 sku4 VGA BIOS
    and the fx4400 show: nv45 p214 sku0 VGA BIOS

    version my bios: Version 5.40.02.36.09
    version fx4400 bios: Version 5.40.02.38.10

    date my bios: 12/03/04
    date fx4400 bios: 01/07/05

    I see that both bios are very similar and the fx4400 is newer.

    I don't prove if this works, for two reasons:
    1) fx4400 has 512mb and my card 256mb (with an ultra 512mb card, don't problem) I DON'T KNOW IF IT'S NEEDED.
    2) fx4400 has 400mhz/525mhz and my card 350mhz/500mhz (with an ultra card, don't problem, I think)

    I'm really wormed for the first reason, but I don't know if the bios need this...

    Somebody know to change the bios with different settings?

    Thank you.
     
    Last edited: Jun 2, 2006
  2. legolasgleaf

    legolasgleaf Member Guru

    Messages:
    194
    Likes Received:
    0
    GPU:
    Quadro FX3500
    Finally I prove the bios of fx4400.
    Works, but with many artifacts (in the beginning post when should be to show "nv45 p214 sku0 VGA BIOS", and after in windows).
    I think that the allocation is different (because 256mb vs. 512mb) and maybe cause problems. One of the reason could be this.
    Then I return to the original bios without any problem.
    Looks like that not be dangerous at least what I did.

    Thank you.
     
    Last edited: Jun 2, 2006
  3. legolasgleaf

    legolasgleaf Member Guru

    Messages:
    194
    Likes Received:
    0
    GPU:
    Quadro FX3500
    Nobody knows how to change the bios?

    For PCI-E users could be very important.

    Thank you.
     
  4. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,471
    Likes Received:
    2,770
    You judge about BIOS similarity just by image file size? Ever heard about per-byte comparions? I'm afraid that I've to disappoint you, that is 100000000 times harder than you're assuming.
     

  5. legolasgleaf

    legolasgleaf Member Guru

    Messages:
    194
    Likes Received:
    0
    GPU:
    Quadro FX3500
    I'm not assuming nothing. I'm not judge the BIOS for the size only. This is one of the points. For example the DELL01 bios of the fx4000 isn't same size respect to my own BIOS.
    If you open the XFX 6800gt rom (my bios) and open the fx4400, they look like.
    And fx4000 do not look like.
    And other thing: "I HAVE PROVEN IT", and I'm looking for someone that helps me. If they isn't look like, don't works at all, and IT WORKS, but with artifacts. I think that fixing the problem (I think that the problem is the addressing... and problem of different sizes 256mb vs 512mb) must would works well.
    I know that is very difficult.
    If I know how to make it, I would not request help...
    Thank you.
     
    Last edited: Jun 3, 2006

Share This Page