Flickering issue with 460.79 ? This simple step solved it 100% for me!

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by PC-Tweaker, Dec 12, 2020.

?

Did it work for you ?

  1. Yes

    10.0%
  2. No

    90.0%
  1. PC-Tweaker

    PC-Tweaker Member

    Messages:
    15
    Likes Received:
    8
    GPU:
    3080 Trinity Zotac
    Edit: After further testings, it seems that MSI mode is not the reason why my issue went away, will update my post #4 with new findings with further testing as it's a wip right now.

    Hey guys,

    Long time reader here but registered today to let you guys know about this fix (since ya know, couple of million of people might be interested to get those drivers working for optimal experience for Cyberpunk 2077 ;))

    My main setup:
    MSI Z270 Gaming M5
    6700k
    1080Ti MSI Gaming X
    W10x64 - 20H2 (Build 19042.685)

    And for the purpose of this post, my monitor:
    Dell S3220DGF hooked through DP @ 164Hz - Gsync compatible always enabled + Vsync On in Nvidia cp

    * I always install minimal drivers as I remove all the clutter and only leave the Display.Driver, NVI2 and Physx folder only, so it might (or not) have an impact. I Also constantly use MSI afterburner (currently 4.6.2) and RTSS that comes with the install.

    So, right on install of those 460.79 (I also always use DDU in safe mode prior to install), I got right away that screen flickering issue (which I never had before) and it was bad, obvious flickering that could not go unnoticed, even idle on desktop...

    Nevertheless, I did my usual extra step (which I do right after each fresh install of Nvidia drivers because Nvidia has this disabled by default), just in case it might change something... and it totally did!

    The fix:
    I just put my gpu in MSI mode (Message Signaled-based Interrupts), rebooted, never had one flicker since!

    For those who dont know about MSI mode, just read @mbk1969 's excellent post and download his tool (link for it is in his 1st post) here: https://forums.guru3d.com/threads/w...ge-signaled-based-interrupts-msi-tool.378044/

    For those who don't want to edit their registry manually, with his great great tool that he provided us with, literally a couple of mouse clicks, reboot and you're done!

    YMMV because not 100% of configs play nice with MSI mode, but those problems should be limited to very old configs / gpu's. Any "relatively new" (roughly 5 years or less) hardware shouldn't have any problems with MSI mode for your GPU.

    Hope this helps at least a few of you out there and if it does, spread the word! ;)
     
    Last edited: Dec 12, 2020
    enkoo1 and Singleton99 like this.
  2. MajorMagee

    MajorMagee Active Member

    Messages:
    58
    Likes Received:
    14
    GPU:
    GTX 670
    Just to be thorough in understanding the depth of your testing, did you turn MSI mode back off again, reboot and have the flickering come back?
     
    PC-Tweaker and fluidz like this.
  3. Caesar

    Caesar Maha Guru

    Messages:
    1,287
    Likes Received:
    484
    GPU:
    GTX 1070Ti Titanium
    Still i cant understand....
    Edit: after reading thrice the topic...ok
    ---------------
    Good....
    .................
    o_Oo_Oo_Oo_Oo_O
    ..................

    BTW......which type of latency does your fix applies to ?
     
    Last edited: Dec 12, 2020
  4. PC-Tweaker

    PC-Tweaker Member

    Messages:
    15
    Likes Received:
    8
    GPU:
    3080 Trinity Zotac
    Good point. I actually thought about it before posting, but the saying "if it ain't broken, don't fix it" won me over before posting ;)

    Technically and logically speaking, the MSI mode should be the reason why it went away considering the following steps I took:

    - DDU in safe mode, rebooted
    - Installed my slimmed driver, the screen flickering started right after insatllation was completed. I did the usual with my settings in Nvidia cp, rebooted
    - On reboot, screen was still flickering, applied MSI mode on my gpu, rebooted
    - No more flickering on reboot, started MSI Afterburner, all is good since then

    But yeah, will try the reverse engineering theory to be more thorough to confirm if flickering comes back in "IRQ" mode and will edit this post with the result.

    @Caesar
    My flickering issue / fix isn't related to latency, but rather refers to what some other people also seemed to experience in the 460.79 discussion thread (i.e., post #32, and see the 1st video in post #47 by @Mbi2011 is the perfect example of the issue I was having too. I also just noticed that he and @Witcher29 also both have a 1080Ti, so maybe it's a specific issue / fix related to 1080Ti's ?... Updated: See Edit 3, it is related to 1080Ti's)

    Edit 1:
    @MajorMagee : You just broke my PC (and my Cyberpunk quality time) lol ;)
    Joking apart, I tried disabling MSI mode, didn't have any flickers in +-5 minutes, so I decided to uninstall and reinstall those drivers to recreate the flickering issue (which worked, unfortunately lol) but his time, I started right away with the MSI mode, rebooted, and still have flickers... So for sure, MSI mode on its own is not the fix, but maybe combined with some specific Nvidia CP settings and/or MSI afterburner / RTSS settings... Really strange though because I was flicker free since my "fix" on release day (Dec 9th), will try some further testings and report back because now, thanks to Major, I have a flickering issue to deal with lol :p;)

    Edit 2:
    Ok, so up to now (roughly 45-60 minutes), no flickers, no MSI Afterburner / RTSS running, no MSI mode for my GPU, only things I have tinkered with are the Nvidia CP settings. And the thing that lets me believe that Nvidia's CP settings are at fault is that when I reverted all the settings to default, the flickering issue came back... But the weird thing is, there is not one specific setting that seems to make THE difference. I tried changing the settings one by one, still got a flicker here and there, but it seems that over time (roughly 5-10 minutes after all my final settings) and a reboot or two, the flickering just... disappears!... So best that I can do is to post screen captures of my CP settings that I changed so that you can try and replicate those to see if those works for you. I've highlighted all the changes I did vs default settings.

    @EdKiefer : I now use "prefer maximum performance" since I saw a post (here I think) that mentionned that "maximum performance" might alleviates microstutters in some games (as opposed to Adaptive or Performance), but I did not do any extensive tests regarding this specific claim.

    3D settings 1.jpg 3D settings 2.jpg Change resolution.jpg Gsync.jpg Physx.jpg

    Edit 3:
    It is confirmed on Nvidia's website that this issue seems to be specific to 1080Ti's:
     
    Last edited: Dec 13, 2020
    enkoo1, Caesar, fluidz and 1 other person like this.

  5. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,646
    Likes Received:
    275
    GPU:
    MSI 970 Gaming 4G
    Do you leave the global power management setting to optimal or adaptive mode?
     
  6. MajorMagee

    MajorMagee Active Member

    Messages:
    58
    Likes Received:
    14
    GPU:
    GTX 670
    Sorry, I'm an engineer, so I tend to be pretty rigorous in my root cause testing before I start being definitive with any diagnosis.
     
    big ROBOT bill and BuildeR2 like this.
  7. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,311
    Likes Received:
    3,704
    GPU:
    GTX 1080ti
    toggling the driver in device manager is what did it.
     
  8. DaRkL3AD3R

    DaRkL3AD3R Member

    Messages:
    48
    Likes Received:
    7
    GPU:
    GTX 1080 Ti STRIX OC
    Set your GPU to higher power states and it goes away. I personally use MSI Afterburner to lock my GPU at the 1.063/1.050 voltage point (aka max stock turbo boost) but also setting the Nvidia control panel to Prefer Maximum Performance in the Global profile and then rebooting will also make it go away. The trigger is being at the true idle power state of 139Mhz core and 101.5/405Mhz memory.

    If you have multiple high resolution or refresh rate monitors hooked up, this prevents your GPU from being in idle clocks so that's why some people with 1080 Tis aren't noticing this problem.
     
  9. PC-Tweaker

    PC-Tweaker Member

    Messages:
    15
    Likes Received:
    8
    GPU:
    3080 Trinity Zotac
    Don't be sorry Major, on the opposite, you brought up an excellent point, so good in fact that it confirmed I was wrong on my 1st impression for the fix (I took a result for granted without reverse engineering = I was a bit sloppy in the name of "science" ;)) and we're all here to try to help others (not confuse them with the wrong fixes!)

    I'm curious, could you be a bit more specific of the steps you took in the device manager ? Because altought I didn't went there at all, I don't have the flickering anymore, so you may have a different workaround for this same issue that might work for other people too ?...

    @DaRkL3AD3R
    I would have to say that this does not seem to be the trigger (on my end at least) because I'm also afflicted with the idle bug since the last 4-5 drivers (meaning my monitor - the only one, not runnung multiple monitors here - does not go in idle @139Mhz anymore, it actually doesn't go below 1544Mhz even idling on desktop no apps running and I did tried all 3 power states and I still had the flickering issue at first even idling @1544Mhz). But maybe you're on to something and it would actually have something to do with the voltages (maybe not same voltage curve as previous drivers ?...)
     
    Last edited: Dec 13, 2020
  10. DaRkL3AD3R

    DaRkL3AD3R Member

    Messages:
    48
    Likes Received:
    7
    GPU:
    GTX 1080 Ti STRIX OC
    I'm going to try locking at 1544Mhz (0.793v) and see if the issue happens. I doubt it will because even at slightly lower clock speeds I wasn't triggering the glitch. Only at idle clocks does it present itself for me.

    Update:
    Even at the absolute lowest voltage point MSI Afterburner lets me set it to (0.700v at ~1177Mhz) I saw 0 flashing over a 30 minute period of time. Setting my GPU to dynamically downclock to its true idle state of 139Mhz, I immediately started seeing flashing and flickering within seconds. I don't know what else to say here. This is a definitive fix for me, raising clock speeds. And it corroborates with what multi-monitor users and elevated clock speeds say about not seeing any flickering either. It's only the people with single monitor setups and low idle clocks that are seeing this problem.
     
    Last edited: Dec 13, 2020
    enkoo1 and PC-Tweaker like this.

  11. PC-Tweaker

    PC-Tweaker Member

    Messages:
    15
    Likes Received:
    8
    GPU:
    3080 Trinity Zotac
    That would actually be incorrect as I had this problem with my single monitor setup @ (bugged) idle speed of 1544Mhz... ;), but...

    Thanks to your update, I think the picture is getting clearer. With your tests, results and infos, I would assume that you don't have a high refresh rate (i.e. 120hz+) monitor right ? (My assumption being based on the fact that you are able to idle @ 139Mhz with this driver, which currently doesn't seem possible with the latest drivers + high refresh rate monitors).

    So this leads me to believe that there are different causes / fixes depending on the different setups / configs and according to your findings, it seems that the workaround for people with "low" refresh rate monitors would simply be to raise idling clock speeds.
     
  12. DaRkL3AD3R

    DaRkL3AD3R Member

    Messages:
    48
    Likes Received:
    7
    GPU:
    GTX 1080 Ti STRIX OC
    I have a 2560x1440 144hz display. My GPU idles at 139Mhz correctly.
     
  13. PC-Tweaker

    PC-Tweaker Member

    Messages:
    15
    Likes Received:
    8
    GPU:
    3080 Trinity Zotac
    Ok... down the drain goes my theory vs the refresh rates lol ... Unless the idling bug affects higher refresh rates than 144hz as mine is also a 1440p monitor, but @ 165hz (and I unfortunately don't have a 144hz native option, it's eithier 164Hz or 60Hz through DP)...

    You're hooked through DP or DVI ?
     
  14. DaRkL3AD3R

    DaRkL3AD3R Member

    Messages:
    48
    Likes Received:
    7
    GPU:
    GTX 1080 Ti STRIX OC
    DP. My monitor can overclock to 165hz and with gsync off my GPU will idle at high clock speeds but with gsync on it downclocks properly.

    You can try making a custom resolution with 120 or 144hz and see if you can replicate the low idle clocks. It is still bizarre that you're seeing it at high GPU clocks. It just doesn't add up with everything I've seen so far and experienced.
     
  15. PC-Tweaker

    PC-Tweaker Member

    Messages:
    15
    Likes Received:
    8
    GPU:
    3080 Trinity Zotac
    Ok, got everything figured out after further testings and the previous post.

    You were right on it @DaRkL3AD3R :
    The root of the flickering issue is indeed the idle clockspeed @139Mhz, so the official fix for the flickering is to raise the idle clockspeed (so yeah, by rebound, power management mode is a way to do so). (I unfortunately cannot edit my 1st post anymore, hence why I put the "official" fix in bold here).

    I also just figured out that my idle speed bug stuck @1544Mhz is actually a Windows 10 bug with the power management mode set at "maximum performance" (short story, I have a dual boot setup with Windows 8.1 - I know, lots of haters for this OS, but for me, it is rock solid and super smooth for gaming - and in Windows 8.1, eventhough I set global power management mode to "maximum performance", it still allows me to idle @139Mhz, but not happening in W10, remaining stuck @1544Mhz even idling on desktop... Another reason for me to prefer windows 8.1 ;). I basically did the W10 move for Cyberpunk, being a DX12 exclusive, otherwise W8.1 would still be my main OS)

    Last mystery also resolved (when I thought the flickering happened to me @1544Mhz): I tinkered with a lot of settings in the control panel at that time, including power management mode, which I set to maximum performance like usual, but most likely forgot to restart after continuing different testings, so I tought I was @1544Mhz when I later saw the flickering and looked at my CP with maximum performance, but in reality, "optimal" mode was still the one active without the reboot.

    So basically, case closed thanks to everyone's input!
     

  16. DaRkL3AD3R

    DaRkL3AD3R Member

    Messages:
    48
    Likes Received:
    7
    GPU:
    GTX 1080 Ti STRIX OC
    Thank you for confirming my findings. Yeah you need to reboot for NVCP Power Management config to change in global profile.
    As for the Windows 10 thing, it's odd because the Windows power profile should only affect the CPU. The Nvidia driver or any programs like MSI Afterburner are the only ones that can affect the GPU power mode. I am on Windows 10 20H2 build 19042.630 and right now setting Windows power plan to High Performance mode only locks my CPU to max OC turbo boost, while my GPU can still idle to 139Mhz.

    I hope Nvidia can resolve this without forcing higher clock speeds. Earlier drivers had this problem but albeit with significantly reduced occurence. As I typed this right now, the flash happened literally 13 times over the span of a minute. It's absurdly broken and demands a hotfix from Nvidia. At least we can temporarily circumvent it by locking the GPU to 0.700v or higher. At that voltage temperature and power draw is insignificantly raised over 139mhz, but it is still annoying having to deal with it.
     
  17. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,657
    Likes Received:
    7,902
    GPU:
    GF RTX 2070 Super
    @PC-Tweaker

    But still MSI mode is better than legacy one, theoretically speaking...
     
  18. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,311
    Likes Received:
    3,704
    GPU:
    GTX 1080ti
    i don't think pascal was ever meant to run 165hz displays at less than low power 3d anyway.
     
  19. Mufflore

    Mufflore Ancient Guru

    Messages:
    12,695
    Likes Received:
    1,290
    GPU:
    Aorus 3090 Xtreme
    An interesting development...
    I tried to change my new 3090 PC to MSI mode in Windows 10 and found it already was using it.
    This was most certainly set by the driver because I hadnt attempted to do this before, I had to download your util. (I normally use Win7)
    So moving forward (perhaps only on newer hardware) MSI mode might be used automatically.
     
    mbk1969 likes this.
  20. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,657
    Likes Received:
    7,902
    GPU:
    GF RTX 2070 Super
    So in a couple of NV cards generations no one will remember what MSI tool is...
    :cool:
     

Share This Page