Fix game stutter on Win 10 1703-1809

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Mott, Apr 3, 2018.

  1. Smough

    Smough Master Guru

    Messages:
    374
    Likes Received:
    54
    GPU:
    GTX 1060 3GB
    BIOS settings? Have you done any changes or tweaks to that? Also, do you run games on HDD or SSD?

    And yeah, 1607 is dated, but if it doesn't give you issues, then you should keep using it.
     
  2. jonaaa20

    jonaaa20 Member

    Messages:
    10
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    Disabled Intel SpeedStep, C-States and did a little RAM Overclock from CL16 to CL12 (not the cause, already tested without the OC, same.).

    And I use a 7200RPM HDD.
     
  3. Smough

    Smough Master Guru

    Messages:
    374
    Likes Received:
    54
    GPU:
    GTX 1060 3GB
    The lack of an SSD on your system makes thing harder to diagnose, because HDD are slow and sometimes cause stutter at some games.
     
  4. janos666

    janos666 Master Guru

    Messages:
    794
    Likes Received:
    83
    GPU:
    MSI RTX2060 6Gb
    Depending on how that switch is implemented, setting SpeedStep to Disabled in the firmware Setup might also disables TurboBoost (which implies that you also loose any manual CPU multiplier overclocking [if present] because OC is effectively a reconfiguration of the default Turbo multiplier limit).
    Disabling some C-states can also disturb TurboBoost (with the factory settings, only one or a few cores are allowed to use Turbo clocks at a time and only while a sufficient amount of other cores are fully idle which is determined by their Px/Cx states... although I think C1 is sufficient and it's really hard to disable C1, you can normally disable C1E and deeper states only but not C1) or Hyper-Threading (which is really a hit or miss anyways with games but ... yeah, I see your CPU doesn't have HT but I finished the thought...).
    So, I suggest you monitor your CPU clocks during some synthetic benchmarks and check if single-threaded loads enjoy Turbo clocks or not. Or re-enable TurboBoost in the Setup and use the Windows PowerPlan to disable the clock changes (set both min and max to 100%).
    (If you are really interested, there is a way to fully disable C states with a hidden PowerPlan option but it's very impractical.)

    That's where RAM caching can be really useful (and thus the forced purging of the cache might impact the performance the most).
     

  5. mbk1969

    mbk1969 Ancient Guru

    Messages:
    8,836
    Likes Received:
    5,791
    GPU:
    GeForce GTX 1070
  6. jaggerwild

    jaggerwild Master Guru

    Messages:
    779
    Likes Received:
    277
    GPU:
    EVGA RTX 2070 SUP
    I don't think you have a Hardware issue, I think you have a settings or software issue. We need the Exact spec's of your system to help you out, just giving us the memory size doesn't help you or us. We also need your cooling method, CPU,GPU and Case. What temps readings are you getting, ETC.
     
    Last edited: Mar 7, 2020
  7. jonaaa20

    jonaaa20 Member

    Messages:
    10
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    Okay.

    CPU: Intel Core i5 7400 @ 3.30GHz (Stock Air Cooler)
    GPU: GALAX NVIDIA GTX 1060 3GB Stock @ 1848
    RAM: 2x8GB Crucial Ballistix LT Gray 3000mhz CL15 @ 2400mhz CL12
    MOBO: H110M CS/BR BIOS ver. 4210
    CASE: AeroCool 500
    CASE FANS: (3x 120mm): DeepCool RF120W
    PSU: Corsair VS500 500W

    Extra Info: My GPU easily hits 82C so I undervolted to 862mV (from 1065) and created a fan curve then the temps are stable @ 70-72C.

    The CPU temp is fine, hits 63C max, the ambient is ~29C.

    About the games, I noticed some stuff...

    Every EGO Engine game stutters (GRID 2, GRID Autosport, DIRT 3), in GTA V, it runs fine but when I alt-tab or I open something like Spotify or a simple text file, the game slowly starts to stutter, it's much less stutter when I had 8GB RAM but it still stutter, in Story Mode I have some weird heavy stutter, probably it's a game issue since I saw some videos and people were having the same issue.

    Recently I've tested GTA: SA and i had some stutters, obviously I will not consider it since I've installed some mods.

    I think that's all I can report.

    EDIT:

    Another extra info:

    When I was using Windows 10 LTSB 2016 (1607) I had much less problems related to stuttering, the only stutter problem I had was related to VRAM or lack of RAM, nothing else, I really don't want to be stuck on 1607.
     
    Last edited: Mar 8, 2020
    jaggerwild likes this.
  8. jaggerwild

    jaggerwild Master Guru

    Messages:
    779
    Likes Received:
    277
    GPU:
    EVGA RTX 2070 SUP
    A good after market cooler is only about $20 for the CPU, which us way better then the factory cooler. That's some high temps for a GPU, I have mine adjusted with After Burner to full on all the time. My temps are 26C with out a loud and around 38 with a load. 82C is pretty high for a GPU, I'd assume that is causing it.Can you redo the TIM on it? Or have you sorry I didn't back read.
     
  9. jonaaa20

    jonaaa20 Member

    Messages:
    10
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    I don't think my issue is related with temps.

    82C is the 'normal' temperature of my GPU, my GPU isn't throttling by the way, same as my CPU.

    Also not related with SpeedStep or C-States, tried some power states but the result is the same.

    I guess I'm just unlucky.
     
  10. jaggerwild

    jaggerwild Master Guru

    Messages:
    779
    Likes Received:
    277
    GPU:
    EVGA RTX 2070 SUP
    82C is VERY HOT in degrees its 180 degrees, you don't think that's hot?
     

  11. Cyberdyne

    Cyberdyne Ancient Guru

    Messages:
    3,398
    Likes Received:
    186
    GPU:
    2080 Ti FTW3 Ultra
    Clearly they agree @jaggerwild because they changed voltage and fan speed to get to 72C. Which is perfectly fine.

    And i doubt 82C would cause stuttering, it would just severely down clock the core to stay at 82. Which is the cards built-in temp limit for GPU Boost, 88C being when you hit base clock for pascal usually.
     
    Last edited: Mar 8, 2020
    Smough likes this.
  12. jonaaa20

    jonaaa20 Member

    Messages:
    10
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    Yes, but this specific model runs @ 82C, so I undervolted to reduce the temps and prevent throttling.

    And like I've said, it still stutters, doesn't matter if the GPU is @ 60, 70 or 80C.
     
  13. Smough

    Smough Master Guru

    Messages:
    374
    Likes Received:
    54
    GPU:
    GTX 1060 3GB
    You literally have no idea what you are saying. Not being rude, its just like that. 82c its normal for any GPU, hot, but normal, GPU thermal throttling happens after 90c and that doesn't cause any stutter, the fps will just drop a bit, but it doesn't mean your game will magically lag.

    "82C is VERY HOT in degrees its 180 degrees". This comment makes so little sense its almost you were trying to troll him.
     
    jonaaa20 likes this.
  14. Smough

    Smough Master Guru

    Messages:
    374
    Likes Received:
    54
    GPU:
    GTX 1060 3GB
    Your temps are within the normal range, that its not your problem, so don't worry, troubleshoot elsewhere. Have you tried to debloat Windows a bit? Also try disabling Superfetch/Sysmain service and report your results.
     
    jonaaa20 likes this.
  15. Smough

    Smough Master Guru

    Messages:
    374
    Likes Received:
    54
    GPU:
    GTX 1060 3GB
    You really should READ what someone posts before just replying on the fly and on what you guess. Tell me, what does he need an aftermarket CPU cooler? Core i5's are known for not getting too hot, his is 62c, as he reported, that is ABSOLUTELY normal for Intel, it can actually function at 80c+ without any major problems, 90c is a dangerous territory, but he isn't getting there, so you literally provided nothing to him to solve his issue.

    In contrast, my Core i7 gets to 65c when gaming and I don't experience any major stutter or issues at games. Now you are gonna tell me my CPU is about to catch flames as well?

    Also setting your GPU fan to the max 24/7 is extremely pointless; this is why MSI Afterburner allows you to create a curve, so when its in load, it actually cools down and when its idle, you can even set the fan to 0 rpm. Mine doesn't ramp the fans until its around 60c, which is the ideal setting for any GPU. What benefit are you getting by forcing your GPU fan to the max when the computer is at idle? Wasted life span.
     
    jonaaa20 likes this.

  16. Himitsu

    Himitsu Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    GTX 1080 G1 Gaming
    If you guys think 80º is hot, my 2080 Ti at 84-88º is what melting?

    The fans goes crazy up to 4000RPM.

     
  17. janos666

    janos666 Master Guru

    Messages:
    794
    Likes Received:
    83
    GPU:
    MSI RTX2060 6Gb
    Many Intel CPUs are seemingly designed to deliberately run into thermal throttling (especially in notebooks) at turbo clocks and it's usually handled smoothly. Pretty much the same applies to VGA cards but they start to drop turbo clocks much sooner (especially nV cards). The consumer generally doesn't need to worry about temperatures below ~90 °C, as long as it happens under sustained heavy load and clocks aren't throttled below the base clock. This is why the upper clock range is called "turbo": it's not guaranteed to be sustained. And this is why there are graceful thermal throttling mechanisms (simple clock throttling and not freezes/shutdowns or jumps to minimal clocks, etc).
     
    Smough likes this.
  18. Smough

    Smough Master Guru

    Messages:
    374
    Likes Received:
    54
    GPU:
    GTX 1060 3GB
    Well, its not melting, but its quite hot, way more than what feels safe for me, but I suppose some GPU models get high temps. Buy some extra case fans, that can help.
     
  19. Himitsu

    Himitsu Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    GTX 1080 G1 Gaming
    got 8 already...
     
  20. jonaaa20

    jonaaa20 Member

    Messages:
    10
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    Okay, i'll uninstall some 'Inbox' Apps since i don't use them, about SysMain(SuperFetch), since i use a HDD, the system will be slow if I disable it, i mean, REALLY SLOW, but i'll keep testing here without it enabled.

    By the way, i've enabled MSI Mode, changed the Timer Resolution to 0.5ms and disabled some exploit protections, no difference.

    Tested with SysMain disabled and the result is the same, will keep testing and looking for any tweak.
     

Share This Page