Fix game stutter on Win 10 1703-1809

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Mott, Apr 3, 2018.

  1. Astyanax

    Astyanax Ancient Guru

    Messages:
    6,584
    Likes Received:
    2,049
    GPU:
    GTX 1080ti
    You'll have to get Microsoft to acknowledge this one because its their own policy that on 8.x and 10 the sysmain caching only covers HDD's.
     
  2. mbk1969

    mbk1969 Ancient Guru

    Messages:
    9,209
    Likes Received:
    6,090
    GPU:
    GeForce GTX 1070
    Just a words without link.
     
  3. Smough

    Smough Master Guru

    Messages:
    449
    Likes Received:
    72
    GPU:
    GTX 1060 3GB
    Sorry, I am not a full expert on these things, so if I come up with something a bit stupid, my bad then. The thing is that with standby memory full or not on my system, there's no performance change or least, its not visible.
     
  4. Astyanax

    Astyanax Ancient Guru

    Messages:
    6,584
    Likes Received:
    2,049
    GPU:
    GTX 1080ti

  5. mbk1969

    mbk1969 Ancient Guru

    Messages:
    9,209
    Likes Received:
    6,090
    GPU:
    GeForce GTX 1070
  6. aufkrawall2

    aufkrawall2 Master Guru

    Messages:
    603
    Likes Received:
    56
    GPU:
    GTX 1070 OC/UV
    It's very apparent that programs start slower after the 1st time when standby memory is flushed. So yeah, it was really unfortunate that it was required with older drivers on Win 1703+ to fight game stutter.
    Btw. no need for fancy tools, just watch the cache value reported in Task Manager RAM section when downloading, copying stuff etc. And Linux basically works the same.
     
    Smough likes this.
  7. Smough

    Smough Master Guru

    Messages:
    449
    Likes Received:
    72
    GPU:
    GTX 1060 3GB
    Turns out you are completely right! Games stutter more if you keep clearing the standby memory. RE2 for example runs miles better if you allow the game to cache all it needs, much less asset load fps drops when you change areas in-game. Also it leaves like 4MB free of standby, sometimes even 0, but the game is smooth all the same. I see that having an SSD or not does not change this. Games still need to cache info to run faster.
     
  8. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,463
    Likes Received:
    228
    GPU:
    MSI 970 Gaming 4G
  9. Astyanax

    Astyanax Ancient Guru

    Messages:
    6,584
    Likes Received:
    2,049
    GPU:
    GTX 1080ti
    The crux of it was on a microsoft page that was deleted when moving to their new blog system.
     
  10. AATT

    AATT Member Guru

    Messages:
    184
    Likes Received:
    15
    GPU:
    GTX1080
    The FPS cap is not that low for it to be flat all the time due to rare FPS drops, this is where the frame time spikes come from, when I go crouched a certain route and dont look any side it is flat and stable.

    I do not use vsyc, or any other sync. I tried FSO off it was 1:1 the same, so I enabled it again, the nvidia frame limiter was crap.

    The context was windows game mode, one can add .exe there and pick different modes, this is not task manager cpu priority.

    Today the UE4 "fatal error" message crashes returned, I thought it was fixed after driver update, played fine for hours.
     
    RodroG likes this.

  11. Smough

    Smough Master Guru

    Messages:
    449
    Likes Received:
    72
    GPU:
    GTX 1060 3GB
    If you don't use v-sync, then FSO won't help you much. FSO works better with v-sync to get the benefits of Fullscreen+Borderless and removing the stutter several games have at Fullscreen that have bad v-sync implementation.

    As for the crashes; update your drivers, via Windows Update, Device Manager or the manufacturers website, install all Visual C++, search for the package that installs them all at once. Use DDU and get the latest nVidia drivers.
     
  12. AATT

    AATT Member Guru

    Messages:
    184
    Likes Received:
    15
    GPU:
    GTX1080
    I already did have the newest drivers (clean version from here) with DDU prior (both as usual) but what fixed the "fatal error" UE4 misery was the tool TDR Manipulator by Wagnard, changing the value TdrDelay from 2 to 10.
     
    RodroG likes this.
  13. Maulcun

    Maulcun Member

    Messages:
    13
    Likes Received:
    3
    GPU:
    GTX 1060
    Test #1 OS: 1803 / Driver: 442.37

    I had a lot of stuttering on the BF4 and always received the low FPS icon. However, after deactivating ASLR (Mandatory ASLR,Bottom-up ASLR and High-entropy ASLR options.) and using the Empty Standby List, the stuttering were gone.
     
    Last edited: Feb 27, 2020
    Smough likes this.
  14. aufkrawall2

    aufkrawall2 Master Guru

    Messages:
    603
    Likes Received:
    56
    GPU:
    GTX 1070 OC/UV
    Can't confirm, works fine here with 1909 442.37 and all exploit protections enabled (+Spectre/Meltdown mitigations).
     
  15. Smough

    Smough Master Guru

    Messages:
    449
    Likes Received:
    72
    GPU:
    GTX 1060 3GB
    Just reporting the issue gets fixed on Windows 10 1803 latest compilation with nVidia latest drivers by disabling ASLR bottom up on Windows Defender. No need to use ISLC anymore. However, it looks like that on 1803 and earlier (1809 too?), with ASLR bottom up enabled on the Defender, the standby memory gets bugged or glitched and causes in-game stutter. With this setting disabled, the size grows on some games until there's zero free memory as it normally would and the game is smooth. For example, Resident Evil 2 and AC: Origins. I am glad I was able to find the cause of this issue, but at the end of the day, it looks like i'll end up updating to a more recent version of Windows because all I want always is stability. Maybe I will give that LTSC 1909 ISO a try. That or wait until Windows 2004, I have no rush really. But I do need to update.

    Anyways, just my 2 centz to anyone who experiences this issue. Also, I recommend updating drivers, via the manufacturer website or using something like Snappy Driver Installer Origin, 100% safe to use, the drivers it installs are certified by MS and very recent. It doesn't hurt and old drivers could still drag issues related to Standby Memory.
     

  16. Smough

    Smough Master Guru

    Messages:
    449
    Likes Received:
    72
    GPU:
    GTX 1060 3GB
    If you disabled those, then there's no point in using Empty Standby List. Maybe only before starting a game, but asides from that, while in-game, the issues that cause standby memory stutter are those settings you mention on Defender so there's no need to do any cleaning while playing with those options disabled. I myself only disabled ASLR Bottom up and that was enough to solve any standby memory issues I was having. Anyway, I am glad that you got a smooth gaming experience again, its nice that some users are getting to know the root of this problem and are fixing it.
     
  17. mbk1969

    mbk1969 Ancient Guru

    Messages:
    9,209
    Likes Received:
    6,090
    GPU:
    GeForce GTX 1070
    @Smough
    Do not assume that your finding is universal solution for all users.
     
  18. Maulcun

    Maulcun Member

    Messages:
    13
    Likes Received:
    3
    GPU:
    GTX 1060
    Test #2 OS: 2004 (1941.84) / Driver: 450.12 with hardware-accelerated gpu scheduling on.

    With Mandatory ASLR (Off) and Bottom-up ASLR (off), I no longer have stuttering in BF4. I didn't need to use the Empty Standby List.

    [​IMG]


    I don't think microsoft is going to fix this problem.
     
    Smough likes this.
  19. Smough

    Smough Master Guru

    Messages:
    449
    Likes Received:
    72
    GPU:
    GTX 1060 3GB
    True. But keep in mind that what I found has already been discussed in here.
     
  20. Smough

    Smough Master Guru

    Messages:
    449
    Likes Received:
    72
    GPU:
    GTX 1060 3GB
    Users with newer Windows versions claim the issue is gone. I've asked some people who use 1909 and they don't report any stutter out of the blue in their games. I am gonna wait for Windows 2004 anyway, this is promising: https://www.minitool.com/news/win10-v2004-hardware-accelerated-gpu-scheduling.html

    On paper, it literally promises to fix most issues gamers have with random stutter that isn't related to slow CPU, GPU or storage device but just Windows managing things poorly so I really want to try this new feature.

    Quote from the article:

    "This Windows 10’s Hardware-accelerated GPU scheduling feature allows video cards such as Intel UHD Graphics and Nvidia GeForce to directly manage its video memory. Through this new GPU feature, Microsoft promises that the video playback performance is improved and the latency on supported hardware is reduced.

    This Hardware-accelerated GPU scheduling feature can work regardless of the API (DirectX, Vulkan, OpenGL) that is used for apps and games. These popular and well-known apps, such as Movies & TV app, Netflix and some other programs, will support the hardware acceleration.

    With this Hardware acceleration feature, your device’s graphics card can more efficiently deal with the actions of video playback and game calculations.

    After you get the Windows 10 20H1 on your computer, you can enable this Hardware-accelerated GPU scheduling feature manually. You can go to Windows Settings to do the job. You can find this feature under the Graphics settings section."

    Are we finally getting a proper, "gamer" optimized O.S? Only time will tell, but it does look like some great will come.
     

Share This Page