Fix game stutter on Win 10 1703-1809

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Mott, Apr 3, 2018.

  1. kman

    kman Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    1080ti Strix
    I have a 1080ti/9900k/16gb ram ddr4/970 evo SSd and pretty much every game has some form of stutter.Tried all sorts of things.None have worked so far.Already use ISLC and have CFG off globally.Is "Randomise memory allocations (Bottom-up ASLR) that you disable Globally just so I'm 100% sure?

    Makes sense why w7 was so much smoother gaming wise.Had none of this stuff.Been dealing with these issues since I "upgraded" to w10 a year ago.Was v1803 I think.

    I might also disable the rest of the exploit protections per game.exe too.Not willing to drop everything globally but I'm willing to drop Bottom-up ASLR Globally and (CFG since I've had this off for months now with no issues)
     
    Last edited: Oct 7, 2019
  2. mbk1969

    mbk1969 Ancient Guru

    Messages:
    8,157
    Likes Received:
    4,935
    GPU:
    GeForce GTX 1070
    Have you tried clean install of Win10?
     
  3. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,341
    Likes Received:
    193
    GPU:
    MSI 970 Gaming 4G
    According to this page posted above by X7007, it's been in Windows since Vista, just not configurable like now.
    https://en.wikipedia.org/wiki/Address_space_layout_randomization#cite_note-28
     
  4. kman

    kman Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    1080ti Strix
    Yes actually.Tried a clean install 2 days ago.no change.

    Ok.I disabled CFG/ (Bottom-up ASLR) Globally.Gonna see how it goes.
     
    Last edited: Oct 7, 2019

  5. kman

    kman Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    1080ti Strix
    Black desert online still stutters with CFG/ASLR disabled so il chuck it to the game being the unoptimized mess that it is.

    Tried Monster hunter world https://imgur.com/a/CQ7J6vz Difference between CFG/ASLR only vs All protections off.Not much difference tbh.

    This with Sysmain/windows search/Gamebar stuff/overlays Disabled.

    I think I just happen to play really unoptimized games.

    Was playing APEX.Sometimes I get a random stutter and sometimes not.Maybe connection related?.Standby memory still purges.Did twice in like an hour.This with CFG/ASLR disabled.Annd... apex just ended up crashing because of "cpu" issues.Nice EA.No issues since the game came out and now this.This an unrelated issue though.
     
    Last edited: Oct 8, 2019
  6. jonaaa20

    jonaaa20 New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    GTX 1060 3GB
    Well, the CFG/ASLR solution doesn't work for me, the only way to reduce these stutters is downgrading to 1607 that was the last decent "for gaming" windows.
     
  7. kman

    kman Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    1080ti Strix
    Kinda on the same boat.Tried everything possible I can think off.I don't think going back would be viable at certain points because I heard older OS version dont support newer gpu's.Such a tough predicament to be in.Stuck between a rock and a hardplace.I do wonder whats causing the issue though...Whats different between 1607 and 1903 that could cause random stutter in most games?I simply can't wrap my mind around it.
     
    Last edited: Oct 8, 2019
  8. mbk1969

    mbk1969 Ancient Guru

    Messages:
    8,157
    Likes Received:
    4,935
    GPU:
    GeForce GTX 1070
    Have you tried MSI mode tweak?
     
  9. kman

    kman Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    1080ti Strix
    [​IMG]
    Took a picture of what I have.Basically I tick MSI checkbox for my 1080ti strix and thats it right?
     
    Last edited: Oct 8, 2019
  10. mbk1969

    mbk1969 Ancient Guru

    Messages:
    8,157
    Likes Received:
    4,935
    GPU:
    GeForce GTX 1070
    I am sure that`s just audio facility of videocard, you can check the OEM code in device manager - it should be the same NVIDIA`s one . You can tick audio-devices as well, but let`s not litter this thread with MSI stuff. You can post there...
     

  11. kman

    kman Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    1080ti Strix
    k il post there.il stick to ticking only the gpu for now.See how it goes.
     
  12. Astyanax

    Astyanax Ancient Guru

    Messages:
    3,861
    Likes Received:
    1,071
    GPU:
    GTX 1080ti
    I'm seeing posts here and there about the internet that the latest 1903 updates have rectified the problem. (18362.388)
     
    Last edited: Oct 10, 2019
  13. MaLDo

    MaLDo Master Guru

    Messages:
    555
    Likes Received:
    3
    GPU:
    GTX1080
    What's the way to disable ASLR?
     
  14. Venomsword

    Venomsword Member Guru

    Messages:
    173
    Likes Received:
    19
    GPU:
    Asus STRIX-GTX1080
  15. MaLDo

    MaLDo Master Guru

    Messages:
    555
    Likes Received:
    3
    GPU:
    GTX1080

    Thank you very much!
     

  16. Prozein

    Prozein New Member

    Messages:
    1
    Likes Received:
    1
    GPU:
    RTX 2080
    Disabling ASLR works really well. Should make a separate thread for that. Honestly would help a lot more people with similar problems. Thanks to guys that found it and posted about it.
     
    Kolt likes this.
  17. mbk1969

    mbk1969 Ancient Guru

    Messages:
    8,157
    Likes Received:
    4,935
    GPU:
    GeForce GTX 1070
    I experimented with ASLR Bottom-up setting and now can state that I got that MS article wrong claiming that this setting is only applied to apps which are built without ASLR support and when ASLR is forced for such apps. I compared the properties of apps built with ASLR support in ProcessExplorer with Bottom-up setting on and off and I see a difference. So it is clear that this Bottom-up setting is applied to apps compatible with ASLR.
     
  18. Xentic

    Xentic New Member

    Messages:
    8
    Likes Received:
    6
    GPU:
    GTX 1080 8GB
    For me, the problem is fixed on winver 1903 (18362.388).

    Dont need to disable protections anymore. Its as smooth, as on 1607 3 years ago.
     
  19. kman

    kman Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    1080ti Strix
    Didnt fix it for me.Just tried playing APEX.Random stutters with 0 free memory and as soon as I used ISLC to empty the standby the stutters in the next game where gone.I'm using w10 1903 (18362.418)

    For some reason apex eats all of the free memory when I start it Look.
     
    Last edited: Oct 11, 2019
  20. Astyanax

    Astyanax Ancient Guru

    Messages:
    3,861
    Likes Received:
    1,071
    GPU:
    GTX 1080ti
    Apex stutters because its shiiiiiii
     

Share This Page