Fix game stutter on Win 10 1703-1809

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Mott, Apr 3, 2018.

  1. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,348
    Likes Received:
    193
    GPU:
    MSI 970 Gaming 4G
    So your saying if you have any one of the exploit protections enabled under system settings the issue happens but turn them all off and it's not happening?
    It's not anyone or a few doing it, that is interesting if true.
     
  2. Mico

    Mico Member

    Messages:
    39
    Likes Received:
    17
    GPU:
    msi 1070 ti aero
    I don't know if really all of them have to be disabled but so far disabling them all solved the memory management issue. Every change requires a restart so trying all the combinations ca be long.
    On this pc i do nothing than gaming, even for online transactions i use another pc and then i install on this one. So security isn't really an issue here, and i understand that for some it might be.
    I've tried running islc running in the background in this situation and it never cleans standby list because it's never needed.
    Per app exclusions are hit and miss.
    So far its working on 6 machines.
    Bit odd we have to choose between a day-0 (supposed to be) protection or gaming.
     
  3. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,348
    Likes Received:
    193
    GPU:
    MSI 970 Gaming 4G
    Ok, you say with ISLC you never get any clean events, what settings on memory size do you have and how much main memory do you have?

    I would test this but it takes me way too long to get stuttering in the games I have.
     
  4. Mico

    Mico Member

    Messages:
    39
    Likes Received:
    17
    GPU:
    msi 1070 ti aero
    1024/1024 @ 1000ms (500ms for ssd).
    If u have it The Divion 2, both dx11 and dx12 can be a good test.
    With exploit protection on i was getting up to 15-16 cleans in 1hour and the game was unplayable without ISLC.
    Now i get none and the game is buttery smooth even with ISLC off.
    I have 16gb ddr3.
     

  5. Terepin

    Terepin Master Guru

    Messages:
    655
    Likes Received:
    5
    GPU:
    GTX 1080
    ISLIC isn't even working for me. I tried tips mentioned in official forum post, but that didn't work.
    [​IMG]
     
  6. mbk1969

    mbk1969 Ancient Guru

    Messages:
    8,209
    Likes Received:
    5,019
    GPU:
    GeForce GTX 1070
    Why do you think it is not working? Because it doesn`t purge standby list? That can be because your rig doesn`t suffer from huge standby list problem.
     
    toyo likes this.
  7. Terepin

    Terepin Master Guru

    Messages:
    655
    Likes Received:
    5
    GPU:
    GTX 1080
    Maybe because it doesn't purge standby list every 1024 MB how it is set to do?
     
  8. mbk1969

    mbk1969 Ancient Guru

    Messages:
    8,209
    Likes Received:
    5,019
    GPU:
    GeForce GTX 1070
    What do you mean by "every"? It should purge when standby list is larger than 1024 MB and when free memory is less than 1024 MB (numbers from your screenshot) - two conditions.
     
    toyo likes this.
  9. Terepin

    Terepin Master Guru

    Messages:
    655
    Likes Received:
    5
    GPU:
    GTX 1080
    Huh. I see. Then why official forums post says "The application will monitor and clear the memory standby list when it is > 1000mb (1gb)." Either that is wrong, or my English skills aren't up to the task.
     
  10. Cyberdyne

    Cyberdyne Ancient Guru

    Messages:
    3,179
    Likes Received:
    116
    GPU:
    RTX 2070 XC Ultra
    That statement is still true. But clearly you can see the second condition that must also be met in the app.
    EDIT: I think maybe you read the conditions as "or"?
    It's "and", as in both must be met for purge to occur.
     

  11. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,627
    Likes Received:
    255
    GPU:
    MSI Geforce GTX 1080
    I have edited on my forum/webpage the possible confusion.

    On others news, a new version of ISLC with minor fixes an a exclusion button/ list will be released soon.
    Must just wait some testing after my night shift at work.

    Edit: It's released.
     
    Last edited: Sep 24, 2019
  12. smackup4u

    smackup4u New Member

    Messages:
    3
    Likes Received:
    1
    GPU:
    RTX 2080ti
    Can you tell us, how turn off this feature off globally? There are several how to's but they all sound a bit differently :)
     
  13. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,348
    Likes Received:
    193
    GPU:
    MSI 970 Gaming 4G
    AFAIK, he is talking about the System setting as info here (not program settings).
    https://www.howtogeek.com/329700/ho...oit-protection-works-and-how-to-configure-it/

    There are like seven sections and you would need to turn them all off, by default six are on, one is off (forced randomization for images=off).

    I have not tested this.
     
    Mico and smackup4u like this.
  14. Xtreme512

    Xtreme512 Master Guru

    Messages:
    665
    Likes Received:
    7
    GPU:
    GTX1060 6GB
    so which game should we add to the exclusion list? btw, great effort wagnard!
     
  15. Xentic

    Xentic New Member

    Messages:
    8
    Likes Received:
    6
    GPU:
    GTX 1080 8GB
    I confirm it fixed my stuttering. In BF1 the free memory is still around 0, but it does not stutter.

    Can anyone confirm if its safe to disable the protections? I use bitdefender + malwarebytes on daily.
     

  16. Mico

    Mico Member

    Messages:
    39
    Likes Received:
    17
    GPU:
    msi 1070 ti aero
    Yup, those. Sorry for late reply, i'm back to my job and don't have much time :p
     
    smackup4u likes this.
  17. Mico

    Mico Member

    Messages:
    39
    Likes Received:
    17
    GPU:
    msi 1070 ti aero
    Today i've managed to reach 0 mbytes available after 3 hours on The Division 2 and it wans't stuttering either.
    You should be fine with bitdefender + malwarebytes.
    After reading the link given by EdKiefer i've noticed that exploit protection was introduced with Creators Update, which also was the 1st win10 version suffering of stutter.
    Maybe it's not a coincidence?
     
  18. Xentic

    Xentic New Member

    Messages:
    8
    Likes Received:
    6
    GPU:
    GTX 1080 8GB
    Yes I have 0 free memory all the time while playing BF1, it caches everything, but its not stuttering after I disabled the protections. So it looks like the caching itself is not an issue, but maybe the managment of it. Which makes sense, caching is and should be beneficial. From what I remember, Windows 1607 cached your entire ram too in some games.

    I tried AC Origins too, sometimes it caches my ram, sometimes it forces my PC to free it, but it never stutters.

    Yes it all started with the first ever creators update.
     
    Mico likes this.
  19. evertjr

    evertjr Member

    Messages:
    15
    Likes Received:
    1
    GPU:
    GeForce GTX 460
    I just tested only disabling globally Randomize memory allocations (Bottom-Up ASLR) and in my testing Battlefiled 1 DX12 is smooth without ISLC running. I have to test in more games to confirm
     
  20. Mico

    Mico Member

    Messages:
    39
    Likes Received:
    17
    GPU:
    msi 1070 ti aero
    Just finished installing BFV. Memory almost constantly at zero but no stutter.
    Evertjir, let us know. I disabled them all but you possibly found the right setting.
    Back to work again in one hour so sorry if don't reply for "a bit" :p
     

Share This Page