Fix game stutter on Win 10 1703-1809

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Mott, Apr 3, 2018.

  1. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,385
    Likes Received:
    2,731
    GPU:
    RX 5700 XT/ MAC M1
    May I ask something - all those that have faced stutter issues, do you have Game Mode enabled by any chance?
     
    endbase likes this.
  2. Passus

    Passus Ancient Guru

    Messages:
    1,748
    Likes Received:
    520
    GPU:
    RX 5700 Mech OC
    It's pretty much set on by default
     
  3. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,385
    Likes Received:
    2,731
    GPU:
    RX 5700 XT/ MAC M1
    Turn it off and test then.
     
  4. Passus

    Passus Ancient Guru

    Messages:
    1,748
    Likes Received:
    520
    GPU:
    RX 5700 Mech OC
    How? If you please tell me it's not really something i thought about, there no toggle button
     

  5. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,385
    Likes Received:
    2,731
    GPU:
    RX 5700 XT/ MAC M1
    What do you mean you can't toggle it off?

    Go to Settings -> Game Mode -> use Game mode, toggle it Off.
    Do the same for game DVR / Game Bar / Broadcasting
     
  6. Ital

    Ital Member Guru

    Messages:
    189
    Likes Received:
    71
    GPU:
    ZOTAC GTX 1080 AMP
    You do know that Win 10 version 1709 no longer has this toggle button in the Game Mode settings, right? In fact, the Game Mode settings page is totally useless in 1709 since there's nothing to change or configure there.

    It's on by default only for UWP games whitelisted by Microsoft. Game Mode is off by default for all other games, and you have to turn Game Mode on individually for each game via the Game Bar.
     
  7. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,385
    Likes Received:
    2,731
    GPU:
    RX 5700 XT/ MAC M1
    I see. Im on LTSB, hence no clue.
     
  8. Kolt

    Kolt Ancient Guru

    Messages:
    1,650
    Likes Received:
    507
    GPU:
    RTX 2080 OC
    For a while I've had to manually disable fullscreen optimizations in games otherwise I would sometimes be met with an FPS cap and other issues. Are you saying that this is no longer a problem? I noticed that the gamepresentwriter process still runs when I run games though.
     
  9. Dragondale13

    Dragondale13 Maha Guru

    Messages:
    1,470
    Likes Received:
    154
    GPU:
    GTX 1070 AMP! • H75
  10. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,672
    Likes Received:
    279
    GPU:
    MSI 970 Gaming 4G

  11. Ital

    Ital Member Guru

    Messages:
    189
    Likes Received:
    71
    GPU:
    ZOTAC GTX 1080 AMP
    Fullscreen optimizations and Game Mode are 2 entirely different things.

    That registry setting only turns off Game Mode by default for UWP games whitelisted by Microsoft. That setting has no effect for all other games, which is most likely why Microsoft decided to remove the toggle button in the Game Mode settings page for 1709. That setting does not disable Game Mode globally for all games. It just controls whether Game Mode is automatically enabled or not for whitelisted UWP games. For all other games, Game Mode is automatically disabled unless you enable it via the Game Bar for that particular game.
     
  12. Kolt

    Kolt Ancient Guru

    Messages:
    1,650
    Likes Received:
    507
    GPU:
    RTX 2080 OC
    Ah, you are right. I was thinking of the "Game Bar" and presence writer issues (fullscreen optimizations) which is in the same settings, but you are correct I was thinking of something else.
     
  13. Caesar

    Caesar Maha Guru

    Messages:
    1,306
    Likes Received:
    501
    GPU:
    GTX 1070Ti Titanium
    Downloaded and tested. (OS build 16299.309).

    My opinion is nothing to do with Game Bar or anything else...... whilst you might see high disk read and write speed with "EmptyStandbyList.exe" (boot speed slower under UEFI)

    ....how a game is coded and how it will operate under new hardware configurations which did not existed at that particular time is another thing.... and [ how the teams working {game prioritized} under gpu drivers development is ......to be honest .....very poor]


    .......and yes... don't be fooled by using THOSE registry cleaners...junk files cleaners....whatsoever available free to use nowadays on the web.....
     
  14. Mott

    Mott Master Guru

    Messages:
    908
    Likes Received:
    205
    GPU:
    MSI 6800XT GXT
    This is no longer applicable in 1709. It is all done in the settings menu under gaming, in fact if you try and do it this way it just redirects you to the DVR menu in the Gaming section of the Settings in Windows 10. All you have to do is click on settings, then click on Gaming, then click Game DVR and turn everything off. No more XBOX app required.

    (sorry for the huge picture)

    [​IMG]
     
    Last edited: Apr 6, 2018
  15. Vidik

    Vidik Master Guru

    Messages:
    604
    Likes Received:
    189
    GPU:
    MSI 1070 Gaming Z
    Is this "using quadro drivers result in better colors" 2.0?:D
     

  16. Xtreme512

    Xtreme512 Master Guru

    Messages:
    702
    Likes Received:
    20
    GPU:
    GTX1060 6GB
    I have decided to monitor standby memory usage while playing BF1 and free memory being 1MB to 50MB fluctuations happened to me as well, but without FPS decrease or constant 100% CPU usage.

    [​IMG]

    See above on 64-player map, I'm getting "normal" CPU usage with stable 60 FPS.

    I'm on latest W10 1709 x64 and my software/drivers are pretty clean and updated. My system has i5 3570K at 4.2GHz and 2x8GB 2400MHz CL10-11-11-32 DDR3. Using 391.35 WHQL.

    Please note that, I previously wrote a combination of settings for optimal BF1 experience and that also helps with CPU usage tremendously. I'm sharing it one more time below.

    ---
    (GameBar/DVR/Mode are disabled).

    1) In user.cfg
    RenderDevice.RenderAheadLimit 2
    RenderDevice.TripleBufferingEnable 0
    GameTime.MaxVariableFPS 60

    2) In compatibility tab, "Disable full-screen optimizations" is checked for native exclusive full-screen.

    3) In Nvidia control panel, pre-render frames set to "3D application default" and max performance is selected.

    4) Windows power settings, max performance is selected.

    5) RTSS FPS limiter to "0" turned off.

    6) DX12 and memory restr. is turned off.
    Fullscreen is on.
    VSYNC is on.
    FPS limiter to refresh rate. (user.cfg overrides anyways).

    My other options are all Ultra including TAA and 1080p.
    Mouse/input lag is like a thunder fast, 60 FPS stable and CPU usage fluctuates between 60%-85%, seldomly shoots to 95% dropping 58 FPS. (In 64-player maps in action).
    ---
     
  17. GSDragoon

    GSDragoon Master Guru

    Messages:
    307
    Likes Received:
    156
    GPU:
    AMD Radeon RX 6800
    I can see this cache get pretty big, but I'm not notice stuttering. It seems to be a just in case cache that is simply ditched if something actually needs it. Anyone find a way to see what's in the standby cache? I'm guessing kernel dumpfiles might be the only way :(
     
  18. Passus

    Passus Ancient Guru

    Messages:
    1,748
    Likes Received:
    520
    GPU:
    RX 5700 Mech OC
    Each to their own mate, I use ccleaner about once a week to get rid of junk internet files and missing registry links from game installs uninstalls
     
  19. warlord

    warlord Ancient Guru

    Messages:
    2,761
    Likes Received:
    927
    GPU:
    Null
    There is no stutter in Windows 10 become real true gamers and stop spreading lies for God's sake stop this nonsense what are you, cry babies?
     
  20. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,796
    Likes Received:
    8,043
    GPU:
    GF RTX 2070 Super
    Yeah


    Be real true gamer or be square!
     
    BlindBison likes this.

Share This Page