1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fix game stutter on Win 10 1703-1809

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Mott, Apr 3, 2018.

  1. Astyanax

    Astyanax Ancient Guru

    Messages:
    3,255
    Likes Received:
    842
    GPU:
    GTX 1080ti
    nothing to do with it.
     
  2. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,885
    Likes Received:
    4,517
    GPU:
    GeForce GTX 1070
    How do you know? Have you tested? Or you just stated your opinion?

    Page combining:
    Memory compression:
     
    Last edited: Jan 6, 2019
  3. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,623
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    1000ms (1sec). Not sure if i'll add a config option. It is running quite invisible at this setting. Got no report of user complaining it had a negative effect on their performance or CPU usage.

    Already tried disabling memory compression in the past and it didn't help. Never tried the / checked the page combining.
     
    Hemisfear likes this.
  4. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,310
    Likes Received:
    184
    GPU:
    MSI 970 Gaming 4G
    Not complaining, you asked if anyone wanted to see an option for a refresh rate.
    It is not that the app is consuming a lot of CPU cycles, but it does add up depending on how many background applications are running.

    Since I only hit this standby issue with long in game games (Bfv Operations), Conquest doesn't happen. I may just clear it and close it out and see if that is enough just before the game runs.
    The application is working fine, as far as doing what it is supposed too, no complaints.
     

  5. Hemisfear

    Hemisfear Member

    Messages:
    21
    Likes Received:
    10
    GPU:
    GTX 1080
    thx, gonna toy around!
     
  6. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,885
    Likes Received:
    4,517
    GPU:
    GeForce GTX 1070
    @AveYo

    I have read documents about tickless kernel (Linux mostly), and I understand it as this - only one CPU core receives periodic timer interrupts (to service scheduling and time), while others non-idle cores schedule one timer interrupt to fire when needed, and idle cores do not schedule timer interrupt at all.
    So in such mode increasing system timer resolution will increase power consumption only for one CPU core.
    It is said that Windows implemented tickless kernel in Win8. So your concern about power consumption increased due to maximum timer resolution is only valid for Win7.
     
  7. Astyanax

    Astyanax Ancient Guru

    Messages:
    3,255
    Likes Received:
    842
    GPU:
    GTX 1080ti
    many users have already looked into disabling these and have had no changes when the standby list causes memory pressure.
     
  8. Vlad V.

    Vlad V. New Member

    Messages:
    9
    Likes Received:
    5
    GPU:
    ASUS GTX 1080 Ti OC
    Hi guys! :)

    So apparently Microsoft is now publicly gathering feedback on how to improve Windows 10 for gaming: https://xboxideas.uservoice.com/forums/919048-gaming-on-windows-10/filters/top

    I am not sure how in-depth this feedback can get, but since there are so many knowledgeable ladies and gentlemen on this forum, I though you might want to get in there and tell Microsoft what they can do better in the future! :p
     
  9. Smough

    Smough Member Guru

    Messages:
    160
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    Question:

    What's the best pagefile size to be distributed to two SSD's with 8GB of RAM and 3GB of VRAM?

    Should I set a min and max size or both min and max size should be the same?

    Thanks!
     
  10. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,068
    Likes Received:
    49
    GPU:
    RX 580 8GB
    I set a static Min/Max at the same value. How much depends what you do. Set say 8GB worth (4GB split if you like) and see if you get close to exceeding the Committed amount. Keep an eye on Committed (Task Manager -> Memory).
     

  11. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,885
    Likes Received:
    4,517
    GPU:
    GeForce GTX 1070
    You can set maximum and then if there are out of memory exceptions in apps you just increase the maximum.
    When you set equal min and max sizes the pagefile becomes of that size (static). When min and max sizes differ pagefile grows from min size to max size dynamically.
    If you set pagefiles on both disks Windows should use the pagefile on the disk with lower activity.
     
    Smough likes this.
  12. Xtreme512

    Xtreme512 Master Guru

    Messages:
    664
    Likes Received:
    7
    GPU:
    GTX1060 6GB
    is it safe to disable those?
     
  13. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,885
    Likes Received:
    4,517
    GPU:
    GeForce GTX 1070
    Of course. Especially if your rig has more than 4GB of RAM.
    And in case you get some troubles you can always turn these back on.
     
  14. Smough

    Smough Member Guru

    Messages:
    160
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    You can always try and see how your computer behaves, if anything crazy happens or you get a crash, just turn them back on.
     
  15. Smough

    Smough Member Guru

    Messages:
    160
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    I still don't get the serious paranoia of some gamers that they insist on "disable full screen optimizations". While on some games that creates issues, at some others makes them butter smooth and with perfect 16.6 ms frametimes without the need of RivaTuner or anything. Some other games behave badly with them on so you just disable them per .exe. I think that to disable them globally is not only very stupid but also unnecessary. Windows does not force you to use them, you have the choice. Either disable them or enable them, is not like having the setting active on Windows will break all of your games. Just a simple click and you disabled that for a game.

    Oh and also I wanted to say that even if you disable the GameBar, Full Screen Optimizations are still active. I think maybe this may have been due to a recent Windows Update or I don't know. So from what I've learned, the GameBar is not related to the Screen Optimizations or at least, not anymore.
     

  16. Smough

    Smough Member Guru

    Messages:
    160
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    Not even 1803 fixed the problem for me. Nioh, Witcher 3, Skyrim, Fallout 4 and lots of other games are smooth without stutter since I used this "Standby Fix" thing. Witcher 3 is probably the game that has gotten the most dramatic change.
     
  17. Smough

    Smough Member Guru

    Messages:
    160
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    It's a bad idea to go full paranoid and just want to kill FSO for all apps and games. Some games benefit greatly from them, others don't. All you have to do is try. You are losing a benefit because you think it's bad according to what some paranoid people say. A simple tickle on any .exe and there you go, disabled.
     
  18. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,068
    Likes Received:
    49
    GPU:
    RX 580 8GB
    Good idea with ISLC Wagnard (and those helping out). Timer resolution was an unexpected feature but i like it. I'm surprised it doesn't have it's owned thread, which links back to this thread. I think a lot of people suffer with stuttering and hitching without giving much more thought about it. My next upgrade = crap ton of RAM.
     
  19. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,885
    Likes Received:
    4,517
    GPU:
    GeForce GTX 1070
    akbaar and AveYo like this.
  20. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,068
    Likes Received:
    49
    GPU:
    RX 580 8GB
    akbaar likes this.

Share This Page