1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fix game stutter on Win 10 1703-1809

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Mott, Apr 3, 2018.

  1. aufkrawall2

    aufkrawall2 Master Guru

    Messages:
    415
    Likes Received:
    3
    GPU:
    MSI RX 580 Armor
    Turning off c-states should be pretty pointless as they hardly affect performance of any real life application (Or do you know an example showing the opposite?) due to the wakeup delay being in μs scope.
    Coreparking is turned off for Ryzen CPUs since some Creators Update with balanced energy profile, and maximum performance energy profile of Windows (which should be used with modern CPUs anyway, as they already save power without being told by on OS clock governor) turns it off regardless.

    I personally think clearing standby list and setting timer resolution is all that we need within such a little tool. And changing registry settings also is quite a different feature set.

    Edit: However, it of course wouldn't hurt if those options were there, as no one is forced to touch them.
     
  2. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,715
    Likes Received:
    4,312
    GPU:
    GeForce GTX 1070
    Core parking should be off in Win8 and Win10, and in performance power plan in Win7 (regardless of CPU model). So this feature is only relevant for Win7.

    I agree on little impact of C-states, especially on modern CPUs. But still on older ones wake from deepest C-state could be almost millisecond. So this feature is only relevant for weaker CPUs and for gamers who want to disable any power management but can`t since either BIOS lacks of settings or user doesn`t know about certain power plan setting (which is hidden by default).

    No need to change registry, because suggested core parking and C-states tweaks can be done through Win API.
     
  3. aufkrawall2

    aufkrawall2 Master Guru

    Messages:
    415
    Likes Received:
    3
    GPU:
    MSI RX 580 Armor
    It was enabled until Win 10 1709 for Ryzen CPUs with balanced power profile (and caused harm). I don't know about Intel X platform.

    Alright. :)

    Thanks for new version @Wagnard , one process less for timer resolution in the background.
    Btw: Would a x64 build be possible for crazy hipsters? :)
     
  4. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,715
    Likes Received:
    4,312
    GPU:
    GeForce GTX 1070
    That`s strange. I checked many times but only on Intel CPUs, and I have never seen core parking 'ON' on Win8, Win10.
     
    Last edited: Oct 19, 2018

  5. artina90

    artina90 Active Member

    Messages:
    63
    Likes Received:
    12
    GPU:
    GTX 970 Windforce 1.55Ghz
    On my 7820X I had to disable most of the C states, I left only C1 active if I recall correctly, C2 and above caused stuttering when switching cores.
    Going all the way from 1.2 to 4.8 Ghz with speedstep has no impact on gaming but switching from C2 to activity leads to stutters.
     
  6. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,617
    Likes Received:
    227
    GPU:
    MSI Geforce GTX 1080
    Possible yes but not really useful the only things you will gain is larger exe and more memory usage.
     
  7. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,715
    Likes Received:
    4,312
    GPU:
    GeForce GTX 1070
    The only serious minus of x64 code (I found) is the double size of pointers. So if code has vast number of pointers (references) it can display noticeably bigger footprint.
    From stackoverflow.com:
     
  8. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,617
    Likes Received:
    227
    GPU:
    MSI Geforce GTX 1080
    Changes since 1.0.0.8
    - On x64 OS, start as a 64bit process.
    - Allow only 1 instance of the application
    - Added some MessageBox information when the application encounter an error instead of just closing or crashing.

    SHA1: FB9B6DDDD2FB549FB95E6016A00CC0DB45778D7F
     
  9. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,715
    Likes Received:
    4,312
    GPU:
    GeForce GTX 1070
    Funny enough any geek with installed VisualStudio can transform any .Net application from x86 to x64 and vice versa just having exe-file itself.
     
  10. mootyful

    mootyful Member

    Messages:
    27
    Likes Received:
    3
    GPU:
    GTX 760 Gigabyte
    for some reason 1.0.0.8 didn't let me change the system timer, but the new one works. is it possible to disable the tray icon?
     

  11. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,617
    Likes Received:
    227
    GPU:
    MSI Geforce GTX 1080
    It is not possible to disable the tray icon. (yet)
     
    mootyful likes this.
  12. Astyanax

    Astyanax Ancient Guru

    Messages:
    3,052
    Likes Received:
    789
    GPU:
    GTX 1080ti
    could more days and the ryzen master dynamic memory feature will be out.
     
  13. Checheck

    Checheck Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    MSI 1060 6GB
    Hey there.

    With my previous Windows installation everything was fine, once I did a fresh install the problems started (same version + build).
    From few months ago I've fixed them with the tools that has been provided, currently using ISLC, everything perfect.

    I want to give thanks to all of you, especially to the people with enough knowledge to confront the problem, doing emphasis in the cooperativeness between all, giving, sharing advices/tips one to other being humble, and with several tools/scripts as options. As well thanks to the users for the feedback.

    Thanks to you all for take your time in order to help others.
     
  14. Memorian

    Memorian Ancient Guru

    Messages:
    2,957
    Likes Received:
    168
    GPU:
    Strix 2080 Ti OC
    Wagnard, is it possible to make ISLC to start automatically with windows ? Also, i'm running Timer Resolution in the backround, does it conflict with ISLC ?
     
  15. DiceAir

    DiceAir Maha Guru

    Messages:
    1,350
    Likes Received:
    14
    GPU:
    Galax 980 ti HOF
    Yes you can. Go to start menu type run enter then shell:startup en press enter. right click on the program exe then select copy. go to the shell:startup windows you just opened and paste shortcut. right click on the shortcut and go to proporties then go to compatibility and click "change settings for all users" then tick "run program as administrator" and you done.

    This will only make it startup when you log into windows so if you want to run it without loging in to windows you would have to run it as a service.
     
    Last edited: Oct 26, 2018

  16. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,715
    Likes Received:
    4,312
    GPU:
    GeForce GTX 1070
    Apart from Start menu method described by DiceAir you can create task in Task Scheduler which will launch ISLC at logon. I can show you bat-file text to do that from command line.

    As for timer resolution there is no conflict in running several timer resolution tools. It is just wasteful a bit - to run two processes when the tweak can be done from each of these.
     
  17. aufkrawall2

    aufkrawall2 Master Guru

    Messages:
    415
    Likes Received:
    3
    GPU:
    MSI RX 580 Armor
    I need to start it with a delay of 30s via Task Scheduler because a stupid bug otherwise makes the tool's tray icon not visible. So many bugs in Windows 10...

    My brother gave BF1 a go with latest Windows 10 insider build on a Ryzen 5 2600 OC 16GB system a go: Unfortunately, it was a stuttery mess, despite of flushing standby memory list. And it's definitely 100% smooth with Windows 10 1607 on the same system with same settings otherwise.

    I installed a RX 560 instead of a GTX 1070 Ti, and no matter how much standby list memory was used, it didn't stutter even once. When there is stutter with Nvidia, it also happens with lowest texture detail and 720p render resolution, so probably having more performance and VRAM with the Nvidia card is not an excuse.

    Anyone else who has graphics cards of both AMD and Nvidia who could give it a go?
     
  18. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,715
    Likes Received:
    4,312
    GPU:
    GeForce GTX 1070
    [​IMG]
     
  19. lucidus

    lucidus Ancient Guru

    Messages:
    11,856
    Likes Received:
    1,373
    GPU:
    .
    Is this still an issue? I was on 1809 since it was signed off and I noticed Yakuza 0 was noticeably more smooth on 1607 (went back). Same 60 fps with the same nvidia drivers (416.34) but smoother.
     
  20. Krzychowiec

    Krzychowiec New Member

    Messages:
    1
    Likes Received:
    1
    GPU:
    2080 Ti
    I had some massive stuttering issues recently. Not in all games, but for example games like Witcher 3 or Assassins Creed Syndicate were unplayable. I never had such issues before, actually I never had a single issue with Win10. But recently I didn't play any games for a longer period of time and when I started to test some games it was obvious that something is wrong. Both on my 1080 SLI that I sold already and that was working great for almost 2 years, but also on 2080 Ti that I have now (paired with 6900K 4.4 GHz and 16GB 3000 MHz memory). Tried some basic troubleshooting like reinstalling drivers and games, also clean Windows reinstall, BIOS tweaks for CPU/memory and etc, but nothing helped. It took a lot of time to fix and it still doesn't feel exactly right. I will just list all things that helped me, maybe it will be useful for someone.

    Things that provided measurable improvements:

    1. Disable Meltdown and Spectre "fixes" through InSpectre.
    2. Go back to motherboard BIOS from before Meltdown and Spectre drama.
    3. Power settings, use High Performance mode and:
    -set minimum and maximum CPU state to 100%
    -disable PCI-E power saving
    (should be default with High Performance mode)
    4. Check core parking settings with Core Parking Manager v3 (for me everything was optimal by default so I didn't have to change anything)
    5. Disable fullscreen optimizations for games played
    6. Use FreeStandbyMemory and set it to apply once per minute.

    High Performance mode and FreeStandbyMemory helped the most, but things still don't feel exactly right even though the stuttering frequency was reduced drastically. I have no idea what this is, I never had any issues like that and I never really bothered with tweaking my OS because it was never an issue, it just worked.

    I will make a clean install again when 1809 officially releases, but I doubt it will help. I really don't like how it works right now, constantly some issues especially with updates and dreaded KB4100347 update that breaks my CPU performance, forcing stock settings and ignoring the BIOS. Fortunately it can be disabled, but a single fact that someone even let this patch release in such state is absurd. So I will probably go back to the version that worked for me when I was playing games heavily, I think it was 1709. Or maybe I will just start using LTSB. My PC is built and used almost exclusively for gaming, getting unexplained and not exactly fixable stuttering issues like that is absolutely not acceptable.
     
    AveYo likes this.

Share This Page