Fix for Crysis and SLI @ 2560x1600

Discussion in 'Videocards - NVIDIA GeForce' started by Napster, Sep 28, 2008.

  1. Napster

    Napster Master Guru

    Messages:
    453
    Likes Received:
    0
    GPU:
    Dual Nvidia GTX980Ti SLI
    I know alot of people with SLI and TRI-SLI running Crysis and Warhead/Wars DX10 at 2560x1600 have been getting low fps or bad stuttering and have had no option but to run at a lower resolution.
    Iv also been having this issue but managed to play with a few settings and found a way to fix the stuttering/low fps.

    Here is how its done,

    1) Create a file called (autoexec.cfg) and put it in your Game folder in Crysis root directory. For me it looks like this (C:\Program Files (x86)\Electronic Arts\Crytek\Crysis\Game)

    2)you will need to edit this file with notepad.

    3)Now past in these commands

    con_restricted=0
    r_DynTexMaxSize=130

    Now save the file and make sure its still a .cfg file.

    Note,
    If you change ingame graphics settings it may override the command but thats ok just change your settings and restart your game and you should be fine.

    This may also fix stuttering or low fps at lower resolution but its worth a try.

    Try this out and let me know how you guys get on :)
     
    Last edited: Sep 28, 2008
  2. dune2

    dune2 Ancient Guru

    Messages:
    3,387
    Likes Received:
    0
    GPU:
    Geforce Titan X Aqua
    Isn't r_DynTexMaxSize=130 basically the same as reducing the Textures tab in the options menu to Mainstream?
     
  3. Napster

    Napster Master Guru

    Messages:
    453
    Likes Received:
    0
    GPU:
    Dual Nvidia GTX980Ti SLI
    No well atleast not for me. I just tested it again and i looks like its set to very high. i did put it on mainstream and it looks like crap. Also without the tweak even if i put my textures on low i still get low fps.
     
  4. Napster

    Napster Master Guru

    Messages:
    453
    Likes Received:
    0
    GPU:
    Dual Nvidia GTX980Ti SLI
    Took some pics to prove, Sorry i didnt bring up fps ingame.

    With Tweak
    [​IMG]

    Without Tweak
    [​IMG]

    With Tweak taken with fraps getting 43fps
    [​IMG]

    Without Tweak taken with fraps gettin 13fps
    [​IMG]

    High rez pics
    with tweak
    [​IMG]

    without
    [​IMG]
     
    Last edited: Oct 1, 2008

  5. Paladinchan

    Paladinchan Ancient Guru

    Messages:
    1,997
    Likes Received:
    0
    GPU:
    EVGA GTX970
    damn impressive.. im going to try it with one card to see what it does
     
  6. subfire91

    subfire91 Master Guru

    Messages:
    233
    Likes Received:
    0
    GPU:
    ATI Powercolor 4870 1GB
    post ur results after that
     
  7. Paladinchan

    Paladinchan Ancient Guru

    Messages:
    1,997
    Likes Received:
    0
    GPU:
    EVGA GTX970
    well.. i put it in.. and i played some.. now to get some results..
     
  8. Paladinchan

    Paladinchan Ancient Guru

    Messages:
    1,997
    Likes Received:
    0
    GPU:
    EVGA GTX970
    well.. after some tests.. same exact performance for me..

    someone with SLI probably needs to confirm this.. lol but ill post my config that i ran just to confirm

    1680/1050 DX9 VSync High ~ 47FPS


    EDIT:

    also i just noticed you are running TWO different resolutions during your tests.. ?
     
  9. Napster

    Napster Master Guru

    Messages:
    453
    Likes Received:
    0
    GPU:
    Dual Nvidia GTX980Ti SLI
    Crap i just niticed that 2, i will rerun the test and post em up.

    check out the difference now:3eyes:
     
    Last edited: Oct 1, 2008
  10. Zooze

    Zooze Master Guru

    Messages:
    487
    Likes Received:
    0
    GPU:
    Palit GTX465 1Gb Dual Fan
    Tested this tweak as well, and made little difference. I believe its because the two different resolutions your running thats affecting your performance.

    Dohh.... :)
     

  11. Napster

    Napster Master Guru

    Messages:
    453
    Likes Received:
    0
    GPU:
    Dual Nvidia GTX980Ti SLI
    Iv fixed that now :).

    Just so you know its only SLI and TRI-SLI with a rez of 2560x1600 that really performs bad in crysis. any rez from 1920x1200 and below run perfect with SLI and TRI-SLI. But using the tweak managed to kill tha bad stuttering which is awsome :p now i can play crysis and wars at 2560x1600 :D
     
  12. Zooze

    Zooze Master Guru

    Messages:
    487
    Likes Received:
    0
    GPU:
    Palit GTX465 1Gb Dual Fan
    Okay I have an SLI rig here with GTX260's in and also my rig with an 8800GTS 640Mb in, however I can only game at a max of 1920x1200 so probably not seeing the problem.

    Zoozer
     
  13. Napster

    Napster Master Guru

    Messages:
    453
    Likes Received:
    0
    GPU:
    Dual Nvidia GTX980Ti SLI
    Oh right i see :)
    Yea 1920x1200 should run really smooth for you, its only noticeable at 2560x1600. Hopefully Nvidia can fix this without having to tweak game settings but i am ok with this tweak as i cant see any change in gfx quality.
     

Share This Page