First look at Windows 8.1

Discussion in 'Operating Systems' started by alanm, Jun 6, 2013.

  1. Anarion

    Anarion Ancient Guru

    Messages:
    13,604
    Likes Received:
    379
    GPU:
    GeForce RTX 3060 Ti
    D3DOverrider still refuses to work on my system.
     
  2. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    I think because it hasn't been updated in years that installing it is a bit hit and miss for many.

    I was using it no problems on my original Windows 8 Pro installation (itself upgraded from Vista and then 7) when I had my i7-920. I then upgraded to Haswell and did a clean install of Windows 8 Pro and found that D3DOverrider no longer worked. Well, it did work as in I could see it running as a background process with Task Manager but there was no system tray icon and the user interface refused to open so it was useless. I then did an inplace upgade to Windows 8.1 Pro and now D3DOverrider works again as there's a system tray icon and I can open the UI and everything. I even hear the sound when it engages triple buffering. :banana:

    I think it is just blind luck as to whether it'll work on Windows 8 or not. Did you do a clean install of Windows 8.1 or an upgrade?
     
  3. Anarion

    Anarion Ancient Guru

    Messages:
    13,604
    Likes Received:
    379
    GPU:
    GeForce RTX 3060 Ti
    I did upgrade. I can open it and all, it runs just fine but never triggers v-sync or triple buffering.
     
  4. kakarot

    kakarot Maha Guru

    Messages:
    1,108
    Likes Received:
    0
    GPU:
    evga 980ti sc+

    I get my chipset, MEI, RST drivers from here. They're always the latest, safe to use and 8.1 ready.

    But I've haven't run into any issues with 8.1 and only missing creative drivers -no surprise there- although I at least got sound with what comes with 8.1. Very nice OS with start8 and noticeable improvement all around, especially in my favorite extremely cpu heavy game, GW2.
     

  5. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    I noticed last night before I shutdown my PC that Windows was using 10.8 GB of my 16 GB of RAM!!! Not that it was running slow, if anything it was very fast, especially at opening apps and games I'd already used so I guess it must cache them in available phyiscal memory rather than in the page file? I admit that I was a little shocked to see such high RAM usage though. Even Vista, bloated as it was, never used 70% of my memory! :3eyes:

    Also, I still haven't found where these animated Start screen backgrounds are. On the Charm bar, from the Start screen, when I click on Personalize it opens a menu on the right-hand side with a range of backgrounds and two sets of colours palettes to customize the background and accent colours. However, none of those pre-set backgrounds are animated. I've read that Windows 8.1 is supposed to have animated background for the Start screen, such as fish tails moving, gears turning and so on, albeit they're supposed to be subtle but I can't see any animation at all.

    So does Windows 8.1 RTM have these animated backgrounds built-in or not?
     
  6. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,198
    Likes Received:
    1,938
    GPU:
    Zotac GTX980Ti OC
    Its metro animated backgrounds. There where you select its colours/patterns.
     
  7. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    That's where I was but none of the backgrounds animate for me. They're all static unless I've somehow enabled a setting that overrides it, for example, I have the setting to make the desktop and Start screen wallpaper the same.

    *EDIT*
    This section here:

    [​IMG]

    *EDIT 2*
    Apparently only 6 of the 20 pre-set wallpapers are animated (called tattoos), 12 are static, one is a solid colour and the other is the one you're currently using on the desktop (bottom-right). My problem is that I can't find any that actually animate!
     
    Last edited: Oct 9, 2013
  8. IcE

    IcE Don Snow Staff Member

    Messages:
    10,692
    Likes Received:
    73
    GPU:
    Zotac GTX 1070 Mini
    Sim city 4 is broken on modern hardware, it has little to do with the OS. I've never been able to play it above 30fps .
     
  9. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,198
    Likes Received:
    1,938
    GPU:
    Zotac GTX980Ti OC
    Yes only a few are animated, I think they animate only if you scroll left to right.
     
  10. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    Ah right, I thought were animated all the time. I've just scrolled across and, yes, some of them do have animations like the cog wheels turning and the little flying robot guy moving left and right. They even animate if you move the mouse into the corner where the Charm bar is. It's a very subtle effect indeed that you can easily miss and mostly pointless really. I guess I'll stick with matching desktop and Start screen background, ta very much!
     

  11. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    I asked this early but no-one replied... has anyone else experienced extremely sensitive mouse mouse movement when Windows has booted to the lock screen and before it has loaded the Start screen/desktop? By that I mean the mouse moves incredibly fast and over larger distances for the same amount of movement than it does once the desktop or Start screen have loaded?

    I'm using the Razer Mamba Elite 2012 mouse with a 1,000 MHz polling rate and a 1,800 dpi (was 1,200 dpi) and that has always worked fine on Windows 7 and 8. I never noticed it running faster than normal on Windows 8's lock screen either; it has only happened since upgrading to Windows 8.1 last weekend. It's like mouse acceleration is enabled or the dpi is set much higher and it only "settles down" once the desktop/Start screen have appeared because the Razer Synapse 2.0 software I'm using has loaded (presumably) the driver and Default profile setting.

    I've tried lowering the Mouse control panel's Pointer Options > Motion setting from Fast to about half way but that makes the mouse move at half the speed on the desktop (it's why I've increased the dpi from 1,200 to 1,800).
     
  12. PhazeDelta1

    PhazeDelta1 Moderator Staff Member

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    Can't say that I've had that happen.
     
  13. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    It is likely an incompatibility issue with my Razer mouse. Hopefully, either Razer or Microsoft will release an update by next Friday which is when Windows 8.1 becomes officially available to everyone. It's something that isn't problematic anyway I only use the lock screen to sign into Windows with my password and after that the mouse returns to its normal speed. I was just wondering if anyone else had the same issue, that's all.
     
  14. PhazeDelta1

    PhazeDelta1 Moderator Staff Member

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    Yea, I don't think Synapse is officially supported with 8.1 yet. But it works fine on my end. Make sure your using v1.14

    I believe that is the latest.
     
  15. Mineria

    Mineria Ancient Guru

    Messages:
    4,531
    Likes Received:
    240
    GPU:
    Asus RTX 2080 Super
    So far Windows 8.1 is an incompatible POS for my setup.
    Will have to wait for everyone to update their drivers and software before it is usable, conflicts with about everything atm.
     

  16. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    @ Mineria - I haven't had too many problems so far. Although it may seem like it from my posts, most of the issues such as missing audio and non-functioning games have been resolved with the exception of FIFA 13 which outright refuses to load. Also, I cannot play The Raven: Legacy of a Master Thief but that seems to have stopped working since I reinstalled Windows 8 Pro back in June (when I built this current Haswell system) so I can't blame Windows 8.1 for that! I did have issues loading Might & Magic X: Legacy and Scribblenauts but they turned out to be conflicts with EVGA Precision X v4.2.1's on-screen display (which is odd because they worked fine with Windows 8 Pro). Adding profiles for both games and disabling the OSD fixed those. I've also managed to resolve the hyper-fast mouse issue I mentioned by lowering the speed in the Mouse control panel applet from Fast to half-way between Fast and Slow (presumably this would be 'Normal'?). It now feels fine on both the Lock screen and on the desktop, etc.

    All the other games I've tried seem to be working OK, including Shadow Warrior, Total War: Rome II and Gas Guzzlers Extreme, and I've not had any blue-screen crashes or misbehaving apps so far. I'm sure as I go through my games library (I have over 400 installed!) that'll I'll come across others that don't work properly but so far I'm pretty satisfied with how well it is running currently. In time, Microsoft will release updates for Windows 8.1 and developers will patch out the remaining issues so I'm glad I went ahead and installed it. I even got D3DOverrider to work again (it refused to work properly in Windows 8!). :D
     
  17. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    Mine shows as v2.0.
     
  18. PhazeDelta1

    PhazeDelta1 Moderator Staff Member

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    I'm referring to the driver version. Click the ? button at the top of the app panel and it'll tell you what driver version you have installed.
     
  19. Loobyluggs

    Loobyluggs Ancient Guru

    Messages:
    4,258
    Likes Received:
    1,057
    GPU:
    EVGA 1070 FTW
    Tried installing 8.1 twice and both times it black screened, rebooted to 8 and said it can't be done.

    I would say any ideas but with so little information to go on it would behave for you to offer any methinks...
     
  20. Witcher

    Witcher Master Guru

    Messages:
    384
    Likes Received:
    0
    GPU:
    Intel
    I have a problem with windows 8.1. I can not edit anything in C:. It looks like that I have admin rights but I can not use them. For example, I cannot create edit or delete any folder in C:
    Kindly help me with this.
     

Share This Page