Firefox freezing alot

Discussion in 'General Software and Applications' started by the_4ork, Nov 27, 2014.

  1. the_4ork

    the_4ork Master Guru

    Messages:
    275
    Likes Received:
    0
    GPU:
    Powercolor HD4850
    ive got the latest firefox and shockwave player. but im getting a lot of freezes and unresponsiveness. I keep getting that stop script popup for shockwave

    any suggestions besides using a different browser?

    its getting annoying?
     
  2. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,562
    Likes Received:
    1,630
    GPU:
    ROG Strix 1080 OC
    Usually FF freezing / crashing is down to addons, trying running it in safemode (Firefox not windows) - if its fine, it's an addon
     
  3. brunopita

    brunopita Banned

    Messages:
    611
    Likes Received:
    0
    GPU:
    MSI Gaming R9 270X 2GB
    Try to disable hardware acceleration. It's a ****ing old bug that will exist forever.
     
  4. tsunami231

    tsunami231 Ancient Guru

    Messages:
    12,498
    Likes Received:
    1,018
    GPU:
    EVGA 1070Ti Black
    I have not had HW acceleration on my personal pc in 5+ years, as it tends to hardlock my pc if i have TS/VENT/MUMBLE up and running.

    I have disabled in any .net app that allow hw acceleration to be disabled along with in flash. never saw any benefits ti hw acceleration on in any of those apps.

    But HW acceleration is buggy at best at lest on my system, and FF hw acceleration has been bugg since forever Mozilla dev even say to disable hw acceleration if u have issues, which saying something.
     

  5. CalculuS

    CalculuS Ancient Guru

    Messages:
    3,105
    Likes Received:
    329
    GPU:
    GTX 1660Ti
    Hardware acceleration is even worse for amd, youtube with HW acceleration causes blue screens and hard locks.

    Confirmed bug since 11.2 CCC, still in 14.4.
     
  6. brunopita

    brunopita Banned

    Messages:
    611
    Likes Received:
    0
    GPU:
    MSI Gaming R9 270X 2GB
    I use Waterforx, 64 bits build, and it works with HW acceleration turned on, but there's some strange bugs with the image in certain sites. I can resolve the problem by scrolling up and down.
     
  7. maur0

    maur0 Master Guru

    Messages:
    831
    Likes Received:
    59
    GPU:
    point of view gtx 570 1gb
    Last edited: Nov 28, 2014
  8. CrazY_Milojko

    CrazY_Milojko Ancient Guru

    Messages:
    2,473
    Likes Received:
    1,086
    GPU:
    Asus STRIX 1070 OC

    1). Firefox >>> Help >>> Troubleshooting information >> Reset Firefox

    2). Firefox >>> Help >>> About Firefox ...update to latest version and restart Firefox after update procedure

    3). Firefox >> Tools >> Add-Ons >> Extensions >> Remove unneeded add-ons

    4). Firefox >> Tools >> Add-Ons >> Plugins >> Disable unneeded plugins

    Come back here with report
     
  9. the_4ork

    the_4ork Master Guru

    Messages:
    275
    Likes Received:
    0
    GPU:
    Powercolor HD4850
    how do you actually remove the plugins? im not seeing any options?

    i have a TON
     
  10. MrH

    MrH Ancient Guru

    Messages:
    2,809
    Likes Received:
    14
    GPU:
    MSI GTX 1080 Armour
    I've been freezing a lot the past week or two in Firefox, before it was fine but I'm freezing daily now.
     

  11. CrazY_Milojko

    CrazY_Milojko Ancient Guru

    Messages:
    2,473
    Likes Received:
    1,086
    GPU:
    Asus STRIX 1070 OC

    easy way: Firefox >> Tools >> Add-Ons >> Plugins >> click on plugin and choose: Never activate

    one more solution via config, in adress field type: about:config ...but be careful and don't touch/change options you're not familiar with


    Not a single problem with Firefox for years, more than 20 rigs around me in my home and office are primarily using Firefox since 2008 (Chrome is strictly forbidden on every rig I own), from few single-core office rigs, to HTPC's and few gaming beasts, rigs are regularly maintained, Firefox + 10 to 12 add-ons on each Firefox and Firefox is working like a charm on every single PC... Maybe I'm just lucky? No, luck has nothing to do with it :)
     
    Last edited: Nov 28, 2014
  12. brunopita

    brunopita Banned

    Messages:
    611
    Likes Received:
    0
    GPU:
    MSI Gaming R9 270X 2GB
    No problem with HW acceleration?
     
  13. CrazY_Milojko

    CrazY_Milojko Ancient Guru

    Messages:
    2,473
    Likes Received:
    1,086
    GPU:
    Asus STRIX 1070 OC
    Nope, I had never turned OFF HW acceleration in Firefox, not even on any rig with Radeon card. On home HTPC's and gaming rigs (no need for that on office rigs, maybe once a year) I change graphics drivers every few months, DDU is god's (Wagnard's) gift for fast/perfect driver cleaning before installing newer. BTW, on most rigs with Radeon cards I'm not using/installing Catalyst Control Center, maybe something about missing CCC has to do something with lack of problems with HW acceleration in Firefox.
     
  14. brunopita

    brunopita Banned

    Messages:
    611
    Likes Received:
    0
    GPU:
    MSI Gaming R9 270X 2GB
    I don't use CCC, always use DDU in safe mode before installing drivers, CCleaner and Wise Cleaner too. The standard Firefox build started giving me problems with HW acceleration on, using a GTX 560 and an older AMD which I don't recall now, some 6-8 years ago and never stopped. pcxFirefox and Waterfox worked with no problem until the 3x.x versions, now some sites are shown with tears/artifacts, but I can solve this by scrolling up and down. And even a clean Windows install have this problem. Everything else works fine.
     
  15. the_4ork

    the_4ork Master Guru

    Messages:
    275
    Likes Received:
    0
    GPU:
    Powercolor HD4850
    how do i turn off HW accell? im on a tri-fire radeon rig...
     

  16. brunopita

    brunopita Banned

    Messages:
    611
    Likes Received:
    0
    GPU:
    MSI Gaming R9 270X 2GB
    Options -> Advanced -> General -> Use hw acceleration when available
     
  17. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    There is a bug in the latest release/s

    https://bugzilla.mozilla.org/show_bug.cgi?id=1089183

    If Maur0's update link doesn't help, you could try disabling OMTC:
    https://support.mozilla.org/en-US/questions/1022825

    Everything this guy said applies to me too:
    https://bugzilla.mozilla.org/show_bug.cgi?id=1089183#c147

    Been reoccurring over the years but never this bad.
    It's particularly noticeable with multiple tabs open, and my CPU load is pegging at up to 90% on one core...almost like multi-threading isn't working.

    I have hw acceleration off and haven't updated drivers since 14.7.
     
    Last edited: Dec 4, 2014

Share This Page