FEAR & Vista (x64)

Discussion in 'Games, Gaming & Game-demos' started by soul8103, Feb 9, 2007.

  1. soul8103

    soul8103 Ancient Guru

    Messages:
    1,813
    Likes Received:
    0
    GPU:
    8600M GT
    Hey all. Just installed vista ultimate x64 (maybe a bit premature i know but work are switching over). Installed new cats, all nf4/xfi drivers and it all runs nicely. Then i boot up fear. On xp i played this game so nicely. Now it runs so crapola. Ive gone from everything on full in xp (pretty much) too everything low and it still sux. I tried an old game like red faction which runs really nicely, as youd expect on my machine.

    So heres my question, does anyone have any tips/tricks to get this game working well in vista. Also is anyone palying this game at a smooth framerate in vista (x64). I would love to hear of anyones experiences with vista and gaming. Hopefully it isnt the case where i have to sit and wait for either driver updates or vista fixes :(.
     
    Last edited: Feb 9, 2007
  2. iamtheoneneo

    iamtheoneneo Banned

    Messages:
    730
    Likes Received:
    0
    GPU:
    Nvidia 8800GTS 640mb @ 576/1700
    i personally wouldnt even try running fear in vista - would proper suck. xp it is matey that will be your best os for fps for a long time to come.
     
  3. soul8103

    soul8103 Ancient Guru

    Messages:
    1,813
    Likes Received:
    0
    GPU:
    8600M GT
    Yeah i know. Jus a drag i gotta use it for work since my company is making the switch. Bloody ball ache if u ask me. 1 thing i realised though...., turn down mouse sensitivity rather then mouse smoothing. Thats the mistake i made lol hense it was so choppy lol. It's actually running very well now, on the same settings i played it in xp. Still not as good though, jus doesnt feel as polished
     
  4. Sash

    Sash Ancient Guru

    Messages:
    6,961
    Likes Received:
    0
    GPU:
    video
    actually you really need to wait for drivers sorry that is how it is
     

  5. soul8103

    soul8103 Ancient Guru

    Messages:
    1,813
    Likes Received:
    0
    GPU:
    8600M GT
    Yeah dont worry. It's nothing urgent. It actually plays well enough. I dont mind waiting. For work, music, internet browsing etc vista is actually a really nice os to use. Jus not great in the game department. I dont expect it to be either for quite a while longer.
     
  6. aircool

    aircool Don Aircooleone Staff Member

    Messages:
    13,761
    Likes Received:
    29
    GPU:
    Zotac GTX 560 Ti 448 Core
    pfff bah etc, i have played fear on vista on my computer , b4 i got my x1950pro and it played as well as xp.
     
  7. Daemon785

    Daemon785 Master Guru

    Messages:
    329
    Likes Received:
    0
    GPU:
    Diamond HD 5870
    mines running fine. u got aa and af on high or something? cuz i got mine at 4xaa 16xaf all settings on high and the game runs smoothly.
     
  8. iamtheoneneo

    iamtheoneneo Banned

    Messages:
    730
    Likes Received:
    0
    GPU:
    Nvidia 8800GTS 640mb @ 576/1700
    but you no it runs nowhere near aswell as in xp.
     
  9. trapper_87

    trapper_87 Master Guru

    Messages:
    382
    Likes Received:
    0
    GPU:
    HIS IceQ 7970
    I am actualy finding that it is beter in vista over XP. I left all the settings the same and after running the built in FPS finder I am up about 5-10FPS. In game it is the same (over 30fps at all times in both) but I notice that my FRAPS numbers are higher by a few points aswell. The only game that runs lower for me so far has been Counter Strike Source (went from 59.7FPS to 59.1FPS, I dont know if I can take it!)

    This is all of course after I installed the 7.2 ATi drivers (unofficial) because the 7.1 vista drivers didnt work with my card, and I had BSOD for a week with no games except on my speedy laptop (and its hude Radeon Mobility x200 GPU)
     
  10. soul8103

    soul8103 Ancient Guru

    Messages:
    1,813
    Likes Received:
    0
    GPU:
    8600M GT
    It actually runs nicely now that ive soted out the settings. I only play online so i have configured the settings as i had on xp (everything on ful accept AA @1440x900) and it runs nicely. As i said still doesnt feel as polished, but plays perfectly fine. Im actually suprised how well it runs considering how new vista actually is.
     

  11. aircool

    aircool Don Aircooleone Staff Member

    Messages:
    13,761
    Likes Received:
    29
    GPU:
    Zotac GTX 560 Ti 448 Core
    it as well maybe 1fps less
     
  12. soul8103

    soul8103 Ancient Guru

    Messages:
    1,813
    Likes Received:
    0
    GPU:
    8600M GT
    Heres a strange bug ive found now playing online in FEAR on vista. Ok guys it runs great for about 10 mins.., like amazingly better then XP then after that time it gets choppy. Still v playable but it seems something clicks.., then the performance drops. I dont oc and ive tried turning off cat AI. Still not sure what the issue it exactly but im gonna keep trying stuff. Coul be AV, could be a number of things. If its a driver issue.., hopefully 7.2 will sort it out...

    *EDIT*
    Was nod32.., hehe
     
    Last edited: Feb 11, 2007
  13. Ryu5uzaku

    Ryu5uzaku Ancient Guru

    Messages:
    7,117
    Likes Received:
    317
    GPU:
    6800 XT
    i had fear running very smooth with around 10fps drop in all around except minimum had sound problems but those went away too
     
  14. soul8103

    soul8103 Ancient Guru

    Messages:
    1,813
    Likes Received:
    0
    GPU:
    8600M GT
    Damn. The problem has re-emerged.., was not nod32. It's such a wierd issue.., game runs great for a while, then suddenly just gets choppy. I really hope its not an over-heating issue :(. Especially considering my card is zalman cooled and has been working flawlessly in xp since i got it. Jus preying its a driver issue...

    *EDIT*

    Found out the issue. omg its the crappiest thing ever. Its my mouse. This is what happens. I play fear and it runs beautifully in vista. Then suddenly it will go choppy. If i alt tab out and disable/reinable my mouse. Or if i unplug, plug it back in. It starts working really well again. Thats just nuts. Dont wanna not be able to use my G5 :(. Really hope this gets sorted either through drivers, or summin else asap.
     
    Last edited: Feb 11, 2007
  15. mmmikezd

    mmmikezd New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    EVGA 8800 GTS 640
    I also have Fear installed but I don't know what your system had. I have a Gigabyte Motherboard with a Intel Core 2 quad and also have a EVGA 8800 GTS with 640 on board and I also have 8 gig of ram.

    Vista X64 does ask for more memory than XP did but I have NO problem at all running FEAR.

    Don't know what you are running but that just might be the problem you are having.

    Mike
     

  16. dshramek

    dshramek Ancient Guru

    Messages:
    3,483
    Likes Received:
    3
    GPU:
    Gigabyte GTX 1070
    lol...this thread is over 2 years old. I am sure any problems the op had have been fixed by now.
    How do people find these old threads?
     
  17. Stromgold

    Stromgold Maha Guru

    Messages:
    1,465
    Likes Received:
    1
    GPU:
    Gigabyte GTX 1060
    Never ceases to amaze me LOL
     
  18. compuguy1088

    compuguy1088 Member Guru

    Messages:
    147
    Likes Received:
    0
    GPU:
    XFX AMD Radeon 5850
    Sadly the mouse problem has not been fixed. I played through fear a few months back, with this continual lagging appearing every so often. It is because of Logitech mice....something to do with the drivers. They never fixed it.
     
  19. dshramek

    dshramek Ancient Guru

    Messages:
    3,483
    Likes Received:
    3
    GPU:
    Gigabyte GTX 1070
    I've never installed the Logitech drivers & never had any lag problems with any games. I use a mx518 & the default 3 dpi settings.
     
  20. Sash

    Sash Ancient Guru

    Messages:
    6,961
    Likes Received:
    0
    GPU:
    video
    Mike... you failed
     

Share This Page