Farcry 3!

Discussion in 'Games, Gaming & Game-demos' started by Strikerx80, Jun 7, 2011.

Thread Status:
Not open for further replies.
  1. millibyte

    millibyte Maha Guru

    Messages:
    1,222
    Likes Received:
    163
    GPU:
    2070 subpar RTX OFF
    Hey buddy, how about some spoiler tags? Not everyone has beat the game here yet.

    I'm wondering if any other users are having poor performance in dx9. I loaded the game up and it seemed to be running great but when I climbed to the top of a tower, there was a massive fps drop while looking out towards the water. This never happens in dx11. GPU usage goes up to 99% and the framerate tanks to the 20s. I'm wondering what the heck is going on in this scene that should be so taxing on my system when it runs 60+ fps in dx11?
    Seems to happen anytime I'm overlooking a cliff onto water/islands in the distance.
     
  2. dsbig

    dsbig Ancient Guru

    Messages:
    4,052
    Likes Received:
    42
    GPU:
    EVGA RTX 2070

    :bang: sorry


    I didnt say which chick.....
     
  3. Bullu$

    Bullu$ Master Guru

    Messages:
    410
    Likes Received:
    0
    GPU:
    R290X CFX@1050/1350
    I got exactly the same in dx9, in dx11 at the same spot no framedrops.

    http://forums.guru3d.com/showthread.php?p=4474985#post4474985
     
  4. BABA-The Hacker

    BABA-The Hacker Banned

    Messages:
    455
    Likes Received:
    0
    GPU:
    PALIT GTX770 OC 2GB
    got it...

    higher <> better...
     

  5. Year

    Year Ancient Guru

    Messages:
    11,594
    Likes Received:
    1
    GPU:
    EVGA GTX 690
    update 1.04 improved performance for me, even though the fps didn't change, lag has pretty much disappeared completely when dealing with too many enemies and explosions at once. :p
     
  6. ViperXtreme

    ViperXtreme Ancient Guru

    Messages:
    3,123
    Likes Received:
    20
    GPU:
    GTX 1070 Super Jetstream
    dunno why but whenever i boot up the game, the original far cry 1 music keeps playing and looping in my head '__'
     
  7. Donny_uk

    Donny_uk Member

    Messages:
    43
    Likes Received:
    0
    GPU:
    EVGA GTX680 Classi 4095Mb
    Right, I need some help from more experienced gamers.

    I've just upgraded my rig while still using my Dell 435MT's motherboard and CPU. But I think my i7 may be bottlenecking the GPU?

    I'm getting between 40-55 FPS with dips down to 35 FPS and that's with PostFX off or on. It doesn't really make a difference in terms of frames per second, but with PostFX on my GPU usage goes to 98%, while off it hovers at 65-75%.

    I thought that a 4Gb 680 classified would let me play the game at 60FPS locked with everything maxed.

    What's funny is that my CPU usage is only about 40-50% while playing the game.

    I'm not running the game off my SDD, instead it's on a 7200rpm harddrive with all my steam games on it. Skyrim with the mega texture DLC runs fine locked at 60 FPS with an occasional dip to 55 and sometimes even going to 90 FPS.

    I don't know what could be the issue :cry:
     
  8. villa_youth

    villa_youth Master Guru

    Messages:
    808
    Likes Received:
    0
    GPU:
    780 Ti
    Would definitely try some overclocking on your 920.
    I know when I changed form a 920@3.4 to a 2600k i7 I noticed frame rate improvements in many games so that 680 GTX you've got could probably use a bit more cpu speed thrown at it.
    Would help with crappy PC ports that are cpu limited also.
     
  9. Donny_uk

    Donny_uk Member

    Messages:
    43
    Likes Received:
    0
    GPU:
    EVGA GTX680 Classi 4095Mb
    Yeah, but my motherboard doesn't allow for any overclocking. I tried using SetFSB and the PC hanged at slightly under 3Ghz. I can't find any good LGA 1366 motherboards for gaming at a reasonable price.

    Well I'm saving up for the next gen Haswell chips, but I will upgrade my x58 in the meanwhile to do some overclocking. Any suggestions?
     
  10. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    they need to fix the multi-threading, i think that would fix the performance issues. the cpu just doesnt get used properly....
     

  11. seaplane pilot

    seaplane pilot Maha Guru

    Messages:
    1,295
    Likes Received:
    2
    GPU:
    2080Ti Strix
    Agreed! I have put the game on the back burner for now & joining it is AC3.
     
  12. F.A.Q

    F.A.Q Banned

    Messages:
    48
    Likes Received:
    0
    GPU:
    EVGA GTX 660 FTW Sig 2.
    It loves Quad core or at least 3GHz HT i3.
     
  13. Kaleid

    Kaleid Ancient Guru

    Messages:
    2,600
    Likes Received:
    221
    GPU:
    Gigabyte 3070 OC
  14. gridiron whirlw

    gridiron whirlw Ancient Guru

    Messages:
    3,877
    Likes Received:
    49
    GPU:
    GTX 570 SLI
    Has anybody played the co-op campaign....is it any good....how long is it?
     
  15. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    not to sure how long it is but it's pretty good if you have people cooperating...
     

  16. gridiron whirlw

    gridiron whirlw Ancient Guru

    Messages:
    3,877
    Likes Received:
    49
    GPU:
    GTX 570 SLI
    Thanks
     
  17. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    if you get the game i would really like to here about your MP, COOP performance.
     
  18. gridiron whirlw

    gridiron whirlw Ancient Guru

    Messages:
    3,877
    Likes Received:
    49
    GPU:
    GTX 570 SLI
    Is co-op performance bad ?
     
  19. signex

    signex Ancient Guru

    Messages:
    8,803
    Likes Received:
    158
    GPU:
    NVIDIA RTX 3050 Ti
    Improve performance? With that card you're FPS is probably sky rocketing :infinity:
     
  20. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    coop is ok, not as good as single player. it's MP thats terrible! SLi setups crash it at the end of a round. i have to set the profile to "single gpu" and turn settings down to "high" to keep it from crashing and hold 60 fps vsynced.
     
Thread Status:
Not open for further replies.

Share This Page