Far Cry 4 Driver ?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Dicehunter, Nov 17, 2014.

  1. jwb1

    jwb1 Master Guru

    Messages:
    725
    Likes Received:
    156
    GPU:
    MSI GTX 2080 Ti
    Download new 344.75 driver. Use SMAA for AA, enable triple buffering in-game option. Experiment with sparse Vsync.
     
  2. EL1TE

    EL1TE Master Guru

    Messages:
    428
    Likes Received:
    102
    GPU:
    GTX1080 SH X 2.1GHz
    I was having stutters on Dragon Age Inquisition, tried various drivers always the same, despite having it installed on my SSD, i decided to Defrag it, yes i Defrag my SSD.

    Even the simple Benchmark would stutter at some point and give min FPS of 22, it gives min 34FPS on Ultra and 4xAA now with no stutters after benchmark.

    Most of the stutter is gone.

    I used MyDefrag 4.3.1 (far better than Auslogics Disk Defrag which was what i used before, despite the Software not being pretty it's amazing) and i used the System Disk Monthly option.

    I too sometimes forget to defrag, and an SSD shouldn't need Defrag at all, but it seems it does.

    I don't know if it will help with Far Cry 4 but you should give it a try.
     
  3. SSJBillClinton

    SSJBillClinton Master Guru

    Messages:
    743
    Likes Received:
    118
    GPU:
    2080Ti Zotac AMP!
    Just put FC4 over to my SSD, makes 0 difference vs the WD Blue I had it on before. Still stuttering.
     
  4. EL1TE

    EL1TE Master Guru

    Messages:
    428
    Likes Received:
    102
    GPU:
    GTX1080 SH X 2.1GHz
    If they are both fragmented yes, it won't make much difference if any.

    I don't have the game so i can't test, sorry.

    Personally i didn't like what i saw in the trailers, i loved Far Cry 3, but this one for some reason doesn't appeal me.

    Try to defrag the drives, disable Anti Virus or any applications that read a lot of files or monitor files/system etc

    Better yet, create a new windows account and try to play from there, obviously defrag the drives also.
     

  5. Gd350turbo

    Gd350turbo Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    Gigabyte 780 ti OC
    Driver 344.75 is out !
     
  6. skryabin

    skryabin Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    Nvidia GTX1070 ASUS
    me too, random black flashes like the shutter effect on a camera.
    wtf

    EDIT: I'm using 344.75
     
    Last edited: Nov 18, 2014
  7. lenix

    lenix Master Guru

    Messages:
    309
    Likes Received:
    0
    GPU:
    EVGA 1080 Ti FTW3
    Solid-state drive fragmentation is negligible, it doesn't affect performance whatsoever.
     
  8. Alex13

    Alex13 Ancient Guru

    Messages:
    2,382
    Likes Received:
    170
    GPU:
    -
    SSD defrag lewl. :stewpid:
     
  9. SSJBillClinton

    SSJBillClinton Master Guru

    Messages:
    743
    Likes Received:
    118
    GPU:
    2080Ti Zotac AMP!
    How very strange! My friend also has the same issue with the exact same card as both as you.


    Also in regards to the stuttering, I think this game just has a case of the Ubisofts.
     
  10. skryabin

    skryabin Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    Nvidia GTX1070 ASUS

  11. zimzoid

    zimzoid Maha Guru

    Messages:
    1,437
    Likes Received:
    24
    GPU:
    2xEVGA980TiSC+(H20) Swift
    No stutter for me either, all settings at high msaa 2x stable at 120fps
     
  12. EL1TE

    EL1TE Master Guru

    Messages:
    428
    Likes Received:
    102
    GPU:
    GTX1080 SH X 2.1GHz
    :)

    Well everytime i do defrag it selects both Hard Drives, i never bored to look into it, on Analysis it shows everything red, so i went ahead and it defrag :grin: because i thought it was the cause of Dragon Age Inquisition and the stutter was gone after defrag.

    Apart from this only thing i did was close raptr, however when i restart PC today raptr was on again and i went to play Dragon Age Inquisition, was as smooth as after i defrag.

    Might haven been something else then.
     
  13. alvaro761991

    alvaro761991 Member

    Messages:
    46
    Likes Received:
    0
    GPU:
    Nvidia GTX 850m
    This fixed my stuttering issue!!

    Originally Posted by dhabulin View Post
    Well, after some experimenting i found one way to get rid of this stuttering. First change graphics quality in game to "custom", then go to C:\Users\Master\Documents\My Games\Far Cry 4 and edit GamerProfile.xml file, change DisableLoadingMip0="0" to DisableLoadingMip0="1" . Stutter almost completely gone. I noticed that game now uses around 1700MB VRAM, and before that was around 2600MB. Not sure what is that setting for. Quick test shows no visual difference in game. Further testing required. Please report back your findings.
     
  14. Terepin

    Terepin Master Guru

    Messages:
    753
    Likes Received:
    45
    GPU:
    MSI 2070S GAMING X
    Until they fix mouse, it's nearly unplayable. At this point only masochist can play this mess.
     
  15. SSJBillClinton

    SSJBillClinton Master Guru

    Messages:
    743
    Likes Received:
    118
    GPU:
    2080Ti Zotac AMP!
    Made it a lot more tolerable for sure.
     

  16. schoolofmonkey

    schoolofmonkey Master Guru

    Messages:
    202
    Likes Received:
    11
    GPU:
    ROG RTX2080ti Strix
    Last edited: Nov 19, 2014
  17. SLI-756

    SLI-756 Banned

    Messages:
    7,604
    Likes Received:
    0
    GPU:
    760 SLI 4gb 1215/ 6800
    pc gaming wiki fc4 page for latest fixes.
     
  18. ManuelG

    ManuelG NVIDIA Rep

    Messages:
    858
    Likes Received:
    259
    GPU:
    Geforce RTX 2080 FE
    What in game graphics setting are you using? Are you using any overrides from the NVIDIA Control Panel? Can you post screenshots of this?
     
  19. schoolofmonkey

    schoolofmonkey Master Guru

    Messages:
    202
    Likes Received:
    11
    GPU:
    ROG RTX2080ti Strix
    Will do.
    I was running on the NVIDIA settings, but the only override was motion blur off, and no xml tweaks.
    I've tried it with everything default and set to NVIDIA, its only in dark areas:
    (Sorry for the thread photo flood, hope it helps)

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
    Last edited: Nov 20, 2014
  20. moab600

    moab600 Ancient Guru

    Messages:
    6,231
    Likes Received:
    166
    GPU:
    1080TI Gaming editi

Share This Page