Far Cry 4 AMD tweaks?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by mtdew332, Nov 26, 2014.

  1. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    7,846
    Likes Received:
    298
    GPU:
    Zotac GTX1080Ti AMP
    My settings:

    I unpacked and modified the patch.dat/patch.fat files to fix the mouse acceleration issue and its not 100% but its sure as hell much better - see main thread for a link on how to do it.

    I have this set in a shortcut on desktop

    at the end of the target line write

    -disablepagefilecheck -skipintro

    also set to run as admin for everyone and open Uplay and then run the game from the shortcut for these to work

    I also changed in .ini file

    FOVscale to 1.20000 for as close to 95 FOV as I can get with minimal clipping

    Everything is set to Ultra Preset, Vsync off, Triple Buffer off, HBAO+ on, SMAA, Volumetric Fog, etc nothing changed all Ultra.

    Using RTSS to cap fps to 45fps and it does dip when loading some new areas but its instant. Like a slip second and its back up. Fighting it stays locked at 45fps and never dips and I was in a massive fight the other day easily 20 enemies and around 10 friendly on screen with two elephants and bombs going off. It stayed pegged at 45fps.

    Just seems to be issues with streaming in new areas. I have the game installed on SSD so load speeds are not the issue. Its 100% the game it self.

    Played it on my friends PS4 and the graphics looks NOWHERE near Ultra on PC. It seems like a mixture of low and medium at best and the fps is pegged at 30fps and still dips on the PS4.
     
  2. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,175
    Likes Received:
    86
    GPU:
    RX 580 8GB
    I also found limiting FPS with RTSS helps with general stuttering. RadeonPro doesn't work for that.
     
  3. crz

    crz Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 ARMOR 8G
    I tried both SSD and HDD installs and does not seem to influence stuttering.
     
  4. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,175
    Likes Received:
    86
    GPU:
    RX 580 8GB
    Even at the lowest resolution (1280x800 I think) and the lowest settings, the game still stutters, also when locked to 40FPS.
     

  5. N3MBOT

    N3MBOT Member Guru

    Messages:
    197
    Likes Received:
    0
    GPU:
    Gigabyte R9 280xoc
    yeah it runs a bit worst in the more heavily populated areas , especialy with many buildings , but its not game breaking i can live with that and still enjoy the game, and thanks , i´ll be posting on my channel a lot more content on it this coming days ;)
     
  6. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,175
    Likes Received:
    86
    GPU:
    RX 580 8GB
    Have a FPS OSD visible while you do that so we can see the drops.
     
  7. mtdew332

    mtdew332 Member Guru

    Messages:
    123
    Likes Received:
    1
    GPU:
    Sapphire R9 390x
    Just to be clear to some.
    We're not really complaining that the game is unplayable...because it is perfectly playable.

    What we're trying to figure out (and why this thread was created ) is if there are any tweaks that can eliminate the stuttering (hitching) when traveling that seems to happen when the game loads new data.

    At this point, I don't really think there is a solution yet besides doing the DisableLoadingMip0="0" tweak or putting textures on medium.
    Which most of us are unwilling to do, due it to lowering image quality too much.

    It just seems like when using high/very high/ultra textures that its impossible to load the new textures without a "hitch" happening ... like there simply isnt enough bandwidth available to load them without a "hitch" happening.

    So it seems for now, that if you wanna play with higher textures, you're just stuck living with the occasional hitch when traveling fast.

    Is it unplayable? Absolutely NOT! Its definitely playable!
    It would just be nice to eliminate the stutter/hitching completely, that's all.

    I mean, I think we all already know how to tweak game settings to get the best playable framerates on our hardware.
    Its just trying to eliminate those occasional stutters/hitches that seems almost impossible to get rid of in this game.
     
    Last edited: Dec 3, 2014
  8. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,175
    Likes Received:
    86
    GPU:
    RX 580 8GB
    Changing xml settings does nothing here, and yes it does make the game unplayable for me because most of the time in the game you're running or driving and that's when the stutters happen.
     
  9. mtdew332

    mtdew332 Member Guru

    Messages:
    123
    Likes Received:
    1
    GPU:
    Sapphire R9 390x
    All I can do is maybe share my settings while testing on my backup rig with a 7950. ( I actually have the game running on that rig right now beside me while I type this on my main rig in sig)

    My backup PC is.
    2500k @ 4.6ghz
    16gb DDR3
    Two 7950's in x-fire (xfire disable for this game)
    Intel SSD
    WD Black HDD
    1080p monitor
    Asrock Z68 Extreme 4 mobo

    Game is installed on mechanical HDD.
    Game is perfectly playable for me on a single 7950 @ 1080p....40fps - 60fps (of course it goes over 60fps indoors due to having vsync off, but outdoors its around 40fps - 60fps with the settings below)
    I only get occasional hitching on that rig also. (exact same occasional stuttering/hitching while running/driving as my main PC)
    But the stutters/hitches don't happen during firefights or in towns, only when traveling fast over longer distances when it seems the game has to load textures for a new area. (sorry, best I can describe it)

    Settings tested are..
    1080p
    Borderless (so i can run with vsync off with no tearing)
    Motion Blur - off (cuz I hate it)
    Textures - Ultra
    Shadows - Ultra
    Post FX - Ultra
    Geometry - Ultra
    Vegetation - Ultra
    Terrain - Ultra
    Water - Ultra
    Environment - Ultra
    Ambient Occlusion - SSBC
    Anti-Aliasing - SMAA
    GodRays - Off
    Fur - On
    Trees Relief - On

    Added to shortcut....
    -skipintro -disablepagefilecheck

    GamerProfile.xml (only one tweak)
    AlphaToCoverage="0"

    note: It may be just a placebo but the game seems to run smoother when I completely disable x-fire in CCC and not just letting the 14.11.2 beta drivers do it for me.
     
    Last edited: Dec 3, 2014
  10. mtdew332

    mtdew332 Member Guru

    Messages:
    123
    Likes Received:
    1
    GPU:
    Sapphire R9 390x
    Well I'm gonna have to eat my words on this one.

    Had a friend stop over while I was playing and he commented on how my game didn't look smooth.
    I said, I don't see stutter.
    He said, he'd describe it more like a "constant jitter".
    Of course I had no idea how he could possibly think that since It seems perfectly smooth and playable to me.

    Anyway, He has a GTX 970.
    So I agreed to go to his place and try the game.

    And let me tell you the difference is like night and day...its WAY WAY WAY smoother on his Nvidia card.
    Its not even close, regardless of what framerate Im getting on my R9 290, its isn't even close to as smooth as the game runs on his 970.

    Problem now is, since Ive played it on a Nvidia card and experienced this smoothness, now I cannot ignore it or stop noticing on my PCs.

    Of course as we all know this is a Nvidia Gameworks title, so its gonna favor Nvidia GPUs.
    But it still sucks.

    Anyway, just wanted to post and say that now I can certainly see how some people perceive it as an unplayable stuttering mess on AMD hardware.
    Some people are just more sensitive to it than others and notice it easier.

    Believe it or not, I liked it better when I didn't notice it.
    Because once you see the difference in smoothness, now there is no way I can stop noticing it.
     

  11. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,175
    Likes Received:
    86
    GPU:
    RX 580 8GB
    Yea, I've played some really smooth games, like Deus Ex: Human Revolution, that game is like butter. Once you go from that to a stuttery game you notice it straight away, well I do.
    Ubisoft seem to cripple AMD support, in favor of NVIDIA, not because it's a gameworks title, but because they're paid a lot. I wonder if they test on AMD machines, otherwise there's no way they could let it ship like that.
    I'm yet to play a smooth game from Ubisoft (with AMD hardware).

    Sadly, there's nothing AMD drivers can do, Far Cry 3 is the same, even now.
     
  12. DiceAir

    DiceAir Maha Guru

    Messages:
    1,351
    Likes Received:
    14
    GPU:
    Galax 980 ti HOF
    exactly. just like you didn't experience the jitter at first some people think they see no screen tear with not vsync on 1080p 60hz but yeah I do. Also so the same as some people don't understand how I can get 80fps on my qnix qx2710 2560x1440@96hz but still get lag or jitter or microstutter even with vsync off it makes matters worse. When I had my gtx 570 sli I had to lower my graphics settings a bit more but my fps even when it dipped it was still rather smooth.


    So maybe I should just sell my cards and get 1x gtx980 or 1x gtx970 at first then upgrade to sli later. I had a friend over that played shadow of mordor on a gtx 760 and even when disable crossfire and running on low the game looks smoother and better on his system @ 1080p 60hz. So I came to conclusion that Nvidia is simply just better all round. power and smoothness wise. high fps, low frametime is not everything.
     
  13. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,175
    Likes Received:
    86
    GPU:
    RX 580 8GB
    FPS and frametime are everything. When games are poorly optimized (Far Cry 3/4) for example. The stutters occur when the FPS drops and the frametime goes up. If a game ran at 16ms and 60FPS the entire time, it would be smooth all the time.
    I'm not speaking about multi-GPU problems, but smoothness in general.
     
  14. DiceAir

    DiceAir Maha Guru

    Messages:
    1,351
    Likes Received:
    14
    GPU:
    Galax 980 ti HOF
    No it's not. You get jitter aswell. Hard to explain wish you could visit me so I can explain but yeah. In some games I get some screen shake when moving sceen from side to side but fps stays at 96-100 for some odd reason vsynced. So yeah FPS and frametime is not everything
     
  15. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,175
    Likes Received:
    86
    GPU:
    RX 580 8GB
    So when this "jitter" occurs, frametime doesn't spike?

    This is what MSI Afterburner reads when I see/feel a jitter/stutter:

    [​IMG]
     
    Last edited: Dec 3, 2014

  16. DiceAir

    DiceAir Maha Guru

    Messages:
    1,351
    Likes Received:
    14
    GPU:
    Galax 980 ti HOF
    no it doesn't. Frame stays on steady 96-100fps. So not a framerate or frametime issue. Well maybe frametime but for sure not framerate issue
     
  17. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,175
    Likes Received:
    86
    GPU:
    RX 580 8GB
    Precisely. Far Cry 4 suffers from frametime spikes.
     
  18. crz

    crz Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 ARMOR 8G
    Jitter = the amount of variance in frametimes. If you are running 60 fps with VSync on, the jitter would the deviation of each frametime from 16.67 ms. Sometimes it jumps to as much as 90 ms for me but between the spikes it maintains constant 16.67 ms. Those spikes are the jitter.
     
  19. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,054
    Likes Received:
    157
    GPU:
    Sapphire 7970 Quadrobake
    The problem that the game has is that it's such a bad port, that it doesn't request the proper timer resolution from the OS.

    Download this, run it, set the timer to 0.5 and run the game.

    It almost completely eliminated the stutters for me.
     
  20. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,175
    Likes Received:
    86
    GPU:
    RX 580 8GB
    Nothing changes here.
     

Share This Page