Far Cry 4 AMD tweaks?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by mtdew332, Nov 26, 2014.

  1. mtdew332

    mtdew332 Member Guru

    Messages:
    123
    Likes Received:
    1
    GPU:
    Sapphire R9 390x
    I know we have a specific game forum, but its mostly Nvidia users and finding any place to share and discuss only AMD specific tweaking info for this game is nearly impossible.

    I'm running...
    2600k @4.7ghz
    16gb DDR3
    Sapphire Tri-x R9 290
    1920x1200 monitor
    14.11.2 beta drivers
    Running Ultra preset with motion blur disabled. (cuz I hate motion blur)

    I just don't seem to be able to get a completely smooth experience no matter what I try.
    I can turn down the game settings, but all that does is increase my FPS in areas where its already high and I don't need more FPS, yet seems to have zero effect in places where a FPS boost is needed. (ie: the first town as an example, I drop into the mid 40's sometimes)

    And the stutter when traveling is a bit annoying too.
    The only tweak that seems to smooth things out and remove almost all stutter is the DisableLoadingMip0="0" in the GamerProfile.xml file and changing it to a 1, but that really degrades texture quality, so I don't consider it a viable tweak.

    I mean if a single R9 290 cannot run the game well at 1920x1080 or 1920x1200, then us AMD users truly are screwed in this title!
    I won't even try this game on my 2560x1440 monitor with just a single R9 290!

    I'd try it on my other rig with a pair of 7950's in x-fire, but AMD has disabled x-fire for this game for now.

    So does anyone care to share what in-game settings and/or tweaks that are working for you in this game for the best / smoothest game-play?

    Oh and B4 someone says the usual...
    1: Yes we all know its a Nvidia Gameworks title
    2: Yes we all know lowering AA helps framerates
    3: Yes we've all already heard the "wait for a patch from UBI" comments

    What I wanna know is has anyone managed to hit a settings "sweet-spot" for the best playable settings NOW on their AMD GPU, and can you share your settings with the rest of us?
     
    Last edited: Nov 26, 2014
  2. mtdew332

    mtdew332 Member Guru

    Messages:
    123
    Likes Received:
    1
    GPU:
    Sapphire R9 390x
    Ok, here is what I have for now and it seems to be playing pretty well for me.

    GamerProfile.xml changes
    Alpha to Coverage - AlphaToCoverage="1" changed to AlphaToCoverage="0"
    FOVScaleFactor=FOVScaleFactor="1.1934" (this is my in-game FOV slider setting value of course)
    DisableLoadingMip0="0" - I will NOT change this, it degrades the textures too much if set to "1", so I leave it at default "0".

    In-game settings

    Aspect Ratio - 16x10
    Display Resolution - 1920x1200
    Refresh Rate - 60
    Window mode - Borderless (so I have no tearing with v-sync disabled)
    V-sync - off

    Triple Buffering - Off
    V-sync mode - Normal
    FOV - about 75% on slider (1.1934 in the GamerProfile.xml file)

    Below is all Ultra preset except for two settings as noted.
    Motion Blur - Off (changed from default Ultra preset)
    Textures - Ultra
    Shadows - Ultra
    Post FX - Ultra
    Geometry - Very High (changed from default Ultra preset)
    Vegetation - Ultra
    Terrain - Ultra
    Water - Ultra
    Enviroment - Ultra
    Ambient Occlusion - SSBC
    Anti-Aliasing - SMAA
    Godrays - Volumetric Fog
    Fur - On
    Trees relief - On

    But it still doesn't seem as smooth as it should be even though my FPS are just fine.
    Any suggestions?
     
    Last edited: Nov 26, 2014
  3. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,150
    Likes Received:
    77
    GPU:
    RX 580 8GB
    It's really not a frame rate issue with Far Cry 3/4. No matter what setting I use, it still spikes 10FPS lower which causes the stutter/lag that makes it appear not smooth. There's nothing you can do right now and I don't expect it to ever get better.
    Some AMD users run these games fine (or don't notice the stutter).
    The only setting that gets rid of general panning stutter is locking FPS below 60, but once in a fast action area like driving or getting shot at, it stutters like crazy. I've even tested locking to 40FPS, it still drops to 30/20 there, it's the games optimization, they haven't done any.
     
  4. mtdew332

    mtdew332 Member Guru

    Messages:
    123
    Likes Received:
    1
    GPU:
    Sapphire R9 390x
    Yeah, I'm actually one of the rare ones that has no stutter in Watch Dogs. (with the right "combo" of settings of course)

    I actually did get Watch Dogs and Far Cry 3 to run really well with the right "settings /combination".

    But its definitely present in this game also and I just cannot seem to eliminate it like I did in Watch Dogs / FC3.
    Was hoping to find that "magical combo" of settings with this game also. ;)


    I already tried a FPS limit of 60 - 50 and even 40...still seems to stutter as you said.
    Its weird, no matter how low you limit the framerate, you're right, it always dips to about 10fps less than you have the limit set at in some spots...now that is "ODD" to say the least!
    Its almost like it's programmed to do that on purpose regardless of your framerate.

    I'm gonna try it with HT off on my cpu and see what happens, this game seems to only be utilizing my four real physical cores anyway.
     
    Last edited: Nov 26, 2014

  5. kimpet

    kimpet Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    Powercolor R9 270X Devil
    Graphic Settings:
    All Ultra Settings SMAA
    Motion Blur Off
    Soft Shadows
    HBAO+
    Enhanced Nvidia Godrays
    Fur On
    Trees Relief On

    Fullscreen
    Vsync Off
    FOV 75%

    Tweaks:
    DisableLoadingMip0="1"
    GPUMaxBufferedFrames="3"
    AlphatoCoverage="1"
    All mouse tweaks in default value im ok with my mouse dont have problem with it.

    Optional:
    DOF Off
    <Post>
    <quality GameDepthOfField="0" CinematicDepthOfField="0" MotionBlur="0" id="ultrahigh" />
    </Post>

    paste between </CustomQuality></RenderProfile> must be check read only may cause crashing after editting some graphic settings or when click save auto saving no harm.

    Optional:
    Sweetfx On


    1366x768Native Resolution also tried with DownSampling @1920x1080

    FPS min: 40 max: 110 avg: 60

    core i3 3210 @3.2ghz
    r9 270x devil ed @1180 1400mhz
    8gb ram ddr3 1600
    1366x768 monitor
    14.11.2 latest beta driver


    played 10hours with minimal hitching thats all. Im OK with it!
     
  6. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,150
    Likes Received:
    77
    GPU:
    RX 580 8GB
    Even If I run the game at 1280x800 it still performs poorer than your system. Shocking.
     
  7. kimpet

    kimpet Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    Powercolor R9 270X Devil
    Try to play it with single card i dont know what is the problem in ur system but it runs smooth on mine the only problem i have is minimal hitching when traveling to other location like 1-3secs then goes back to normal
     
  8. crz

    crz Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 ARMOR 8G
    It seems that the game is more or less geometry bound than fillrate bound. I have played around a bit with various settings in the starting village and surrounding areas and it seems that the Terrain, Environment and Geometry have the biggest impact on the stuttering. With them on low the stuttering is minimal. Once you start to increase them the stuttering becomes more and more pronounced.
     
  9. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,150
    Likes Received:
    77
    GPU:
    RX 580 8GB
    I don't run crossfire on this game.
     
  10. PhantomGamers

    PhantomGamers Active Member

    Messages:
    79
    Likes Received:
    2
    GPU:
    NVIDIA GTX 1080 EVGA FTW
    Even if you had a crossfire setup (I do), the latest AMD drivers disable it in FC4 and if you force it on you get crazy lighting flickering. :(
     

  11. jamek

    jamek Banned

    Messages:
    88
    Likes Received:
    0
    GPU:
    R9 270x Gaming
    The final solution of all those problms of shtuttering is to sale AMD gpu and go for a new GTX 970/980 ....AMD is HOPELESS

    :no: :no: :no:

    :no: :no: :no:
     
    Last edited: Nov 27, 2014
  12. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,150
    Likes Received:
    77
    GPU:
    RX 580 8GB
    I run a single 1920x1200 monitor so only use both cards if needed.

    The game is just badly optimized. They have hardware and drivers to test the game on before releasing, and obviously forgot to.
     
  13. jamek

    jamek Banned

    Messages:
    88
    Likes Received:
    0
    GPU:
    R9 270x Gaming
    you'r right, the game is bad optimized, however, why often there are stuttering with AMD gpus but somehow no or less stuttering with NVIDIA gpus?
     
    Last edited: Nov 27, 2014
  14. mtdew332

    mtdew332 Member Guru

    Messages:
    123
    Likes Received:
    1
    GPU:
    Sapphire R9 390x
    The game plays much better with HT turned off on my 2600k. (ie:less framerate dips)
    I also added -skipintro -disablepagefilecheck to my desktop shortcut target box, not really sure if -disablepagefilecheck did much, but it didn't hurt anything either, so I left it there.

    Now with all my settings as I stated above and these few last tweaks, its playing very well for me.

    I still get a VERY RARE "hitch" once in a great while when traveling fast.
    I'm running a 128gb SSD(for my OS) with 2tb of HDD's (For my games/steam).

    Maybe I'll try FC4 on my SSD then and see if I can eliminate those rare loading hitches also, but for now, I'm happy with it.

    But please keep sharing any tweaks that work, so we can all try them.
     
  15. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,150
    Likes Received:
    77
    GPU:
    RX 580 8GB
    They trade blows.
     

  16. SpdyRobi

    SpdyRobi Active Member

    Messages:
    93
    Likes Received:
    0
    GPU:
    GTX 1070 SLI
    What I did was overwrite the Far cry 4 profile using the BF4 profile
     
  17. shadow_craft

    shadow_craft Member Guru

    Messages:
    189
    Likes Received:
    0
    GPU:
    ASUS StiX OC 1070
    Nvidia is having the same issue with stuttering, check out TotalBiscuit's port review, he has sli 980's and have to turn off mipmaps to make it playable.

    You are just being a troll
     
  18. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,150
    Likes Received:
    77
    GPU:
    RX 580 8GB
    Doing that has absolutely no effect here.
     
  19. angmar

    angmar Maha Guru

    Messages:
    1,193
    Likes Received:
    0
    GPU:
    RTX 2080TI Founders
    I'm having frame rate issues with the game as well...bad enough that I just couldn't get past the first 2 hours....was running choppy.
     
  20. jamek

    jamek Banned

    Messages:
    88
    Likes Received:
    0
    GPU:
    R9 270x Gaming
    Who Talks about Sli? do you forget Big stutters with Far Cry 3 ? AMD it self has admitted that. READ THIS:

    Smoothness Issues

    We would rate Far Cry 4's smoothness overall below average due to the fact that there is a consistent stuttering on AMD GPUs currently. We tested AMD R9 290X and R9 290 with the latest 14.11.2 Beta driver and experienced an odd consistent stutter as you play the game. It is annoying and distracts from the gameplay experience. The stutter is not present on GTX 970 or GTX 980.

    This is also unacceptable for a high profile and highly expected game. Once again, AMD gaming base is getting a machete to the knee in this game. Perhaps future patches or drivers will fix this stuttering. We did not have time yet to pin it down to any specific quality setting, but we will see if anyone setting can be attributed to the stuttering in our full evaluation. Perhaps future game patches and or drivers will fix this. Right now, the smoothest gameplay is on GTX 970 and 980.

    source: http://www.hardocp.com/article/2014/11/21/far_cry_4_video_card_performance_iq_preview/3
     

Share This Page