Far Cry 3 massive micro stutter when under 60 frames?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by NudeDragon, Dec 6, 2012.

  1. NudeDragon

    NudeDragon Active Member

    Messages:
    92
    Likes Received:
    0
    GPU:
    Gigabyte GTX 680 WF x3
    Hi anyone else have an issue with FC3 running terribly when it's under 60 frames? It's as if the game is skipping and you need to have it at 60 to keep it smooth.
     
  2. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,644
    Likes Received:
    1,538
    GPU:
    MSI 3080 Gaming X
    I suppose you are using Vsync? Maybe it the double buffering which causes your game to drop down to 30fps when under 60fps. You could try D3DOverrider and triple buffering to bypass this problem?
     
  3. NudeDragon

    NudeDragon Active Member

    Messages:
    92
    Likes Received:
    0
    GPU:
    Gigabyte GTX 680 WF x3
    Yes I am using V-Sync but my problem isn't the game dropping down to 30 frames.

    If it goes below 60 whether it's 55 or 50, anything under 60 the game runs awful like. Micro stutter everywhere. Even if I turn off V-Sync it's the same thing.
     
  4. nick0323

    nick0323 Master Guru

    Messages:
    988
    Likes Received:
    45
    GPU:
    Palit GTX970 Jetstream OC
    Someone else mentioned this with VSYNC, have you tried adaptive VSYNC?
     

  5. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,644
    Likes Received:
    1,538
    GPU:
    MSI 3080 Gaming X
    What ingame settings are you using including resolution?

    I'm using 1920x1200, 2xMSAA, High, Vsync enabled, DX11 and have no slowdowns like you mention. I remember having pretty smooth 60fps all the time but can double check this with MSI AB.

    If I try using Very High or Ultra my FPS goes down to 42 on some occasions and average around 50 which for me is not very playable.
     
  6. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    755
    Likes Received:
    7
    GPU:
    Geforce GTX 970 @1420
    I get microstuttering at 60fps unless I use D3DOverrider, have you tried that?
     
  7. Jakshi

    Jakshi Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    PoV GTX680@1300/3700
    It seems nobody here has a f***ing clue what he is talking about. I have the same issues like op so I know. The game has two vsync options from the get go, one double and one triple buffered. With my GTX680 OCed to 1300 core I get 60fps most of the time but when fps drop, not by much, minimum I get is 55fps, the game stutters a lot more while triple buffered+vsync than other games.
    I noticed more and more games have vsync stutter because the frametimes are wrong. Darksiders 2 had this issue which could be solved by D3D Antilag which tells the GPU to use fixed frametimes and ignore the frametimes given by the game engine. Too bad this little app is DX9 only, I already started a request but the developer ignored it due to low support by others requesting.
    Other games with vsync engine stutter are Metro 2033, Hitman Absolution and Sleeping Dogs. Sleeping dogs can be fixed by using a frame limiter and setting it to 60fps but when fps drop below this mark, again not by much, minimum 56fps, the games stutters the same like Far Cry 3 does.
    For Far Cry 3 theres no solution atm, the only thing that helps is to set max prerendered frames to 1, ingame option, which does reduce the input lagg alot which helps to ignore the issue a bit but you'll loose about 2-6 avg fps.

    Edit: I'm aware of D3DOverrider and it's ability to solve similar problems, but it'll only help when the vsync option itself is poorly implemented within a game, which is not the case in Far Cry 3.
     
    Last edited: Dec 6, 2012
  8. Iruwen

    Iruwen Master Guru

    Messages:
    307
    Likes Received:
    0
    GPU:
    EVGA GTX 670 FTW
    The stuttering can sometimes be fixed by setting the limiter to 59FPS for whatever reason, somebody explained why some time go, works for BF3 for example.
     
  9. Jakshi

    Jakshi Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    PoV GTX680@1300/3700
    This will only work satisfactorily when not using vsync because 59fps+Vsync = massive micrustutter due to the very nature of vsync to stutter when not perfectly synced to monitor refresh.
    It could work without vsync but that's, for me, not an option.
     
  10. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    755
    Likes Received:
    7
    GPU:
    Geforce GTX 970 @1420
    It was the only thing that worked for me in Far Cry 3 to get rid of the stuttering. YMMV, but it's always worth a try.
     

  11. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb
    I don't have far cry 3 yet, but I have the problem you are describing with a lot of other games with my GTX 670, when it drops below 60, it doesn't just look like normal low framerate; it looks like its skipping frames;

    check this thread:

    https://forums.geforce.com/default/...posts-will-be-deleted-vsync-stutter-discussi/
     
  12. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb
    This is an excellent post. I have the same experience in a lot of the games you listed with my GTX 670 4gb. I wish someone would inform the proper authorities of what has been happening in so many games so that we don't have to keep using all kinds of 3rd party apps to make the game run smooth. Do you think the frametimes mismatch can be corrected through drivers?
     
  13. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,369
    Likes Received:
    761
    GPU:
    6800XT Nitro+ SE
    Ive given up with trying to get this game to run properly on my 2x 7970's in crossfire. The looks terrible with some decent lighting effects. It looks like far cry 1 with AO enabled. Even with 1 7970 with everything maxed out, gpu buffer off, vsync off, 8xaa, alpha enhanced, ssao, everything on ultra I pull in around 26-55fps and the game STILL stutters everywhere. Even turning down AA from 8 to 4 makes the min fps jump up to around 33fps. If I turn everything on low, turn off aa, turn everything to the lowest possible settings I still get a little stutter but its more or less gone and the game runs at 150+fps. This game seriously seriously needs some optimizing for the PC! I have since given up and purchased it for my PS3 and whilst it does look pretty bad at least its playable!!!
     
  14. Jakshi

    Jakshi Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    PoV GTX680@1300/3700
    The issue mentioned in this thread occurs with steady fps. SO lets say you have always 60fps and active vsync you will get stutter. This was caused by some polling problems which probably caused latency in gpu buffer due to the new boost technology being used by GTX600 series. But for me the mentioned games have unusually varying frametimes with anything lower than the monitors refresh in FPS when using vsync. Causing microstutter much more evident than other games.

    @NeoandGeo: Maybe my statement was misleading, I did test D3DOverrider with Far Cry 3, hence my global setting is HIGH detection for all 3d apps because I can't stand tearing.

    The problem here lies within the engine and I guess in Far Crys case the max gpu buffer implementation is to blame. The input lag is far too high with vsync and frames to buffer to OFF to be really controlled by the gpu driver. I tried ingame buffer OFF and all possible choices for frames to buffer within the driver menu and it didn't make any difference. In other games you really can feel the difference between the default setting(3 frames to buffer) and the 1 frame setting, which is really much better regarding lag.

    Edit:
    I think that is what the new options from RadeonPro are doing.
    Quote from Mr.Johns changelog for the new Radeonpro version:
    - New: Dynamic Framerate Control (DFC) support. This feature acts like a frame rate limiter with smoothness control, just set a frame rate target and RadeonPro will try to keep it as close as possible while maintaining frame rendering times close to each other to avoid stuttering.

    So I guess this could be also done via Driver. And as I already mentioned D3DAntilag will also correct frametimes, it's a shame this works only for DX9 as it will also reduce inputlag while correcting frametimes with no evident fps loss like the 1frame setting from nVidia
     
    Last edited: Dec 6, 2012
  15. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb

    so, the ultimate solution would be for nvidia to bring back "set prerendered frames to 0" option in the drivers?
     

  16. SLI-756

    SLI-756 Banned

    Messages:
    7,604
    Likes Received:
    0
    GPU:
    760 SLI 4gb 1215/ 6800
    set the frame limiter from the config, then enable full v sync so you don't get tearing.(mine's @60)
    much smoother now, the lowest i can take the in-game pre-rendered frames is 1, when i was running game previously with some settings disabled i could manage 0, but now with some of these ultra presets.

    edit : i'm back to pre-render 0 & postfx low. :)
     
    Last edited: Dec 6, 2012
  17. Jakshi

    Jakshi Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    PoV GTX680@1300/3700
    Maybe, but I can't guarantee it. The 680 is my first Nvidia card after the 8800ultra. I had only AMD cards since then and I think there's no GTX600 series driver with the ability to set frames to 0, which is now equal to default setting. If there is pls give me a link I would love to test it myself.
     
  18. Iruwen

    Iruwen Master Guru

    Messages:
    307
    Likes Received:
    0
    GPU:
    EVGA GTX 670 FTW
    No. That's what you'd expect, yes, but it's not what's actually happening. Only works combined with triple buffering though.
     
  19. Jakshi

    Jakshi Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    PoV GTX680@1300/3700
    In what game is this working? If the game has controller support: plug it in and try to pan the camera around without moving with the analog sticks, if not set the camera to the arrow keys of your keyboard. These are the only options to have a 100% steady moving camera, now watch the frames, do they have the same frequency or is it stuttering? Best place to test would be with varying geometry like in Far Cry the trees or houses.
     
  20. valentyn0

    valentyn0 Member Guru

    Messages:
    132
    Likes Received:
    11
    GPU:
    GTX1080Ti Aorus Ext
    If you disable postFX u will get much better framerate, IQ + aliasing is barely noticeable. ( > Click here )
     
    Last edited: Dec 6, 2012

Share This Page