Fallout 4 Performance Thread

Discussion in 'Videocards - AMD Radeon Drivers Section' started by RexOmnipotentus, Nov 9, 2015.

  1. Undying

    Undying Ancient Guru

    Messages:
    16,667
    Likes Received:
    5,571
    GPU:
    Aorus RX580 XTR 8GB
    Hehe, take a guess. :p
     
  2. niczerus

    niczerus Master Guru

    Messages:
    290
    Likes Received:
    3
    GPU:
    MSI GamingX 580 4GB
    installed and not fixed :/ , and have a problem the fps lock in some areas to 50 or 40 fps(high settings 1080p or low settings 720p have the same fps xD )
     
  3. TheBomb

    TheBomb New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Gigabyte 7950 3GB
    This game is super weird, not sure if it's bethesda or amd fault.

    I got 2x r9 290x (only using one) and my monitor is a QNIX oc'ed at 110hz and yet I'm locked at 55hz when using Fallout 4 v-sync. If I disable the v-sync the screen tearing is off the chart even though I remain below 110fps.

    Activating v-sync through amd crimson or radeon mod doesn't do anything in fallout 4.

    I'm not sure if I'm doing something wrong but I was expecting to reach atleast 60fps or more without screen tear.
     
  4. gx-x

    gx-x Ancient Guru

    Messages:
    1,507
    Likes Received:
    156
    GPU:
    1070Ti Phoenix
    screen tearing happens when output frames from graphics card are not in sync with monitor refresh rate, it can happen at low fps or at high fps, it doesn't matter. V-sync (or newer methods) correct that problem by halting the output to match the refresh rate of input (monitor). V-sync usually has steps at which it works. For instance, if GPU can't keep up with 60Hz (60 fps) V-Sync will tell it to halve the rendering to 30 fps, if it can't do 30 fps, than another halving occurs and 15fps is attempted etc.
    Going from your 110Hz, half is 55Hz, you can't get 60 fps with V-Sync on your monitor at that refresh rate. You could try and use triple buffering (easiest way to do this is to play the game in borderless windowed mode, keep V-Sync on of course) then the stepping down of FPS is less radical, it's not halving the fps but rather doing something like a quarter less than max refresh if it can't keep up (60>45>30 instead of classic 60>30).
    Fallout 4 has physics and animations based around framerate and it's supposed to stay locked at 60fps as a maximum. If you unlock it, game will play faster when it has more than 60 fps, and slower if it has less.
    Anyway, 55fps is fine, I don't see an issue, it's not that far off of 60, if you disable FPS overlay you will not care for it.
     

  5. IAmGhostDog

    IAmGhostDog Maha Guru

    Messages:
    1,128
    Likes Received:
    7
    GPU:
    XFX R9 390
  6. Barry J

    Barry J Ancient Guru

    Messages:
    2,793
    Likes Received:
    133
    GPU:
    RTX2080 TRIO Super
    Loving the game what are the best mods (I would like to improve the graphics) I don't mind if there is a performance hit playing above 100fps on 60hz TV
     
  7. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    For your 980ti SLI?

    Forget the 100fps goal on your 60hz TV, stick with vanilla 60 fps limit.

    Enable 4K DSR and choose FXAA in-game.

    Shadowboost and enb sweetfx, lowered weapon mod too.

    And this one too:

    http://www.nexusmods.com/fallout4/mods/102/?
     
  8. gx-x

    gx-x Ancient Guru

    Messages:
    1,507
    Likes Received:
    156
    GPU:
    1070Ti Phoenix
    for people that don't know this: holding "R" (reload) holsters your weapon and you move faster. Presing "R" again (or using an attack) will draw weapon out again.
     
  9. heroxoot

    heroxoot Master Guru

    Messages:
    442
    Likes Received:
    0
    GPU:
    EVGA 1080ti SC2
    So I applied the shadow fix. I put the .ini and the rest in the root folder for FO4. I noticed performance is better inside places and in some areas more than others. But for the most part I still get 40 - 50 fps traveling the commonwelth. Is there something more to do? I'm playing on Ultra, AA off, 3800x1800 VSR. The game runs the same on straight 1080p, I just do VSR to push my GPU to load.
     
  10. flow

    flow Maha Guru

    Messages:
    1,011
    Likes Received:
    14
    GPU:
    Asus TUF RTX3080 oc
    I guess 3800x1800 is just a little too much for one card without reducing some ultra settings.
    Although I agree that the game runs about the same for me with 1080p and 1440p vsr.
    Haven't tried higher res though. Will give 3200x1800 a whirl today.
     

  11. heroxoot

    heroxoot Master Guru

    Messages:
    442
    Likes Received:
    0
    GPU:
    EVGA 1080ti SC2
    Thing is it plays all the same @ 1080p but it's not giving the GPU much load. I will try something like 2560x1920 I think is the next one below 3800x1800. This is purely to push my GPU to load. Otherwise I see like, 40-50% load.
     
  12. gx-x

    gx-x Ancient Guru

    Messages:
    1,507
    Likes Received:
    156
    GPU:
    1070Ti Phoenix
    for me it doesn't. when I do 1440p I get like 30% less fps, though, tbh, I tried it when it came out, without any optimizations, everything on ultra etc. I am curious to try it now but...places like satellite stations exteriors etc lower fps quite a bit.
     
  13. gx-x

    gx-x Ancient Guru

    Messages:
    1,507
    Likes Received:
    156
    GPU:
    1070Ti Phoenix
    hey, can someone help me, I cant get VSR to work properly :/ I am using Fallout 4 tweeker Launcher, I set 2560x1440, set it to full-screen, no windowed and stuff it launches but my game gets shrieked and instead of stretched I just get black space, tho, ENB info is stretched properly?! wtf... I remember that it did work with zero mods and original stuff, I tried setting resolution in the launcher but same thing...

    confused...
     
  14. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    I had this problem with previous driver a temp workaround is to set desktop res at the same vsr res than you will use in game.
     
  15. Barry J

    Barry J Ancient Guru

    Messages:
    2,793
    Likes Received:
    133
    GPU:
    RTX2080 TRIO Super
    Thank you really good advice
     

  16. gx-x

    gx-x Ancient Guru

    Messages:
    1,507
    Likes Received:
    156
    GPU:
    1070Ti Phoenix
    I will try that :) Anyway, I am on last catalyst betas, not crimsons. I was on those when VSR worked correctly. I don't think it has anything to do with drivers, it's probably the ENB...
     
  17. heroxoot

    heroxoot Master Guru

    Messages:
    442
    Likes Received:
    0
    GPU:
    EVGA 1080ti SC2
    Is VSR enabled in your driver? It has a habit of resetting to default sometimes when you close crimson or reboot. Does it to me all the time and I just wanna slap AMD's GPU driver team.

    Also change res in the default FO4 launcher not the tweaker.
     
  18. gx-x

    gx-x Ancient Guru

    Messages:
    1,507
    Likes Received:
    156
    GPU:
    1070Ti Phoenix
    yea it's enabled, it works, it's just that in fallout it doesn't render the game in 2560x1440, it renders it in 1080p and than puts that in top left corner, the remaining space of the (2560x1440) is filled with black and I have time (you can enable system time to show in ENB overlay) in the upper right corner and it's smaller font etc compared to 1080p, so it works (VSR) but it just does not affect the game world. Like I said, it's probably due to ENB. I don't have time to fiddle with it atm, I will try it later and report.

    PS. Again. I am not using Crimson driver. I am using last catalyst beta.

    "Also change res in the default FO4 launcher not the tweaker. "

    That's the first thing I tried, no change.

    edit: here's how it looks like:
    http://imgur.com/HDPwx4A
    I disabled ENB but it didn't help. Weird because it used to work. Must be because of some changes done to all the ini files by tweaks and stuff...Oh well...
     
    Last edited: Dec 31, 2015
  19. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    This pix show VSR 1800p when it was "bugged" in my 1080p monitor:

    [​IMG]

    The posted workaround fixed it and a new driver and reinstall solved it.
     
  20. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    that preempts the dlls with older ones.

    you will lose any performance enhancements from subsequent drivers.

    not acceptable.
     

Share This Page