1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fallout 4 Performance Thread

Discussion in 'Videocards - AMD Radeon Drivers Section' started by RexOmnipotentus, Nov 9, 2015.

  1. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    I just fixed the brightness issue of AFR friendly mode. It turns out that bloom is increased alot if you enable AFR friendly mode. I fixed this with some console commands.

    -> Download this .txt file (contains the commands): http://s000.tinyupload.com/?file_id=01177407222545874676
    -> Put the file in the fallout4.exe folder
    -> Start the game
    -> open the console
    -> typ "bat 1" AFTER you loaded a savegame for the first time. This is very important, because if you do it before, your screen gets black once your savegame is loaded (restart is the only fix). Once you loaded a savegame for the first time, it doesn't matter if you load another savegame. You can even go back to the main menu and load a savegame from there.

    Once you close the game, all values will switch back to 'normal'. This means that you need to reapply the console commands everytime you start the game.

    I haven't played the game alot with this fix. So it there might be some problems. Ambient occlusion is still bugged (maybe it can also be fixed by console commands), but if it bugs you to much, you can simply disable it. Don't use TAA, FXAA is fine, but TAA doesn't work correctly.

    I hope this helps. I'm just going to test this some more.

    If you want you can tweak the console commands in the 1.txt file yourself. There are 9 values in the 1.txt file. Some values don't seem to do anything. They have no impact on the games visuals (or maybe they have in situations i haven't encountered yet).

    Value 1 doesn't seem to do anything. Setting this value to high will result in a black screen. Restart of the game is required.

    Value 2 and 3 also don't seem to do anything. Setting value 3 to 0 will result in a white screen.

    Value 4 did had an effect on a light bulb. Not sure what it is.

    Value 5 is light reflection strength. Setting it higher than 1 will make the reflection to strong.

    Value 6 seems to be HDR

    Changing value 7 didn't do anything for the visuals.

    Value 8 is definitely bloom. Like i said before, this is what caused the game to become extremely white/bright.

    Value 9 also has a huge impact on the visuals. I don't know what it does, but setting this to low will make trees white. I don't know what value fallout 4 is using, but i set it to 2. I know for sure the game normally uses a lower value.

    Even if you don't use CrossFire. You can use the console commands to change it. I made the 1.txt in AFR Friendly mode. So using it for single GPU's could negatively impact the visuals.
     
    Last edited: Nov 19, 2015
  2. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    Some comparison shots

    No console commands
    [​IMG]

    With console commands
    [​IMG]

    No console commands
    [​IMG]

    With console commands
    [​IMG]

    No console commands
    [​IMG]

    With console commands
    [​IMG]

    Im running the game in 4K by the way. I hope AFR friendly mode isn't causing to much problems while playing. I will report back as soon as i find something.
     
    Last edited: Nov 19, 2015
  3. Turanis

    Turanis Maha Guru

    Messages:
    1,422
    Likes Received:
    155
    GPU:
    Gigabyte RX500
    Imo Windows 7/8.1 run better Fallout 4 than Windows 10 TH2.In win10 the game is loading much slower,even with newer drivers.
    In Win10 i have CTD after multiple loadings (F9).
    No stutter or lag in win7/8.1.Is just my opinion,maybe other guys dont think that. :)
     
    Last edited: Nov 19, 2015
  4. fr33jack

    fr33jack Maha Guru

    Messages:
    1,153
    Likes Received:
    3
    GPU:
    1050Ti @1.9/ 9.0GHz
    Yeah. I remember how AMDMatt was so excited about telling us how W10 would be so much awesome with AMD GPU's and CPU's..."just you wait!" he was telling us :D ...figures.
     

  5. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,071
    Likes Received:
    49
    GPU:
    RX 580 8GB
    I don't have stutters with TH2. I see FPS drops though in heavy drawcall areas.

    https://www.youtube.com/watch?v=lYoY32Ezp7M
     
  6. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    You will see some flickering bodies in AFR friendly mode (very noticable). Didn't have any other issues so far. Playing at 4k with a stable 59FPS (locked it to 59FPS because of FreeSync) and the game looks much better now without all the brightness gone. Of course i had to set shadow distance to medium, because of the cpu bottleneck. God rays are set to low. Everything else is maxed out.

    If someone gives my console commands a try, please let me no if it worked for you or not. ;)
     
    Last edited: Nov 19, 2015
  7. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,004
    Likes Received:
    137
    GPU:
    Sapphire 7970 Quadrobake
    It's probably my RAM then, or the CPU memory controller. I can't even boot at 1866 with the same timings.

    That's unexpected actually.

    They probably have written a new pipeline for the thing and integrated tessellation settings in there.
     
  8. Ryu5uzaku

    Ryu5uzaku Ancient Guru

    Messages:
    6,770
    Likes Received:
    107
    GPU:
    5700 XT UV 1950~
    Unexpected for sure. That is why I actually said anything at all. I wasn't expecting that at all. I still wish bethesda would ditch their horrid thing of an engine for the next what ever game they will make.

    @RexOmnipotentus

    Your comparison shots made the game look way better.
     
  9. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    I really like the look i created with the console command. It's way better than the normal settings. Even without CrossFire the game is just to bright. Everything shines and glows. It's way to much :p
     
    Last edited: Nov 19, 2015
  10. mehdi

    mehdi Maha Guru

    Messages:
    1,283
    Likes Received:
    0
    GPU:
    XFX 5970
    whats settings are you using at 4K with 2 290x?

    Im running the game in 4K by the way. I hope AFR friendly mode isn't causing to much problems while playing. I will report back as soon as i find something.[/QUOTE]
     

  11. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    I don't have the x version, just two r9 290. Mostly everthing is maxed out. Shadow distance is set to medium, because of the cpu bottleneck in some places. Godrays is set to low. In CCC i have set tesselation to 8x. That's it.

    So far AFR-friendly mode is working great. You will have some flickering here and there and every now and then you might see something strange, but it's nothing serious. Of course it's always better to have a really CrossFire profile without any problems, but AFR friendly mode enables me to play this game at 4K and everything just looks better. The bugged AO (looks very pixelated sometimes) doesn't bug me at all.

    One of the strange things i saw was right at the beginning of the game. You can select a male or a female character. I didn't go for the female character, so i don't know how she looks in the rest of the game, but her face will become black in ARF-friendly mode. All the other NPC i've met so far don't have this problem. Their faces looked fine.
     
    Last edited: Nov 19, 2015
  12. mehdi

    mehdi Maha Guru

    Messages:
    1,283
    Likes Received:
    0
    GPU:
    XFX 5970
    thank you
     
  13. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    It's not working fine here, there is some sort of CFX but i think is better to aply the AMD usual solution: disable it.

    :(

    I tried AFR and tes at 16 (maybe 8 improve it?) the FPS have improved but the flickering is very evident almost all tree around flicker constantly.

    The GPU scaling is horrendous 52/12 or 20/40, i never see it stay at more than 50/50 so the CFX is no giving any better than a single GPU working at max (if this was possible in this game right now).
     
  14. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    Wait what? I'm getting a steady 59 FPS in most areas. Maximum scaling with AFR friendly is 100/100 unless there is a cpu bottleneck. It gives me double the FPS. I played the game for a couple of hours with AFR friendly mode enabled and not once i saw a tree flicker. You did disable TAA right? If you leave that on the game will become bright everytime you move and becomes dark again if you stop. Very annoying and not pretty at all. It will also give you a huge performance hit. TAA is an absolute NO GO with CrossFire enabled. It simply doesn't work.
     
    Last edited: Nov 19, 2015
  15. Sharoth

    Sharoth Master Guru

    Messages:
    722
    Likes Received:
    3
    GPU:
    Aorus RTX 2080 OC
    Works fine for me with the exception of the flickering.. Real apparent in the Perk Tree... I have since gone back to single gpu..
     

  16. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    I have FXAA set.

    I reloaded the game this time i closed the 2 hundred palemoon tabs i had left open before.

    :D

    Maybe this has changed something, i don't see the flickering now but the day time has changed and it's not night at this moment, the scaling is still horrendous.

    Maybe darker nights mod has something to do with this, i will try vanilla game.

    I see a brief moment over 50/50.
     
  17. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    Nvidia God rays (=ultra godrays) are disabled? I don't know if that has an negative impact on.
     
  18. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    God rays disabled.

    I don't exepct any better until a game patch (or a few ones).
     
  19. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    nothing changed. I did enable FXAA (didn't use it before) and enabled nvidia godrays and still 100/100 scaling. No flickering trees. Are the completely flickering or just some part of it?
     
  20. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    All of them, i guess is something with mods.

    I will try vanilla tommorow with tes at 8.

    Now i must get ready for my night shift.

    :)
     

Share This Page