Fallout 3 Vegas - Performance Hot Tweak!

Discussion in 'Games, Gaming & Game-demos' started by PirateNeilsouth, Oct 20, 2010.

  1. Phroster

    Phroster Master Guru

    Messages:
    285
    Likes Received:
    4
    GPU:
    Asus Strix 980 Ti
    Frame skipping is fixed with editing the FalloutPrefs.ini in my docs.

    Change iFPSClamp=0 to your own refresh rate.

    So something like iFPSClamp=60

    Also the game is broken in Win 7, when i play it in WinXP i get 60 frames almost anywhere.
    I use a dual boot for this.

    Remember that this is just the old oblivion engine.
     
    Last edited: Oct 21, 2010
  2. PirateNeilsouth

    PirateNeilsouth Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    980 OC
    Read my thread before repeating what i already said :)

    http://forums.steampowered.com/forums/showthread.php?t=1525127

    Even posted it on guru/fallout and nvidia forums
     
  3. Phroster

    Phroster Master Guru

    Messages:
    285
    Likes Received:
    4
    GPU:
    Asus Strix 980 Ti
    Where did i miss the part that i mentioned? Btw this is usefull information, i have no problems on windows xp x64 dual boot :)

    And also this frame skipping bug and bad performance with this engine has never been fixed.

    Just tried the .dll, it almost compares to the same performance on windows xp x64.

    Windows XP i just a little faster with this game.
     
    Last edited: Oct 21, 2010
  4. PirateNeilsouth

    PirateNeilsouth Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    980 OC
    Yes once or twice but people have been repeating it for the last what 3 years and there is a flaw with this as i've been repeating that too.

    Ifpsclamp is not a permanent solution but a temporary one

    I know people are trying to help and mean well
     

  5. Phroster

    Phroster Master Guru

    Messages:
    285
    Likes Received:
    4
    GPU:
    Asus Strix 980 Ti
    Well there is one very simple solution, play it on Windows XP.

    This probably also explains the bad compatibility with DX10/11 cards.
     
    Last edited: Oct 21, 2010
  6. PirateNeilsouth

    PirateNeilsouth Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    980 OC
    Again read my thread :bang:

     
  7. jasonmvt

    jasonmvt Active Member

    Messages:
    99
    Likes Received:
    0
    GPU:
    RTX 2080Ti
    I just wanted to say that this d3d9.dll fix, while I'm sure the added performance is welcome to many, does come with a cost. There are definitely visual compromises using this. Mainly for those who are saying they are running on ultra and think they're still getting the highest visual quality, smooth frames, and no sacrifices.

    I wanted to check it out just to see, and it was immediately obvious that the HDR lighting isn't working right, at least, despite being turned on. I'm sure it doesn't matter if you're fighting just to play the game at an acceptable rate, but it's definitely not the full "ultra" regardless of what the settings say, which could explain some of the performance gains. Removing the .dll immediately restores the better lighting.

    Again, not trying to bash this fix, just wanted to put that out there.
     
  8. crushilista

    crushilista Ancient Guru

    Messages:
    3,471
    Likes Received:
    0
    GPU:
    MSI GTX 670
    THANK YOU SO MUCH! I get straight sixty now from 18-30 FPS! WHOOHOO!
     
  9. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,562
    Likes Received:
    1,613
    GPU:
    ROG Strix 1080 OC
    Is this game only DX9 ?
     
  10. Phroster

    Phroster Master Guru

    Messages:
    285
    Likes Received:
    4
    GPU:
    Asus Strix 980 Ti
    The .dll also turns off AA.

    Just play it on Windows XP if you can.
     

  11. crushilista

    crushilista Ancient Guru

    Messages:
    3,471
    Likes Received:
    0
    GPU:
    MSI GTX 670
    I still have AA.
     
  12. cowgawd7

    cowgawd7 Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    Diamond 5850 1GB
    thanks for this fixed my lagg problem near npcs
     
  13. IcE

    IcE Don Snow Staff Member

    Messages:
    10,693
    Likes Received:
    73
    GPU:
    Zotac GTX 1070 Mini
    This helped me immensely, the game is actually playable near NPC's now. That and turning off HDR fixed most of the game problems. It's at least playable until the patch.

    Actually, I tested something. If you use the DirectX Redist included with the game and install it, it has the same affect as using the file except you don't lose any graphical quality.
     
    Last edited: Oct 21, 2010
  14. GXice

    GXice Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Gigabyte 460 GTX 1GB
    Incorrect, AA is still working fine or me. :)
     
  15. DualCORE1

    DualCORE1 Master Guru

    Messages:
    682
    Likes Received:
    0
    GPU:
    XFX 295x2
    thanks for tweak guide will deffntly try it when i get fallout vegas hopefully get it tommrrow was hoping id get it today so i could play it midnight when it unlocks on steam
     

  16. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,487
    Likes Received:
    844
    GPU:
    6800XT Nitro+ SE
    This game automatically install its own DX files, so yes.
     
  17. isidore

    isidore Ancient Guru

    Messages:
    6,276
    Likes Received:
    58
    GPU:
    RTX 2080TI GamingOC
    first patch released..
    Only a day after Fallout: New Vegas's release, the first patch has arrived. The PC version now has an automatic update that can be downloaded through Steam.

    The patch is said to fix "quest and scripting issues."

    guess next one will fix the dx10/11 bug..
     
  18. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,487
    Likes Received:
    844
    GPU:
    6800XT Nitro+ SE
    Great I shall try this, I am sure I installed the DX version the game came with but I will reinstall it.

    I also noticed that the game installs an older visual studios 2008 version. But I uninstalled this because I have a newer one already installed... hmmmmm I might reinstall that too and see if it has better compatibility with the version the game comes with.

    Thanks.

    EDIT:

    Updated DX from the Redist in the game folder and reinstalled the VS 2008 the game came with as well. Performance is a little smoother. But when there are a lot of NPC's on screen the fps still drops to around 30fps.

    Anyone know how to lock the fps at 30 using the ifpsclamp tweak but stop the game from either running in slowmo or in fast forward? If we can get cap the fps at 30 then it should technically be the best fix possible for the time being.

    Thanks.

    EDIT:

    Just tried the D3D9.dll file posted by the OP and yes it detected new hardware but it does not show it as a 7800GS it still shows my actual GTX480 when I set my setting back to what they were...

    EDIT:

    Nevermind, got it to work now. It now detects my card as a 7800GS, also setting iFPSClamp to 60 in all three config files locks my fps at 60 and it says there consistently! :) Very happy bunny here! :banana:

    One word of warning though... I HATE SCORPIONS!!!! :bang::bang:
     
    Last edited: Oct 22, 2010
  19. JohnDow79

    JohnDow79 New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    gtx 285
    This doesnt fix the frameskipping

    this engine is ****
     
  20. Kaleid

    Kaleid Ancient Guru

    Messages:
    2,578
    Likes Received:
    217
    GPU:
    MSI 5700 8GB
    It doesn't work correctly...not everything is rendered as it should with this dll

    Example:
    http://yfrog.com/5xscreenshot4ydj

    Shouldn't contain any spoilers.
    I'm going back to regular drivers provided by the game.

    Edit:

    Seems I was wrong. It looks just as bad with the normal .dll
     
    Last edited: Oct 23, 2010

Share This Page