Fable 3 pc horrid performance

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by SwiftDragon, May 23, 2011.

  1. Maximus7724

    Maximus7724 Master Guru

    Messages:
    449
    Likes Received:
    0
    GPU:
    AMD 7950 PCS+ @ 1150/1500
    Fixed
     
  2. SwiftDragon

    SwiftDragon Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    HOF gtx980ti
    Nah not fixed at all, anyway uninstalled that crud game and have been playing the witcher 2.

    Just so damn awesome, molyneux should go back to game design school.
     
  3. Zool

    Zool Active Member

    Messages:
    51
    Likes Received:
    0
    GPU:
    Geforce 6600 GT
    Having similar problems (ignore specs on the left - I haven't updated them, it's been a long time since I posted here!).

    Running a 460GT on an I5 (I can run the witcher on high/very high with no issues)...

    It's not happening all the time or at a specific place - The game will be running at 60-80 fps (or around 40-50) in town, then suddenly drop to 20-30 fps - but it's not even a smooth 20-30 but it's like a slow motion movie with lots of blur...

    I've tried all the stuff you can find on the steam/Lionhead forums including:
    - vsync on/off/forced through nvida panel.
    - lowered all types of details one by one (I've actually put all the settings to minimum, my fps went up to 120-150 but I still get the same thing eventually and it drops to 20-30)!
    - disabled steam overlay/windows themes.
    - disabled second monitor.
    - run the game in a window.

    None of this works... The crazy thing is that I can "fix it" simply by Alt tabbing out and straight back in, at least for a while... I'm wondering if it's something to do with the game window "losing focus".

    I get a similar effet in Rift (I play in a windowed mode full screen as I have 2 monitors) when I click outside of the game window into Chrome (for example), but it always goes back to normal when I click back into the game...

    It's really annoying and the really frustrating thing is the complete lack of comms from Lionhead on the forums - Especially when you compare it with the Witcher 2, who even with all the problems people have, are out there busting a gut and trying to keep people informed (and they don't even have the forums working...).

    Shame really as I am enjoying the game and it's quirky style and jokes... I'll keep playing and using the Alt-tab method to "fix" this but it's far from being a fun experience...
     
  4. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,049
    Likes Received:
    569
    GPU:
    EVGA GTX 1080 Ti SC2
    You don't have to Alt-Tab out of the game to fix the framerate drops, Zool, pressing START on the controller or Esc twice will do trick too.
     

  5. GenClaymore

    GenClaymore Ancient Guru

    Messages:
    6,070
    Likes Received:
    52
    GPU:
    XFX 5700 XT Thic II
    Actually There are Other controllers which came out some time ago which uses Xinput which what the Games for windows based game uses for gamepad support.

    Logitech F series, Certain Saitek and that latest Razer gamepad controller all are Xinput controllers. Only with the Logitech F series having a switch for Dinput from Xinput on the controller it self.

    I use a Logitech F710 wireless which is one of the controllers which is Xinput with a switch on the rear for switching to Dinput mode for correct button maping for older games
     
  6. HaZe303

    HaZe303 Ancient Guru

    Messages:
    1,944
    Likes Received:
    0
    GPU:
    RTX 2070 Super
    I have no issues with performance in game, ok I have two 570´s in SLI, but still both gpu´s are @50% so even with one card I should be able play the game with minimal framedrops.
     
  7. madmanmarz

    madmanmarz Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    2900 pro @ up to 900/1000
    Note: I'm on a 6850 with 11.5 hotfix drivers

    When I first tried it, the frame rate was horrid and the camera was terrible.

    Turned the in-game v-sync back on, put everything at very high except shadows at high, and made sure most options in catalyst were set to "app controlled" or whatever.. also turning on AA made the game unplayable due to a shaking screen.

    Now the game is playable and I'm almost always right at 30 FPS, but still the camera is not the most fluid and having to escape to get to the map as well as other glitches has made the game a bit annoying at times. This really should've had a beta. I'm guessing they just threw it out there and will wait for everyone to complain about stuff and then fix it eventually.

    Still it's pretty fun, although I agree, I think I liked the way the first game played better.
     
  8. dooms33ker

    dooms33ker New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Radeon 4850
  9. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,049
    Likes Received:
    569
    GPU:
    EVGA GTX 1080 Ti SC2
    Nice guide, dooms33ker. Thanks.

    Is there any way to force MSAA through the driver yet?
     
  10. suddenlyisee

    suddenlyisee Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    GeForce GTX 570 MSI TFII
    Amen to that. The godlike Witcher 2 makes so many games look like crap, don't it?
     

  11. sterkiller

    sterkiller New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    GTS 250 1GB
    i had a bad time , trying to solve this game lagness oO
    but i found a "way around"

    it worked for me and i was able to turn off the damn blur , and bloom as well ,
    go to the game´s folder and edit the "VideoOptionsConfig.xml" file , and turn off or on , things you think will do better for your rig´s spec.

    its better this way , cuz you can edit things without lose overall quality , like turning blurr of without disabling the AA opts.

    Hope it works for you.

    Registered just to state this lol
     
  12. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,049
    Likes Received:
    569
    GPU:
    EVGA GTX 1080 Ti SC2
    @sterkiller - You should have explained that values above 5 disable the setting and lower values for settings with Minimum in their names increase the setting.

    For example, to disable motion-blurring then just change these settings from 2 to 6 (or any other number higher than 5):

    <MotionBlurMinimumEffectsDetail>2</MotionBlurMinimumEffectsDetail>
    <RadialBlurMinimumEffectsDetail>2</RadialBlurMinimumEffectsDetail>
     
  13. sterkiller

    sterkiller New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    GTS 250 1GB
    @Darren Hodgson

    Nice point m8 , on mine i just set it to 0 , and it was turned off , but for those who dont want to turn it off , but tweak it instead , should do as you said.

    this topic is one of the first ones when you google this matter , now ppl have a way out of it

    1° > turn off shadows (even the lowest setting will lag as hell)
    2° > tweak the config file for your needs :D
    3° > enjoy it! :)
     
  14. signas_86

    signas_86 Master Guru

    Messages:
    373
    Likes Received:
    0
    GPU:
    GTX670 SLI Watercooled
    is there any other to fix the performance other than alt+tab??the game sometimes drop tu 20-25 fps..i need to back to desktop to restore it..
     
  15. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,049
    Likes Received:
    569
    GPU:
    EVGA GTX 1080 Ti SC2
    Press START on the controller or, I believe, Esc twice on the keyboard to go to the Sanctuary and back to the game to fix the framerate drop. 60 fps to 20 fps just ain't nice...

    Better still, just enable the in-game v-sync and live with the 30 fps framerate cap. The game never drops below that for me if I do but does if I disable v-sync in-game and force it via D3DOverrider or the game's profile in the NVIDIA control panel.

    The engine clearly isn't optimised to run at anything above 30 fps as that was all the ageing Xbox 360 could manage. Despite being eight months late and Lionheart claiming that Fable III has been upgraded for the PC I've seen absolutely no evidence of it. Higher resolutions and improved graphical effects are par for the course in a PC port not what I consider upgrades!!!

    The one shining beacon of hope for PC owners is that the Xbox 360's successor is heavily rumoured to be unveiled at next year's E3 and will use DirectX 11 so we'll finally see an end to these half-baked, lame, lazy DX9 ports.
     
    Last edited: Jun 15, 2011

  16. jodokast

    jodokast Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    ASUS DirectCU DC2OC-R9290
    I changed the values in my VideoOptionsConfig.xml to disable the annoying motion-blurring. It didn't work for me by just changing the Blur values, I had to set the both motion blur and aa options to 99
    <RadialBlurMinimumEffectsDetail>99</RadialBlurMinimumEffectsDetail>
    <MotionBlurMinimumEffectsDetail>99</MotionBlurMinimumEffectsDetail>
    <TemporalAAMinimumEffectsDetail>99</TemporalAAMinimumEffectsDetail>
     
  17. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,049
    Likes Received:
    569
    GPU:
    EVGA GTX 1080 Ti SC2
    @jodokast - Surely, you want to leave the AA enabled not disabled otherwise the game will look aliased/jaggy?

    *EDIT*

    Sorry, I see that you said the motion blurring cannot be disabled without also turning off temporal AA. That isn't an option for me I'm afraid, unless there's a way to force AA through the driver, but it explains why motion-blurring and AA are grouped together under the Effect category I guess.
     
  18. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,609
    Likes Received:
    12
    GPU:
    MSi GTX980 GAMING 1531mhz
    Can i disable AA in the game ?
     
  19. Brendruis

    Brendruis Maha Guru

    Messages:
    1,242
    Likes Received:
    1
    GPU:
    Reference GTX 680 SLI
    That's because the game is absolutely terrible it runs like a dog on my machine too.
     
  20. bratbag07

    bratbag07 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    nvidia geforce512mb x2sli
    having issues with fable 3 offline

    first going all right tad lagging
    then put in second graphic card and freeze on live sign in

    running
    xp sp3 pro 64bit
    mb gigabyte GA-M57SLI-S4 ver 1.0 i think
    psu apower ak series sata atx 800w
    cpu amd athlonx64bit +5200
    ram 3.5gb going up grade 2gb more soon
    hdd 250gb
    graphic's card nvidia geforce 9500gt 512mb sli
    nvidia geforce 9500gt 512mb sli
     

Share This Page