F.E.A.R. slows down every few minutes and has to be restarted?

Discussion in 'Games, Gaming & Game-demos' started by fluxcapacitor81, Aug 11, 2010.

  1. fluxcapacitor81

    fluxcapacitor81 Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    GigabyteGTX670@1200/6600
    I realize this is an old game but seriously my system is more than enough to handle 5+ yr old games no prob:

    Gigabyte GA-EP43-UD3L
    C2D e7200 @ 3515Mhz
    4GB ocz ddr2800
    Auzentech X Fi Prelude 7.1
    ATI HD 5750 1GB
    Win 7 x64 Ult

    At first I couldn't even run it playable iit was so choppy. I mean so bad that during the credits during intro it took like over a minute between credits! But running in Win XP compatibility mode solved that. The game looks gorgeous at max settings in 1080p. Super gorgeous. And runs as smooth as butter. No lag ever. With 4x16x fsaa/af. But then every 10 or 15 minutes or so it screeches to a halt and has to be saved and restarted. Anyone else have this and/or know how to fix it running F.E.A.R. on a modern Win 7 system?
     
    Last edited: Aug 11, 2010
  2. kanej2007

    kanej2007 Ancient Guru

    Messages:
    8,276
    Likes Received:
    0
    GPU:
    MSI GTX 1080 TI 11GB
    I get EXACTLY the same problem with Condemned - Criminal Origins by Sega, pisses me off, after a while it will randomly stutter like mad, the only way to fix it is to restart!!
     
  3. fluxcapacitor81

    fluxcapacitor81 Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    GigabyteGTX670@1200/6600
    Yeah like I said at first I couldn't even play it so I'm glad to be able to. But its retardedly annoying. I don't think it's asking too much to be able to play a 5 year old game without issues on Windows 7.
     
  4. dualloop

    dualloop Member Guru

    Messages:
    143
    Likes Received:
    0
    GPU:
    Nvidia Geforce GTX TITAN
    I had the exact same problems a couple of years ago with a 9800GX2 on Windows Vista Home Premium 64Bit.
    Mine would slow down every 10 mins or so to the point of being unplayable.
    The strange thing is that FEAR 2 uses the exact same engine with a modified Havok engine and never has any slow downs. I never solved the problem, even when i upgraded to a GTX295 it was still there, and with FEAR that got bundled with FEAR 2. I think it's possibly Havok as it seems thats the only thing that was modded on the new FEAR 2 but it is possible that Monolith may have slighty tweaked the game code.
     

  5. Pill Monster

    Pill Monster Banned

    Messages:
    25,234
    Likes Received:
    0
    GPU:
    7950 Vapor-X 1100/1500
    Sounds like a memory leak.
     
  6. Damien_Azreal

    Damien_Azreal Ancient Guru

    Messages:
    8,291
    Likes Received:
    11
    GPU:
    EVGA GTX 970 ACX2.0 4GB
    Techically... FEAR 2 doesn't use the exact same engine. True, both games use the Jupiter EX engine. But FEAR 2 uses a heavily modified version of the engine.
    The build of Jupiter EX used in FEAR 2 (and Condemned 2) has the inclusion of motion blur, HDR, depth of field and completely revamped lighting/shadow system.

    Think of it like how NOLF was build on LithTech, and NOLF 2 was build on LithTech 2.0. Same engine, very similar, but some heavy code changes and tweaks were done in between.
     
  7. dualloop

    dualloop Member Guru

    Messages:
    143
    Likes Received:
    0
    GPU:
    Nvidia Geforce GTX TITAN
    Yeah, it's a shame Monolith haven't released a patch for it, it's a good game and its the only reason that I don't play it anymore.
     
  8. TheHunter

    TheHunter Banned

    Messages:
    13,412
    Likes Received:
    0
    GPU:
    MSi N570GTX TFIII [OC|PE]
    its bugged engine in win7/vista.

    Something about direct input; the only fix is use windows xp. That's how it is. I have to use dual boot for this game because im playing Fear mp allot.
     
  9. fluxcapacitor81

    fluxcapacitor81 Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    GigabyteGTX670@1200/6600
    Well thanks for the replies. What a shame. But at least it's playable.
     
  10. Damien_Azreal

    Damien_Azreal Ancient Guru

    Messages:
    8,291
    Likes Received:
    11
    GPU:
    EVGA GTX 970 ACX2.0 4GB
    Yeah, Vista compatibility was something they worked into the Jupiter EX engine with FEAR 2.
     

  11. Year

    Year Ancient Guru

    Messages:
    11,595
    Likes Received:
    0
    GPU:
    EVGA GTX 690
    never had this problem with any of my rigs in W7 X64, perfect performance after 1-2 hours of play.
     
  12. TheHunter

    TheHunter Banned

    Messages:
    13,412
    Likes Received:
    0
    GPU:
    MSi N570GTX TFIII [OC|PE]
    for me its G15v2 pos software that lags the thing, like i said its ok in winxp..

    you can try this fix for win7/vista; but it didnt work as it should here..

     
  13. kbozz71

    kbozz71 Member Guru

    Messages:
    158
    Likes Received:
    0
    GPU:
    GTX 1060 6GB
    I had serious problems in FEAR with windows 7 64. Turns out it was my Logitech mouse. Went into device manager and disabled all the HID compliant devices and it's running like a dream ever since. May want give that a shot. TheHunter has given directions above.
     
    Last edited: Aug 11, 2010
  14. rOBvAN

    rOBvAN New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ATI 4870X2
    I too can confirm that this is a problem between Windows 7 and Logitech Gxx gaming peripherals.

    For me it was my G15 keyboard causing the problems. I am running Windows 7 64bit and got really slow FPS after about 10 minutes in F.E.A.R and Extraction Point. "The Hunters" solution works (to disable the HID compliant devices with a 046D ID).

    I had four of these devices that needed to be disabled and after that the game was smooth as silk. It basically disables the LCD screen and the buttons on it. Perseus Mandate was unaffected by this problem, possibly because it is a stand-alone expansion and possibly uses a tweaked engine?

    Anyway, thank you "the Hunter" for your solution!
     
  15. WaroDaBeast

    WaroDaBeast Ancient Guru

    Messages:
    1,963
    Likes Received:
    0
    GPU:
    Gigabyte HD7950
    Aah, nice find, TheHunter. :)
     

  16. TheHunter

    TheHunter Banned

    Messages:
    13,412
    Likes Received:
    0
    GPU:
    MSi N570GTX TFIII [OC|PE]
    sure np :)
     
  17. ST19AG_WGreymon

    ST19AG_WGreymon Ancient Guru

    Messages:
    4,698
    Likes Received:
    1
    GPU:
    eVGA 970 SC ACX 2.0 4GB
    I have the Steam version of FEAR and I've played this game for hours abd haven't experienced anything like this on Win7 x64 Pro.
     
  18. w1nbl00d

    w1nbl00d New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD 6970
    I got this issue with Condemned - Criminal Origins.
    I have a Logitech G930 headset, so I tried to disable HID\VID_046D&PID devices, but it turned out to be only my Saitek Eclipse II keyboard exhibiting the issue.

    Disabled HID\VID_06A3&PID devices and I just doubled and maintained the initial 60 FPS I was having before it was dropping to ~23 FPS after a while.
     
    Last edited: Oct 26, 2011

Share This Page