Enabling VSync enforces framerate cap

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by xvt, Dec 6, 2017.

  1. xvt

    xvt Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Z
    Hi there, the title is a bit silly but hopefully someone can help me out with this.

    In the present and previous drivers (388.13, 388.31 and 388.43) I've been experiencing odd behaviour: whenever I enable vsync, be it through the control panel or in-game, the drivers impose a framerate cap of (Refresh Rate) - 2. This even happens when using fastsync. This is not the usual when enabling vsync.

    Yes, I've made sure RTSS is not doing the cap nor has the driver such option enabled.
    I've tested it with both 60hz and 75hz refresh rates and both get capped at 58fps and 73fps respectively.

    Now, I am aware of the whole reduction of input lag when you cap 2 frames below the refresh rate, but I find the frame skipping unbearable and I've been previously using the method posted here by RealNC to great success and wish to continue to do so.

    Is anyone else experiencing this? Is this some new feature nvidia implemented in the drivers recently? Maybe some variable that enabled such behaviour?

    OS: Windows 7 x64 Pro.

    tl;dr:
    whenever I enable vsync, be it in-game or through the control panel/inspector, out of nowhere, framerate is capped at 2 frames below refresh rate (58 fps if i use 60hz, 73 fps if i use 75hz). I am NOT using any software to cap the framerate.

    Cheers!

    edit:
    issue resolved, occam's razor: dust in the hdmi contacts in the GPU port and/or not securely plugged in cable, really stupid shite but to great effect.
    Hopefully this will save some hours to some poor soul in the internet with a similar problem.
     
    Last edited: Dec 7, 2017 at 12:06 PM
  2. archie123

    archie123 Ancient Guru

    Messages:
    2,464
    Likes Received:
    10
    GPU:
    Aorus 1080ti Extreme
    Thats what vsync does , it caps your framerate below max refresh to stop tearing , can give you a little mouse lag too
     
  3. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    10,381
    Likes Received:
    263
    GPU:
    1080Ti H20
    No, vsync caps the fps to the monitors refresh rate, not a 2 fps cap below it.
     
  4. xvt

    xvt Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Z
    Thank you for taking the time to read the thread.

    After some more testing, what seems to enforce the cap is the Vertical Sync Tear Control set to Standard/LoL, regardless of vsync method used, tho the 1/2 Half Refresh option plus Standard Tear Control seems unaffected, i.e. doesn't lock to 28fps.

    Also tested with two older drivers (385.41 and 387.92) and unfortunately the same behaviour shows up now.

    So that leaves me thinking that it might be some recent Windows Update KB... ?
    Just speculation until someone else can confirm they experience the same framerate lock.
     
    Last edited: Dec 7, 2017 at 4:46 AM

  5. khanmein

    khanmein Maha Guru

    Messages:
    1,417
    Likes Received:
    26
    GPU:
    EVGA GTX 1070 SC
    Slinkyminx likes this.
  6. xvt

    xvt Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Z
    Maybe I'm not wording the OP correctly because there are two people confused over the issue now (archie123 and khanmein).

    tl;dr:
    whenever I enable vsync, be it in-game or through the control panel/inspector, out of nowhere, framerate is capped at 2 frames below refresh rate (58 fps if i use 60hz, 73 fps if i use 75hz).
    I am NOT using any software to cap the framerate.

    [​IMG]
     
  7. Heinrich Von Schnitzel

    Heinrich Von Schnitzel New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Gainward GS GTX1070
    Try creating a custom resolution in the nvidia control panel to make sure you're actually running 60 or 75 hz. If that doesn't work try removing the drivers with DDU, and install them again. Also you should post your complete specs, or at least what screen you're using (if your specs on your profile are up to date)
     
  8. xvt

    xvt Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Z
    No luck with custom resolutions, still locked at 58/73 fps.
    BlurBusters Refresh Rate test lists the refresh rates to the expected values, 60hz/75hz.
    I always use DDU with every driver install.

    Specs on profile are up to date.
    Monitor: LG 34UM57.
     
  9. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,725
    Likes Received:
    6
    GPU:
    ASUS GTX 980 STRIX
    What does vsynctester.com say your actual refresh is?
     
  10. xvt

    xvt Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Z

  11. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,725
    Likes Received:
    6
    GPU:
    ASUS GTX 980 STRIX
    The only thing that makes sense to me, is if you had somehow had the frame limiter set globally in Profile inspector.

    But if it happens at 75 hz too, that's weird.
     
  12. xvt

    xvt Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Z
    Yeah, I'm lost on this. I have absolutely nothing capping the framerate, it just so happens when standard vsync is enabled.
    What I find even weirder: fastsync behaves the same.
    You could argue it's maybe a left over from an old driver, a borked install or the sort, but I've been thorough with scrapping everything from the registry, even going in to manually check and the behaviour still remains.
     
  13. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,725
    Likes Received:
    6
    GPU:
    ASUS GTX 980 STRIX
    Maybe turn off all the Gsync feature stuff, and turn off Aero.

    Does your monitor have multiple inputs? (DVI,HDMI,DP?)
     
  14. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,725
    Likes Received:
    6
    GPU:
    ASUS GTX 980 STRIX
    Is this happening in Full Screen Exclusive programs, or only in windowed?
     
  15. xvt

    xvt Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Z
    Tested with GSync stuff forced to off and disallowed: on both occasions, no luck. (This is a freesync monitor, but it was worth a shot).
    Aero off: no luck.

    Monitor has both DP and HDMI, currently set on DP.
    I also have a TV connected through HDMI, but the same thing happens.
    Tested on each one independently to see if it was a multi monitor problem, but have ended up with the same result.
    VSync should have no bearing on windowed mode since Desktop Window Manager takes over, but nonetheless, if i enable vsync (in-game or in control panel before launching), the cap goes into effect.
    So yes, it's happening in both, windowed and full screen exclusive.
     

  16. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,725
    Likes Received:
    6
    GPU:
    ASUS GTX 980 STRIX
    You could try locating the display in the registry and delete them all.

    \HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\nvlddmkm\display database.

    Then use CRU To reset the display driver with Restart64.exe. Also use CRU reset-all.exe
     
  17. xvt

    xvt Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Z
    Did so and nope, same thing.
     
  18. xvt

    xvt Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Z
    While doing some more troubleshooting, I disconnected the TV and the cap went away.
    Then switched over to the TV as main display, ran a test and disconnected the monitor: cap went away.
    I have to physically pull the input plug from either device for it to normalize, using Win key+P to only enable each display while the other is connected won't work.
    I still have no idea why this suddenly started to happen, this is just odd.
     
  19. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,725
    Likes Received:
    6
    GPU:
    ASUS GTX 980 STRIX
  20. xvt

    xvt Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Z
    Well, this was really fucking stupid and laughable, but, in case anyone else comes across something like this:
    Unplug the input cables from your GPU, dust them off, plug again.
    crap works as it should.

    Goddammit.
     
    Last edited: Dec 7, 2017 at 9:35 AM

Share This Page