Enable/Disable G-Sync using Commandline or Bat?

Discussion in 'General Hardware' started by Odellot, Apr 15, 2015.

  1. Odellot

    Odellot Master Guru

    Messages:
    661
    Likes Received:
    0
    GPU:
    MSI 1080TI SLI PG348Q
    Hi..Is there anyway to Enable/Disable G-Sync using commandline or Bat?

    I'm asking because in 3DVision you can use this command..
    Code:
    "C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /enable
     
  2. Nono06

    Nono06 Master Guru

    Messages:
    865
    Likes Received:
    0
    GPU:
    680 GTX SLI (1215/6884)
    He Odellot,

    I have never seen any command for that.
    In opposite to 3DVision, G-sync is part of the core driver, so I'm not sure an external service is controlling it.

    May I ask why you need that? It is something that you can set by application in the control panel, so I'm not sure I understand the reason why you need that.
     
  3. Odellot

    Odellot Master Guru

    Messages:
    661
    Likes Received:
    0
    GPU:
    MSI 1080TI SLI PG348Q
    I want to have a keyboard hotkey on disable/enable G-Sync like what I do with 3D Vision..I want to quickly disable G-Sync so that I can enable ULMB on some games...
     
  4. Nono06

    Nono06 Master Guru

    Messages:
    865
    Likes Received:
    0
    GPU:
    680 GTX SLI (1215/6884)
    So if it is for specific games, is that not enough to disable gsync in their profile? Do you want to do that on the fly in game?

    It also means that you have your refresh rate set to 120Hz because ULMB is not compatible with 144Hz.

    Switching to a borderless window (if supported by the game) could do the trick since g-sync only works in exclusive mode but SLI works better in exclusive mode also.
     

  5. Nono06

    Nono06 Master Guru

    Messages:
    865
    Likes Received:
    0
    GPU:
    680 GTX SLI (1215/6884)
    It seems that with the driver 350.12 even the desktop is using Gsync.
    Do you also see that on your side?
    So it seems that now G-sync is also compatible with window mode.
    In that case running the game in borderless mode will not solve your problem.
     
  6. ancalimon

    ancalimon New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    XFX r7979 Black
    Setting gsync and ulmb for some reason does not work for profiles.

    For example setting gsync on globally and setting ulmb of dwm.exe (windows desktop) results in fullscreen games switching to 144hz fixed refresh rate instead 144hz gsync. Returning to desktop properly sets it to ulmb.

    So what we need is an ulmb command because ulmb - gsync based on profiles has been bugged for years now.
     

Share This Page