Emulating OpenGL 2.0 for Intel 915GM graphics?

Discussion in 'Videocards vs General Purpose - NVIDIA Ageia PhysX' started by Seestern, Nov 15, 2005.

  1. nirvek

    nirvek Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    Mobile Intel 915GM
    returning to topic , i was check with opengl extension viewer and shows that intel drivers support opengl 1.4 100% but 1.5 only in 66% and 2.0 in 11% , is this because of hardware (915gm) or because of drivers?
     
  2. Wolverine69r

    Wolverine69r Guest

    opengl 1.5 is the vertex objects

    and 2.0 is the shader objects.. this is purely hardware
     
  3. nirvek

    nirvek Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    Mobile Intel 915GM
    if 915gm have pixel shader 2.0 then only problem is in vertex shader? cant intel drivers emulate vertex shader and caps for opengl like in directx?
     
  4. Wolverine69r

    Wolverine69r Guest

    lol

    ok its like this

    Pixel shader requires the use of the T&L engine.. the intel chip can't do this via hardware so technically its a false pixel shader and will suffer greatly.

    the vertex line can be emulated by cpu but you'll just make the performace hit worse

    your better off just using fixed function calls
     

  5. nirvek

    nirvek Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    Mobile Intel 915GM
    uh

    i have another problem ... i was try run diferend opengl demos and always i have error : ARB_multisample and EXT_texture3D and EXT_texture_edge_clamp <- not found .... But OpenGL Extension Viewer shows that 915GM support it .... What is wrong?? (multisample is in opengl v1,3 rest in 1,2)
     
  6. Dr. Vodka

    Dr. Vodka Ancient Guru

    Messages:
    3,803
    Likes Received:
    9
    GPU:
    Sapphire R9 290 Tri-X
    This makes me think if Intel's solution works AT ALL.
     
  7. nirvek

    nirvek Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    Mobile Intel 915GM
    i wonder too , but games in directx are runing , so .. maybe is something wrong with software , i cant run 3dmark2001 since i install SP1 on win2003
     
  8. Wolverine69r

    Wolverine69r Guest

    have you set hard acceleration back to full?
     
  9. nirvek

    nirvek Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    Mobile Intel 915GM
    i have all set to full hardware
     

Share This Page