1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dxgmms2.sys BSOD

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Anna9, Mar 23, 2019.

  1. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,193
    Likes Received:
    3,670
    GPU:
    GeForce GTX 1070
    @Anna9

    Windows Error Reporting is about applications, about the crashes of applications:
    https://docs.microsoft.com/en-us/windows/desktop/wer/about-wer
    https://docs.microsoft.com/en-us/windows/desktop/wer/using-wer

    I browsed those pages and neither BSODs nor dump-files for BSODs are mentioned.

    There is known issue with the dump-files when user configures page file not on the system partition (so that there is no page file on the system partition).

    Here:
    https://support.microsoft.com/en-us/help/130536/windows-does-not-save-memory-dump-file-after-a-crash

    PS

    You should see BSOD error in the System log, it can reference not the sys-file, but any application.
    See the checkbox "Write an event to the system log"
    [​IMG]

    You don`t have to search or filter, just clean the System log and then reproduce the BSOD.

    And the path for small dump directory - I changed it namely because I moved page file from the system partition to another one. My rig has no BSODs for a long time so I am not sure that Windows actually respects that changed path.
     
    Last edited: Mar 24, 2019
    Anna9 likes this.
  2. Anna9

    Anna9 Member

    Messages:
    21
    Likes Received:
    3
    GPU:
    nVidia 1080 SLI 2x
    The thing is I have 64GB RAM, so I disabled the page file, it maybe the reason I don't have memory dumps?

    Until now no BSOD, still can't say for sure it is fixed.

    Regarding the event viewer, I check the time when the BSOD happens,and I could see the error about it, but there is no data, no files, nothing.

    I will check again though. Thank you all guys for the help.

    I think the Killer network was the cause, the mentioned file KfeCo10x64.sys used to take lots of resources, and its thread inside inside the system Process ID used CPU resouces leaving not enough CPU for the dxgmms2.sys which is also a thread inside the System Process, and causes the BSOD.

    @Caesar thanks again for the hint about the monitoring software, one would never think of it as a reason for the BSOD.

    Still not conformed, will return.
     
  3. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,193
    Likes Received:
    3,670
    GPU:
    GeForce GTX 1070
    Should be. In case BSOD will happen again you can enable page file and then post detailed info.

    It is old theme - to disable page file or not. I stay in the camp of those who leave page file alone. Because the more RAM you have the less activity will be in page file - hence no harm to performance.
     
    Anna9 likes this.
  4. Anna9

    Anna9 Member

    Messages:
    21
    Likes Received:
    3
    GPU:
    nVidia 1080 SLI 2x
    @mbk1969 I will enable the page file for sure if I get any BSOD, I would have never thought of it as a reason if you haven't told me. Thank you so much, you are all guys so nice.

    Yesterday I stressed my PC with lots of processes and I even overclocked my CPU with a very high CPU usage, nothing happened,

    I under-clocked my CPU to check, also no BSOD. that is why I said it maybe have been addressed and fixed.

    I will return for sure.

    Thanks again all
     
    Singleton99 likes this.

  5. Astyanax

    Astyanax Ancient Guru

    Messages:
    1,805
    Likes Received:
    439
    GPU:
    GTX 1080ti


    Don't disable the page file.
    Having a lot of memory is not a valid reason to disable the page file, it does more than just serve as a place to purge old pages to, its also required to be able to allocate (even if not use) memory large than the currently available contiguous amount as well as a buffer to allow device resets if another driver leaks so much that it starves the non paged driver set.
     
    Smough likes this.
  6. Anna9

    Anna9 Member

    Messages:
    21
    Likes Received:
    3
    GPU:
    nVidia 1080 SLI 2x
    I big to differ, in fact I encourage anyone with 16GB to disable their page file to gain performance improvements and longer HDD/SSD life cycle.

    I have always disabled file paging, and not once I had a problem.in this case Windows uses the memory to write private bits and page old or faulty data. see the pic https://imgur.com/a/9j5D418
     
  7. Anna9

    Anna9 Member

    Messages:
    21
    Likes Received:
    3
    GPU:
    nVidia 1080 SLI 2x
    I must thank you again, no more BSOD so far.

    I would never think of Killer Network Monitoring software as a reason, I knew it made my laptop slower, but never thought of it as a cause for BSOD because I had it before.

    The problem there is a bug with Killer WiFi will keep me using that Software for ever and never think of it as a reason for BSOD, I would just think of it as unwanted app.

    Although it is a struggle to keep it disabled, cause windows update forcing it, even though I used the utility from Killer Network to disable it from windows update.
     
    Last edited: Mar 27, 2019
  8. Astyanax

    Astyanax Ancient Guru

    Messages:
    1,805
    Likes Received:
    439
    GPU:
    GTX 1080ti

    Stop begging, You're wrong pure and simple and your belief is founded on ignorance regarding the windows NT memory manager.

    https://blogs.technet.microsoft.com...pushing-the-limits-of-windows-virtual-memory/

    https://lifehacker.com/understanding-the-windows-pagefile-and-why-you-shouldnt-5426041

    http://azius.com/pagefile-yes1/
     
    Smough likes this.
  9. Anna9

    Anna9 Member

    Messages:
    21
    Likes Received:
    3
    GPU:
    nVidia 1080 SLI 2x
    If you just read the page you linked ;) , although I think you didn't even read my post :)


    Private bits and paging to be written into RAM instead of a page file :cool:

    Yet it is not a stupid way to use memory, it is faster with no life cycle limits.

    Only RAM has lifetime warranty, does this ting a bell?

    If you have plenty of RAM you should use it and not use your disk.


    Read carefully ;) and take look at the picture again
     
    Last edited: Mar 28, 2019
  10. Alessio1989

    Alessio1989 Maha Guru

    Messages:
    1,219
    Likes Received:
    159
    GPU:
    .
    I can confirm this is a Microsoft bug, I got the same issue using a AMD Radeon with the latest drivers, so it's not an NVIDIA driver issue, and I am using Windows 10 version 1903.

    I also inspected the system memory dump with Microsoft WinDbg, and I confirm it's dxgmms2.sys fault, just some quick details:

    A driver tried to write to an unallocated address in the user space of the system process.

    Simply Microsoft fucked around with a Microsoft Media Streaming implementation component, which is used by DirectShow/DXVA/DXVA2/DXVAHD/EVR etc..

    Until Microsoft fix this issue with a patch, the only solution now is using an older Windows version.

    I didn't never trigger such bug under 1809 but probably I was lucky enough with AMD drivers...
     

  11. boombastik

    boombastik Master Guru

    Messages:
    231
    Likes Received:
    8
    GPU:
    PNY GTX 970 XLR8 OC

    Windows is designed to work with a pagefile. Not having one, even if you have a lot ram, you are asking for trouble.
     
  12. Astyanax

    Astyanax Ancient Guru

    Messages:
    1,805
    Likes Received:
    439
    GPU:
    GTX 1080ti

    theres nothing to fix, if something is broken its your radeon drivers.

    :cool:
     
  13. Alessio1989

    Alessio1989 Maha Guru

    Messages:
    1,219
    Likes Received:
    159
    GPU:
    .
    it's not, I know how to use a system debugger, while you probably don't.
     
  14. Astyanax

    Astyanax Ancient Guru

    Messages:
    1,805
    Likes Received:
    439
    GPU:
    GTX 1080ti
    I can assure you, you don't have any idea what you're doing.
     
  15. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    5,936
    Likes Received:
    425
    GPU:
    MSI GTX 1070
    I always manually set my Pagefile to 4096.

    Should be enough... it has never caused issues atleast.
     

  16. Astyanax

    Astyanax Ancient Guru

    Messages:
    1,805
    Likes Received:
    439
    GPU:
    GTX 1080ti
    you might as well leave it on automatic, it'll only get used if it needs to get used and you haven't hit a case where it does.
     
  17. Witcher29

    Witcher29 Maha Guru

    Messages:
    1,052
    Likes Received:
    69
    GPU:
    1080 Ti Gaming X
    @ OP unistal intel RTS, also let windows do all the updates.
     

Share This Page