Drivers don't recognize OpenGL games?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by v0latil3, Jun 23, 2015.

  1. v0latil3

    v0latil3 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    XFX 290x 4GB
    Hello,
    I just bought an r9 290x coming from a gtx 650, and the catalyst drivers dont seem to be recognizing OpenGL games.
    I posted on AMD official forums https://community.amd.com/thread/183220 but thought I might find a solution here.
    What happens is that when I play a game such as minecraft or xonotic or others, I get low fps in the game. The gpu stays at low clock frequencies like 300-500 MHz and has average load of 5-20%
    Is there a way to force it into a performance mode? Do any of you have this problem too?
    Let me know if there is more information that could help diagnose this.
     
  2. lexer98

    lexer98 Master Guru

    Messages:
    668
    Likes Received:
    1
    GPU:
    GTX 1070 - WC
    Disable ULPS with MSI Afterburner and see if it works
    [​IMG]
     
  3. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    670
    Likes Received:
    138
    GPU:
    AMD RX 570 4GB
    Is your driver properly installed?
     
  4. v0latil3

    v0latil3 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    XFX 290x 4GB
    That does not help :( I still have only 50 FPS and the highest the core has gone is 694 Mhz since I rebooted
     

  5. gabibbo97

    gabibbo97 New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    R9-290X 4096MB
    What game is it?(the others)
    I have no problem at all with X-Plane that is a OpenGl game
     
  6. v0latil3

    v0latil3 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    XFX 290x 4GB
    xonotic
    kerbal space program
    I will look and see if there are any others I have that aren't affected
     
  7. Hootmon

    Hootmon Maha Guru

    Messages:
    1,227
    Likes Received:
    6
    GPU:
    RX580 8GB
    Which driver are you using. Some of the leaked drivers are hit-and-miss when it comes to OpenGL
     
  8. lexer98

    lexer98 Master Guru

    Messages:
    668
    Likes Received:
    1
    GPU:
    GTX 1070 - WC
    What drivers version currently have installed ?
     
  9. v0latil3

    v0latil3 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    XFX 290x 4GB
    I have tried 14.12, 15.4, 15.5, and the leaked 15.15
     
  10. Hootmon

    Hootmon Maha Guru

    Messages:
    1,227
    Likes Received:
    6
    GPU:
    RX580 8GB
    15.6 just came out...
     

  11. lexer98

    lexer98 Master Guru

    Messages:
    668
    Likes Received:
    1
    GPU:
    GTX 1070 - WC
    This is not a pretty solution but maybe can work. Install Radeon PRO and make a profile for those games and in the Overdrive tab enable Always use highest performance clocks while gaming
     
  12. v0latil3

    v0latil3 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    XFX 290x 4GB
    Okay, I will try the 15.6 drivers.
    On second look, it seems to be working with ksp actually
     
  13. v0latil3

    v0latil3 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    XFX 290x 4GB
    Wow thanks for the help guys but the problem is something with my minecraft. The other games had a max frame rate limit set that I didn't know about.
     
  14. Hootmon

    Hootmon Maha Guru

    Messages:
    1,227
    Likes Received:
    6
    GPU:
    RX580 8GB
    We are (mostly) a helpful bunch as long as you do due diligence.

    Search before asking. Provide full details. Stuff like that.
     

Share This Page