Driver release for BioShock

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by imladris701, Aug 20, 2007.

Thread Status:
Not open for further replies.
  1. Sieras

    Sieras Ancient Guru

    Messages:
    3,815
    Likes Received:
    0
    GPU:
    Gigabyte GTX 970 G1 4GB
  2. KillerC

    KillerC Master Guru

    Messages:
    418
    Likes Received:
    0
    GPU:
    EVGA 2080 RTX
    AWESOME!! thanks for the heads up Ragtag!!
     
  3. vurt

    vurt Master Guru

    Messages:
    266
    Likes Received:
    4
    GPU:
    RTX 3090
    30-60. I'd say 30 FPS on average when fighting and lots of things going on.

    DX10 or DX9 doesnt seem to matter, i get the same FPS.

    EDIT: Wohoo! new driver :D
     
  4. fischju

    fischju Ancient Guru

    Messages:
    2,083
    Likes Received:
    0
    GPU:
    Visiontek Radeon HD 4850
    Same FPS and people say they don't see a difference....I'm guessing the demo doesn't really have DX10 effects
     

  5. St. bluedrop

    St. bluedrop Member Guru

    Messages:
    100
    Likes Received:
    0
    GPU:
    MSI GTX 570 TFIII@950MHz
    This did not fix the slow down bug.. :(
     
  6. jeffy

    jeffy Active Member

    Messages:
    65
    Likes Received:
    0
    GPU:
    GTX570 TwinFrozrII OC
    The new drivers works way smoother for Bioshock. It feels smoother as well. A keeper for me! Also, digital vibrance is a go!
     
  7. ChaosPhoenix

    ChaosPhoenix Member Guru

    Messages:
    177
    Likes Received:
    0
    GPU:
    Gainward GLH 1080GTX
    The new driver fixes the SLI bluescreen problem.
     
  8. vurt

    vurt Master Guru

    Messages:
    266
    Likes Received:
    4
    GPU:
    RTX 3090
    Didnt do much for me.. i still have to use windowed mode for BS to load levels (i can turn on fullscreen when playing though).

    FPS is exactly the same as before.
     
  9. ChaosPhoenix

    ChaosPhoenix Member Guru

    Messages:
    177
    Likes Received:
    0
    GPU:
    Gainward GLH 1080GTX
    It fixed everything for me. Did you try to disable vsync?
     
  10. vurt

    vurt Master Guru

    Messages:
    266
    Likes Received:
    4
    GPU:
    RTX 3090
    yes, ive tried vsync on and off.. the performance is ok for my computer, but that fullscreen bug is very irritating, would really suck if i have to switch back and forth like this with the full game.
     

  11. Bravo

    Bravo Master Guru

    Messages:
    866
    Likes Received:
    0
    GPU:
    eVGA Geforce 9600GT 512MB
    these drivers are amazing for bioshock (havent tested any other games) my performance is anything from 50 - 110 fps. Average at 75 at max settings. Just goes to show that Nvidia still does its job very well.
     
  12. ChaosPhoenix

    ChaosPhoenix Member Guru

    Messages:
    177
    Likes Received:
    0
    GPU:
    Gainward GLH 1080GTX
    Too bad, the driver fixed everything for me. Although I get some weird textures on the first screen.
     
  13. 1heone

    1heone Master Guru

    Messages:
    229
    Likes Received:
    0
    GPU:
    HIS 4870 1GB
    how are u guys testing FPS's in the game? is there a way to turn this on?
     
  14. Sieras

    Sieras Ancient Guru

    Messages:
    3,815
    Likes Received:
    0
    GPU:
    Gigabyte GTX 970 G1 4GB
    You can use FRAPS or RivaTuner's OSD (fraps are easier to use, lol..but RivaTuner gives much more than just FPS display while you play :p).

    Just download FRAPS, leave it running and play. That way you can see your FPS in every game you play. And with F12 you can change in which corner you'll see the counter.
     
  15. Bravo

    Bravo Master Guru

    Messages:
    866
    Likes Received:
    0
    GPU:
    eVGA Geforce 9600GT 512MB
    fraps, get the new version from the main site here
     

  16. slappydooda777

    slappydooda777 Banned

    Messages:
    1
    Likes Received:
    0
    Nope you're a twat for posting flawed information. He's right


    Hey vurt and anyone else with the full screen bug did you read this part of the read me?

    "
    On some video cards when running DirectX 10, it is possible that the game will start in a non-full screen mode. To reset to full screen mode, go to the options/graphics options screen and toggle windowed mode on and then off. This should rectify the problem."


    Hope this helps


    Well Im just about to dload the new drivers (though Im not too impressed they are beta but never mind) but with 160.18 in XP Im getting 75-85 FPS with max settings, 1280x1024 vsync on. Ran smooooooooth as for me. I'm happy ;-)
     
    Last edited: Aug 20, 2007
  17. painter

    painter Maha Guru

    Messages:
    1,084
    Likes Received:
    24
    GPU:
    GTX 1060 6GB
    Look if I had known I would have posted it with a warning for 8800 users - it wasn't an issue I was aware of - it's impossable to know everything, though some think they do. Lowering prerender to as low as 0 has been used for years to reduce lag.

    SO 8800 OWNERS DON'T USE 0 OK.

    I called him a **** because of his arrogant attitude - same goes for you slappydooda777.

    What's with all the ***** on this forum these days?
     
    Last edited: Aug 21, 2007
  18. 1heone

    1heone Master Guru

    Messages:
    229
    Likes Received:
    0
    GPU:
    HIS 4870 1GB
    o i knew about fraps.. i didn;t think that made a vista 64 compat version :) today is a good dayy.. bbl!
     
  19. vurt

    vurt Master Guru

    Messages:
    266
    Likes Received:
    4
    GPU:
    RTX 3090
    slappydooda777: i dont have a problem that it doesnt start in fullscreen... it just wont load when i press "demo" in fullscreen mode. thx anyways.
     
  20. WildStyle

    WildStyle Ancient Guru

    Messages:
    15,306
    Likes Received:
    20
    GPU:
    MSI GTX 970
Thread Status:
Not open for further replies.

Share This Page