1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Driver issue? Or is my GFX card failing?

Discussion in 'Videocards - AMD Radeon' started by panniK, Aug 10, 2018.

  1. panniK

    panniK New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Radeon R7 260x
    Okay... well... I've tried so many different forums with no help, my GPU is a Radeon R7 260. After about 5 months one of my RAM cards went bad. Removed the bad card and all was fine. Until about 4 moths ago I started getting BSODs pointing to my AMD drivers (windows 7). This would only happen about once every couple weeks. Then one day, constant BSODs on startup, still pointing to my AMD drivers. I decided to upgrade to Windows 10 after 3 hours of trying to get my PC started, thinking maybe it was a bootleg copy of Windows 7 causing driver issues. *NOTE my motherboard doesn't have on-board gfx.*

    Was able to successfully install Windows 10, everything started up fine, and Windows installed "Microsoft Basic Display Adapter." Thinking all was fine I downloaded my favorite PC games at the time (PUBG and Fortnite),they installed fine but attempting to run Fortnite I got an error "DX11 feature level 10.0 is required to run the engine", knowing this meant I needed to update my video drivers, then proceeded them to t he AMD Adrenaline (18.x) Drivers, and then I received a Windows 10 BSOD "THREAD STUCK IN DEVICE DRIVER" about 70% of the way through the driver install, the part where the monitor flashes to a black screen then back to your desktop. PC then restarted and went through its self repair because of the blue screen. It restored it to right before I updated the video driver. Did some google searching to find out what the problem was and still pointed to my video driver (obviously).

    Thinking my PC was just a brick I used it only for viewing news and Facebook. Until one day i became bored and tried to watch a stream in 1080p, which I was able to, to my surprise. A buddy of mine about a month later who plays on a WoW Private Server and offered me to come play, told him about the situation with my PC, he goes on a rant on how old the game was, blah blah blah. I decided to give it a try, and truth be told it works (about 22-38 FPS lowest settings 1360x768 resolution). Thinking all was fixed I tried Fortnite again and received the DX11 error again, tried updating video driver again, and the same BSOD "THREAD STUCK IN DEVICE DRIVER". Windows 10 restored itself to right before updating the video driver again. Used DDU to clean drivers (in safe mode) then windows reinstalled the basic display adapter.

    I have tried almost everything I can think of to resolve this issue, re-seating card, updating motherboard BIOS, using another PCI slot, and making sure PSU was properly working. Any help would be greatly appreciated, this has been an on-going issue now and I would like to know if it is software or hardware issue before buying or replacing the card.

    DXDIAG log Pastebin link: https://pastebin.com/LpzqEepz
    HWiNFO log Pastebin link: https://pastebin.com/yyzmjhAB
     
  2. dudecat64

    dudecat64 Ancient Guru

    Messages:
    3,737
    Likes Received:
    5
    GPU:
    Zotac 1060 6gb mini
    Did you try different drivers? I am thinking maybe newer drivers are not setting well with the older cards. I had similar issues with my rx470 but mine would install. Run benchmarks fine but then crash during games. I got a different card and no more crashing. Not sure what all was causing it but i believe it might be bricked drivers maybe.
     
  3. Caesar

    Caesar Master Guru

    Messages:
    241
    Likes Received:
    36
    GPU:
    GTX 1070Ti Titanium
    1. Try running fortnite in Compatibity Mode ( right click on Game .exe)

    else

    2.
    Download: STABLE DRIVER (do not install yet)
    Disconnect from Internet
    Go to device manager> Right click on Microsoft display Adapter> Uninstall (also tick the delete drivers)
    -Install the above downloaded driver-

    else: Checked your BIOS, HAS NOT BEEN UPDATED :
    I do not know which revision your mobo is but is not updated! [last resort]
    3.
    GIGABYTE 970A-DS3P Rev 1.0 : https://www.gigabyte.com/Motherboard/GA-970A-DS3P-rev-10#support-dl-bios
    GIGABYTE 970A-DS3P Rev 2.0 : https://www.gigabyte.com/Motherboard/GA-970A-DS3P-rev-2x#support-dl-bios
     
  4. Fox2232

    Fox2232 Ancient Guru

    Messages:
    7,573
    Likes Received:
    903
    GPU:
    -NDA +AW@240Hz
    Downclock GPU and VRAM. Maybe voltage is not sufficient for given clock.\
    Check your temperatures. R7 260 is old enough for TIM between GPU and cooler to be dry or pushed away by uneven pressure.
    Run Memory Diagnostics for system RAM. Then run Memory Diagnostics for VRAM.
     

  5. Only Intruder

    Only Intruder Master Guru

    Messages:
    955
    Likes Received:
    64
    GPU:
    Sapphire Fury Nitro
    Definitely do as Fox has suggested, my mate had a 260X and he started having thermal issues, overheating and BSODs with it, turned out the thermal paste had completely dried. He cleaned out out the fansink and reapplied some MX-4 paste and it returned to normal. He had since upgraded his GPU to a 580 but he gave his 260X to his dad and it's still in good working order.
     

Share This Page