Driver 418.91 419.17 cuts / skip sound after long idle!

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by crashburn162, Feb 25, 2019.

  1. crashburn162

    crashburn162 Active Member

    Messages:
    55
    Likes Received:
    4
    GPU:
    MSI 1080 Ti Wc
    Hi,

    So after I updated to 418.91 I had problem my sound is connected via AVR with HDMI to my 1080 Ti and so far had no problem. After I updated the drivers I saw there is a new HD Audio driver 1.3.38.13 the problem is after a long idle time my AVR shuts off or I shut it off doesn't matter after that when I start using the PC again the sound cuts for 1 second in 2-3 second intervals and my AVR is loosing connection or it so indicates. I've rolled back to the old driver which is on the 417.22 drivers and the problem is gone. So I don't know why but something is wrong with the driver. I have friend with the same setup different AVR and he has the same problem as me after he updated to one of the new drivers. I can confirm that both 418.91 and 419.17 have this problem since they both use the new HD audio driver. I hope there is a fix for this. I have also tried the new driver on my HTPC setup which is with different AVR Yamaha RX-A2050 and it's the same story there. I've also tried to rollback the audio driver only, didn't work. The other thing i've tried is going to regedit Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0000\PowerSettings and setting the settings to start with 00 , which eleminates the cutting of signal between different audio content like switching from DTS to Stereo, but this doesn't help also. So I am open to suggestions.

    Update: I've tried a Workaround is to install the previous Audio Driver which is 1.3.38.4 you have to uninstall the Nvidia driver from control panel and then after restart manualy put in the old driver also I turned off the internet so windows doesn't update it but the problem is still there.

    Update2: So the fix for now is from advanced settings if I set it to 24 bit 48000hz it's fine, before it was at 24 bit 96000hz which is the max for my speakers but changing it to 96000hz is what causes the problem.
     
    Last edited: Feb 25, 2019
  2. crashburn162

    crashburn162 Active Member

    Messages:
    55
    Likes Received:
    4
    GPU:
    MSI 1080 Ti Wc
    So after some more testing the method I described switching to 24bit 48000hz works sometimes it's not constant so open up for suggestions :)
     
  3. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,984
    Likes Received:
    331
    GPU:
    RTX 2080 OC
    Sometimes there's no audio input being shown on my AVR after some idle time - this doesn't mean that anything has shut off as if you just start some audio on your PC it will get back and play normally. Seems like the driver disables audio output if there's no audio being sent through it for some time. Don't see any issue with it.
     
  4. crashburn162

    crashburn162 Active Member

    Messages:
    55
    Likes Received:
    4
    GPU:
    MSI 1080 Ti Wc
    After idle when you start to play something the audio shuts off for 1 second and comes back like skipping in that 1 second the AVR is blinking like the input is being disconnected and connected again. This occurs every 2-3 second after idle the only way to fix it is to restart the pc or log out and log back in. So yes there is a problem if your audio keeps skipping 1 second every 2-3 seconds :)
     

  5. crashburn162

    crashburn162 Active Member

    Messages:
    55
    Likes Received:
    4
    GPU:
    MSI 1080 Ti Wc
    Ok after few hours of testing this is what I came up with.
    1.Stop internet connection
    2.Uninstall Nvidia HD Audio driver from control panel
    3.Remove the driver from Device Manager under audio.
    4.Stop windows updates through Destroy Windows 10 Spying tool so it won't update itself again. ( https://github.com/Nummer/Destroy-Windows-10-Spying/releases )
    4.Restart

    After these steps you get "High Definition Audio Device" which is some kind of windows drivers so far it works after 2-3 idles with this. I've also disabled Windows updates via Destroy Windows 10 Spying tool so It won't update itself to the nvidia one. It works so far for both my machines.
     
  6. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,362
    Likes Received:
    194
    GPU:
    MSI 970 Gaming 4G
    I don't have an answer to your issue but if you do a clean install of NV drivers and only select the graphic drivers, no NV audio, that should give you windows driver.
    Are you saying windows try to install NV audio even after the windows audio is installed?
     
  7. crashburn162

    crashburn162 Active Member

    Messages:
    55
    Likes Received:
    4
    GPU:
    MSI 1080 Ti Wc
    Yes if you are doing an install it will work this way. For the windows on one machine after 1 restart it updated itself to NV driver on the other it didn't that's why I just blocked the updates untill Nvidia fixes whatever is wrong :) But Windows driver does work yes.
     
  8. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,984
    Likes Received:
    331
    GPU:
    RTX 2080 OC
    Hm, I don't have such issue. It's true that it takes a second for audio to start playing from this "standby" state but it plays fine after that here. I use either 44100/24 or 48000/24 depending on if my TV connected through AVR is on or not.
     
  9. Chastity

    Chastity Ancient Guru

    Messages:
    2,091
    Likes Received:
    530
    GPU:
    Nitro 390/GTX1070M
    You can also use DDU to disable driver updates.
     
  10. adolfotregosa

    adolfotregosa Member

    Messages:
    49
    Likes Received:
    0

  11. crashburn162

    crashburn162 Active Member

    Messages:
    55
    Likes Received:
    4
    GPU:
    MSI 1080 Ti Wc
    That is somewhat different, from what I read is that the AVR is switching through dacs while changing content like DTS to stereo and so on or even when you pause something for a while and then you can physically hear the dac switching off. This is fixed with the registry but the problem I have is something to do with the drivers since it happens to 1080Ti, 950, GTX 770 . The moment I roll back the drivers it's ok. For now the windows drivers work, after long idle the first 20-30 seconds it's skipping sound and then it fixes it self, if I put the Nvidia ones I have to logout or restart to fix it.
     
  12. adolfotregosa

    adolfotregosa Member

    Messages:
    49
    Likes Received:
    0
    To me it seams the same thing, some kind of power saving mode kicking in and the AVR responds by going to some default state, mine noticeably goes to stereo from 5.1 and each time something is played it changes back to 5.1 but of course the delay has to happen. Your case still seams like some power saving is happening.
     
  13. Denissimo

    Denissimo New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    GTX690, 4GB (2GB+2GB)
    I'm also experiencing issues with HD Audio driver 1.3.38.13 that comes with NVIDIA graphics drivers. An AV is connected to GTX 980ti through HDMI, and thus uses this driver for audio, and the issue is terrible crackling during playback/pauses/going fullscreen, etc., mostly on Atmos/DTS:X tracks, but also during youtube or windows sounds sometimes. Multiple tips didn't work for me, including that registry fix for the "silent stream bug". What works for me is uninstalling the audio driver for the NVIDIA High Definition Audio device from the device manager, andmanually selecting the other Windows HD audio driver, dated 14-Sep-18, driver version 10.0.17763. After this the device in the device manager does not have "NVIDIA" in the name, but works OK, without any crackling/static noise in all scenarios. Due to this, I have to skip installation of that faulty HD Audio driver 1.3.38.13 during every graphics diver update. I hope NVIDIA will address this and finally update their HD audio driver, which has not been updated for a while now.
    Also, If I go to the properties of the audio device in Windows sound devices, on the Supported Formats tab, the info is a bit different depending on the audio driver installed: with the older audio driver mentioned above (that does not cause crackling), there is additional bit depth (20 in addition to 16 and 24), and Atmos in the list of supported sound format is listed as Dolby Atmos (Dolby Digital Plus), Dolby Atmos (Dolby MAT 2.0), and Dolby Atmos (Dolby MAT 2.1), while with newer NVIDIA audio driver, the bit depth lists only 16 and 24, and in list of supported format Atmos is mentioned only on one line (without mentioning its MAT subtypes).
     
  14. Chastity

    Chastity Ancient Guru

    Messages:
    2,091
    Likes Received:
    530
    GPU:
    Nitro 390/GTX1070M
    NV HDMI Audio driver is notorious for latency issues. As you found out, using the MS driver is better.
     
  15. crashburn162

    crashburn162 Active Member

    Messages:
    55
    Likes Received:
    4
    GPU:
    MSI 1080 Ti Wc
    I can confirm that the new driver 419.35 fixes the problem after long idle you still get 2-3 seconds until the sounds is constant but it stops after that. And if you do the registry trick it's instant. So it's fixed for me.
     

  16. alanm

    alanm Ancient Guru

    Messages:
    9,016
    Likes Received:
    1,345
    GPU:
    Asus 2080 Dual OC
    Had this problem a few months ago and resolved it, but it just occurred again recently and forgot the solution. So had to google it all over again and stumbled upon this thread. Now I remember the solution. It was that registry power state idle delay mentioned in OP which needs to be set to 00 00 00 00 for all 3 values. This resolved it for me. I am also on AV receiver w/HDMI audio. It seems to affect Nvidia HDMI audio mostly. Previously, I had tried HDMI audio out from the IGP and no issues there, its just from Nvidia side this problem occurs.
     
  17. janos666

    janos666 Master Guru

    Messages:
    714
    Likes Received:
    64
    GPU:
    MSI GTX1070 SH EK X 8Gb
    I would consider this as a feature rather than a bug since my AVR has an Auto input selection mode which picks an active HDMI first and SPDIF as second (and the TV is also connected to the AVR for things like the built-in Netflix app because the Win10 Store version is a diseaster).
    However, this (the nVidia driver "cutting" the HDMI audio after some idle time) rarely happens. I think it was a bug in some drivers. I remember considering it as a "new feature" but then it stopped "working".
     
  18. crashburn162

    crashburn162 Active Member

    Messages:
    55
    Likes Received:
    4
    GPU:
    MSI 1080 Ti Wc
    So I completely fixed the problem my AVR is Pioneer-VSX-1131 I disabled HDMI CEC and Auto-Standby feature now it works even with Nvidia drivers bad part is I have to remember to switch off the AVR every time I leave the PC but still better than logging out every time.
     

Share This Page