Dragon Age: Inquisition - Mantle Unplayable

Discussion in 'Videocards - AMD Radeon Drivers Section' started by jaju123, Nov 18, 2014.

  1. Tronman

    Tronman Member Guru

    Messages:
    102
    Likes Received:
    0
    GPU:
    XFX 295x2
    Solo what are your load times like with mantle?
     
  2. Meccs

    Meccs Active Member

    Messages:
    72
    Likes Received:
    1
    GPU:
    Radeon RX 480 GAMING X 8G
    I'm not Solo but load times seem a tiny bit longer with Mantle. Not much though, hardly noticeable (I'm running the game on a Evo SSD).
     
  3. solo16

    solo16 Active Member

    Messages:
    67
    Likes Received:
    0
    GPU:
    MSI Gaming X 1080Ti 11G
    i didn't really test dx11 since it's pretty broken for me ...so for mantle the game loading in general is ok...not overly long .....sorry i didn't really timed it ...
     
  4. Tronman

    Tronman Member Guru

    Messages:
    102
    Likes Received:
    0
    GPU:
    XFX 295x2
    Hmm so bizarre I have the game installed on an evo 840 SSD as well and just can't understand what is causing the insane load times. DX11 loads in literally seconds.

    I've tried deleting the mantle pipeline cache so the game would rebuild it but there's no difference. The only thing I can think of is that I installed the game when I was on 14.11.1 betas, then I did a proper clean install of 14.11.2 (used DDU to wipe all traces of previous version). I wonder if that has something to do with it?

    I'm going to reinstall 14.11.2 one last time just to see if that fixes it lol - but from what I've read online it seems to be like a 50/50 issue - some ppl get it and some ppl dont.
     

  5. Toss3

    Toss3 Member Guru

    Messages:
    193
    Likes Received:
    13
    GPU:
    WC Inno3D GTX 980 TI
    It's a mantle issue - it's mentioned in the Guru3D Dragon Age performance benchmar, so it's not just you. Mantle is basically just broken at this point, so use DX11 (mantle gives you worse performance).
     
  6. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    i have no issues with load times on my 940 EVO.

    Is this related to crossfire only?
     
  7. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    It is not broken. It is actually really good.

    I always have pagefile disabled and I have the game installed on a 7200 rpm disk. No long load times to complain.
     
  8. Toss3

    Toss3 Member Guru

    Messages:
    193
    Likes Received:
    13
    GPU:
    WC Inno3D GTX 980 TI
    That doesn't mean anything without a proper benchmark comparing mantle vs dx11. I've done countless comparisons and right now dx11 comes out on top every time. Even Hilbert himself said as much in his VGA Performance review here.

    The load times are also a fair bit longer with mantle (no huge difference, but if you switch to dx11 you notice the difference right away).

    Just save the game - start a log and run around a track for a while, then stop the log - switch API and do the same thing over, and then compare the results. Mantle for me, on a 4770k at 4,3Ghz + 2xSamsung 840 EVO in RAID 0, always ends up performing worse, along with higher and more frequent CPU spikes (stutters).

    Things I've tried:
    -disable pagefile (all disks - reboot - no difference)
    -disable HT (no difference)
    -setting thread.maxprocessorcount and processorcount to 8 or 4 (makes no difference)
    -setting RenderDevice.RenderAheadLimit to -1, 0 or 1 (0 and 1 makes the problem a lot worse, while -1 doesn't seem to have any effect)
    -unparking CPU cores (makes no difference)
    - Turning triplebuffering on an off, with vsync on and off

    Only thing that works is switching to dx11.
     
  9. veggiesaurus

    veggiesaurus Member

    Messages:
    35
    Likes Received:
    0
    GPU:
    GeForce GTS 450
    All we can really say is that it IS awful and unplayable on many people's machines, and it ISN'T on others. Personally, I think that still counts as being broken. It's not clear why it's working on some machines and not others though. I'm pretty bleak that I belong to the broken camp.
     
  10. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    I understand that it could be frustrating dealing with this instead of playing the game. Why dont you just play in DX11 and have fun?

    Btw do you uninstall with DDU or similar software, clear registry, run radeonpro at same time, run msi afterburner, etc? I ask because I dont.
     

  11. veggiesaurus

    veggiesaurus Member

    Messages:
    35
    Likes Received:
    0
    GPU:
    GeForce GTS 450
    +1, game is awesome :D
     
  12. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    it really is, i think sometimes that ill never finish it because its so big.
     
  13. Myzon26

    Myzon26 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    XFX 7950 crossfire
    Mantle seems to run better for me. The only thing that doesn't work as well or better are load times. When I'm loading a save for the first time the game will freeze on the loading screen and the music will stop. After a short while it will unfreeze and load the rest of the way. I tried with dx11 but the framerate seemed to be quite a bit less.
     
  14. Broken Haiku

    Broken Haiku Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    AMD 280x 3GB
    280x here, and Mantle doubles our triples loading times. Game plays well though, but often crashes during loading a new scene.
     

Share This Page