Dragon Age: Inquisition - Mantle Unplayable

Discussion in 'Videocards - AMD Radeon Drivers Section' started by jaju123, Nov 18, 2014.

  1. Tronman

    Tronman Member Guru

    Messages:
    102
    Likes Received:
    0
    GPU:
    XFX 295x2
    So I've done some more testing on my 295x2 running 14.11.2 drivers with mantle. I did the testing in Haven when you first get there (the crowd is all lined up outside so it seems to hammer your rig). I've disabled crossfire but the CPU spiking is definitely still there whilst running around Haven. Not only that the but the ridiculous mantle loading times also happen - again it's like my computer almost hangs as audio drops out and screen stops moving but then suddenly it loads.

    In DX11 in haven, CPU usage goes crazy which also causes slight FPS drops but the stutter from spiking is not nearly as perceivable. Mantle definitely limits the crazy CPU fluttering when heaps of NPCs are around it's just the 5 second spikes that need to be addressed. The game doesn't appear to be that taxing as I normally run in DX11 supersampling at a resolution scale of 1.8 (from 1080p) and it is smooth as butter everywhere (even hinterlands) except in towns with hordes of NPCs.

    As someone mentioned before I saw a german website had done benches and noticed the exact same things, apparently bioware supplied them with an unofficial patch so I'm guessing this going to be addressed soon. @AMDMatt are you aware of anymore developments on AMD driver side?
     
  2. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    I dont have any memory leak. Just reduce some settings, especially textures.
     
  3. veggiesaurus

    veggiesaurus Member

    Messages:
    35
    Likes Received:
    0
    GPU:
    GeForce GTS 450
    Yep, putting the textures on high removes the problem. However, mantle still takes an extra 600mb of vram, which is probably where the problem lies in the first place. The stuttering continues with high textures too though.

    I think the point of this thread is that mantle is unplayable for some people on certain settings, while the dx11 build is playable. Turning down settings so that we can use a more efficient api is kind of backward.
     
    Last edited: Nov 22, 2014
  4. AMDMatt

    AMDMatt Master Guru

    Messages:
    466
    Likes Received:
    1
    GPU:
    4x Fury X
    Mantle performance characteristics are the purview of the developer, not the driver, but we're continuing to collaborate on performance optimisations.

    Regarding DX11 14.9.2 is currently the best driver for Dragon Age and as always we'll continue to improve on this in future driver revisions.
     

  5. Ferdimage1

    Ferdimage1 Member Guru

    Messages:
    162
    Likes Received:
    3
    GPU:
    Gigabyte RTX 2080
    14.11.1 is the best driver for my CF & mantle setup.
    14.11.2 on mantle would crash the game before it even starts.
     
  6. crz

    crz Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 ARMOR 8G
    Using Mantle CF I played the game continuously for 6+ hours yesterday with Alt - Tabs to other stuff or to take a break. Not a single crash and only minor stuttering in the Hinterlands. The key seems to be to reduce video memory usage by dropping texture quality (Fade Touched seems to be extreme and to require more than 4 GB VRAM) and to drop MSAA from 4x to 2x. This game seems to use way VRAM more than BF4, and even if the console command displays 3.6 GB usage, it will stutter.

    As for DX11 CF compared to Mantle it is pure s**t just like in BF4: uneven frame times and sudden FPS drops.

    There is also stuttering during cinematics even though the framerate stays at a steady 30 FPS, but this seems to be a game engine thing.
     
  7. jaju123

    jaju123 Master Guru

    Messages:
    356
    Likes Received:
    3
    GPU:
    2x AMD R9 290 Crossfire
    [​IMG]


    This is with textures on high and MSAA x2... completely unplayable. Turning MSAA off doesn't help either, but I guess I am at 1440P.

    BF4, however, is perfectly fine. So it's not my system.
     
  8. ravaged

    ravaged Member Guru

    Messages:
    196
    Likes Received:
    0
    GPU:
    G1 970 SLI
    I tried it again to see if anything changed after the latest drivers and nope. Game takes 2-3 times longer to start up and load into areas. FPS is incredibly unstable and not great even at peak. My afterburner overlay doesn't work so I can't give you any solid numbers without fiddling with my setup, but it's bad and I'm not going to use it so I won't bother.

    Again, this probably sounds like an indictment (and maybe it is -- for the implementation in this game) but DX11 works fine and I'm happy with it. First attempt at using mantle... I trust it works better with other games. Although I'm upgrading in a week or two and probably won't be running into the setting again anytime soon.
     
  9. Meccs

    Meccs Active Member

    Messages:
    69
    Likes Received:
    1
    GPU:
    Radeon RX 480 GAMING X 8G
    Dragon Age runs better with Mantle (Max/Min 86/68 vs Dx 70/40) but I have severe frame drops from time to time. It runs at a stable 60 and then suddenly down to 30 for a second. It stutters like it's loading something but I have the game on an SSD and it doesn't happen under DirectX. Probably the CPU spikes the OP is talking about. As others have said, BF4 had the same "Mantle" problem for a while.

    Also do you guys run the game with Vsync on or off?
     
    Last edited: Nov 23, 2014
  10. crz

    crz Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 ARMOR 8G
    VSync off, with VSync on all Frostbite games have input lag.

    @jaju123: strange that you have such low VRAM usage and yet it stutters. I have Motion Blur and Post-process AA, but that shouldn't have such a big impact. You could also try to disable Origin in game overlay if you didn't do it already.
     

  11. Meccs

    Meccs Active Member

    Messages:
    69
    Likes Received:
    1
    GPU:
    Radeon RX 480 GAMING X 8G
    DA:I has way more tearing than other games for me. Do you guys get used to it or what? I heard people run games in borderless window but I have some jittering every 10 seconds or so when not in fullscreen mode.

    I have a constant 60 frames but the frame drops and the other stuff annoys me to no end currently.
     
  12. BrianJ_64

    BrianJ_64 Member

    Messages:
    46
    Likes Received:
    0
    GPU:
    MSI GTX 970 Gaming 4G
    For me Mantle makes the game get stuck on loading screens.
     
  13. rogue221979

    rogue221979 Master Guru

    Messages:
    625
    Likes Received:
    4
    GPU:
    Gigabyte 2070 GTX
    I played for a good 5 hours last night. With DX11 fully maxed at 1920x1080 with 2xaa.

    Other than some blinking textures here and there it played ok.The cut scenes play at 30fps, game play stays a solid 60fps with vsnyc on, with crossfire enabled. Don't mind the input lag, its not a first person shooter and I use tactical view anyway.

    The game did crash but after 5 hours of straight play, it started to stutter then crashed. I'll try mantle, and also try running a single GPU as well just to see if it makes any difference.

    I had MSI afterburner going, it only showed about 4GB of vram being used so I wasn't maxed on it either at my current settings.
     
    Last edited: Nov 23, 2014
  14. crz

    crz Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 ARMOR 8G
    For the tearing to become unnoticeable I need about 85-90 FPS, in BF4 I limit it from the user.cfg file. Or limit the framerate to 60/59 (your refresh rate/one less) but there will be some tearing.

    In the last 2 hours I experimented with DX11 CF and I ended up limiting the framerate to 59. Despite some tearing and some minor lag the game is now smoother than Mantle. Also like rogue221979 says, there are more flickering textures compared to Mantle. I will test some more with Mantle later on.
     
  15. Meccs

    Meccs Active Member

    Messages:
    69
    Likes Received:
    1
    GPU:
    Radeon RX 480 GAMING X 8G
    I have no flickering with Mantle (no CF though, single card). But I agree that locking the FPS to 59/60 feels way "snappier" than Vsync. Although the tearing is quite bad, even with a locked frame rate.

    I tried to play with Mantle again today but I can't. The frame drops are crazy. I walk around and suddenly stuttering, 20 FPS and back to 60. I'll go with DX for now until this is fixed.
     

  16. BrianJ_64

    BrianJ_64 Member

    Messages:
    46
    Likes Received:
    0
    GPU:
    MSI GTX 970 Gaming 4G
    Locking the FPS only causes very bad tearing cutscenes for me(So bad that vertical lines start blurring where there's movement). Actual gameplay i haven't noticed a thing.

    Having a Samsung S24D590L PLS screen that is.
     
  17. Meccs

    Meccs Active Member

    Messages:
    69
    Likes Received:
    1
    GPU:
    Radeon RX 480 GAMING X 8G
    Is there any way to enable triple buffering when using Mantle? It seems Mantle doesn't support it...
     
  18. darkjj

    darkjj Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    XFX R9 280X DD
    RenderDevice.RenderAheadLimit -1

    Yea i know you're gonna say 0 is minimum... Thats the same thing i was thinking when i saw someone posted it. But i thought well it aint gonna hurt me so lets just find out if it really makes any Different. AND IT DID.. At least for me it's a day/night difference. The spikes are not all gone for 100% but its rarely now. I tried every other number before already. ("Doesn't mean it works for everyone"). Give it a shot!
     
    Last edited: Nov 23, 2014
  19. Tronman

    Tronman Member Guru

    Messages:
    102
    Likes Received:
    0
    GPU:
    XFX 295x2
    I think RenderDevice.RenderAheadLimit -1 is just meant to use the default value for the driver, well I'm pretty sure that's what it did in BF4.

    Dunno if this helps other people but in BF4 if you leave in-game vsync on and set the gametime.maxvariablefps to 59.9 it eliminated input lag as well as tearing. I have this in my user.cfg for DA:I and it seems to work.

    It's interesting that people think mantle is eating up so much VRAM, I wonder why there's such a huge difference between that and DX11. I'm downsampling at 1.7 from 1080p in DX11 and it only seems to use roughly 3.5G (I've only got 4GB to play with).
     
  20. solo16

    solo16 Active Member

    Messages:
    66
    Likes Received:
    0
    GPU:
    MSI Gaming X 1080Ti 11G
    Hi,

    I guess there's some problem with the cpu threads not properly utilized. I'm using mantle with user.cfg tweaking HT on 8 cores 7 threads are used so that might be the culprit of it. Also by any chance you're on Borderless windows mode? It's "broken" when used with Mantle. From windows task manager all 8 cores / threads are fully utilized and well balanced.


    I ran the game pretty fine, but sure the games need to be patched for performance.

    This is my in game setting:
    Mesh and Tessellation -- Utlra
    Textures -- Fade Touched
    Grass and Water -- high
    Shadows -- Medium
    Post-processing -- Low (Don't like motion blur)
    AA -- off
    Post AA -- Medium
    AO -- HBAO Full
    Vsync -- On
    Res -- 1080
    Effects -- Ultra

    Pretty steady with Mantle @60FPS sometime will dip to mid-high 50 for a second or two seems like it's loading something

    Hope it helps!!
     

Share This Page